summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-02 08:34:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-02 08:34:24 +0000
commit37ed5accc8bf2bfcb8022b0bbd7b8cb921a724dd (patch)
tree9e9e7acbe9808a1bdee429dd8cb86d61ca3b7ced /xfce-base/xfce-utils
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-37ed5accc8bf2bfcb8022b0bbd7b8cb921a724dd.tar.gz
gentoo-2-37ed5accc8bf2bfcb8022b0bbd7b8cb921a724dd.tar.bz2
gentoo-2-37ed5accc8bf2bfcb8022b0bbd7b8cb921a724dd.zip
Use xfconf.eclass.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce-utils')
-rw-r--r--xfce-base/xfce-utils/ChangeLog6
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild48
2 files changed, 29 insertions, 25 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index b6802d374142..ed653aa4d7d7 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.142 2009/07/27 17:46:12 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.143 2009/08/02 08:34:24 ssuominen Exp $
+
+ 02 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ xfce-utils-4.6.1.ebuild:
+ Use xfconf.eclass.
27 Jul 2009; nixnut <nixnut@gentoo.org> xfce-utils-4.6.1.ebuild:
ppc stable #265587
diff --git a/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild b/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild
index 9464103817ce..2143f40436ec 100644
--- a/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild
+++ b/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild,v 1.9 2009/07/27 17:46:12 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild,v 1.10 2009/08/02 08:34:24 ssuominen Exp $
-EAPI="1"
+EAPI=2
+inherit xfconf
-inherit xfce4
-
-xfce4_core
-
-DESCRIPTION="Collection of utils"
+DESCRIPTION="Collection of utils for Xfce4"
HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="dbus debug +lock"
@@ -17,36 +17,36 @@ RDEPEND="x11-apps/xrdb
x11-libs/libX11
>=dev-libs/glib-2.6:2
>=x11-libs/gtk+-2.10:2
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- >=xfce-base/libxfcegui4-${XFCE_VERSION}
- >=xfce-base/xfconf-${XFCE_VERSION}
- dbus? ( dev-libs/dbus-glib )
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
+ dbus? ( >=dev-libs/dbus-glib-0.70 )
lock? ( || ( x11-misc/xscreensaver
gnome-extra/gnome-screensaver
x11-misc/xlockmore ) )"
DEPEND="${RDEPEND}
- dev-util/intltool"
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
pkg_setup() {
- XFCE_CONFIG+=" $(use_enable dbus) --with-vendor-info=Gentoo"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable dbus)
+ $(use_enable debug)
+ --with-vendor-info=Gentoo"
+ DOCS="AUTHORS ChangeLog NEWS README"
}
src_install() {
- xfce4_src_install
-
+ xfconf_src_install
insinto /usr/share/xfce4
- doins "${FILESDIR}/Gentoo"
-
- dodir /etc/X11/Sessions
- echo startxfce4 > "${D}/etc/X11/Sessions/Xfce4"
- fperms 755 /etc/X11/Sessions/Xfce4
+ doins "${FILESDIR}"/Gentoo || die "doins failed"
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/Xfce4 || die "doexe failed"
}
pkg_postinst() {
- elog
elog "Run Xfce4 from your favourite Display Manager by using"
elog "XSESSION=\"Xfce4\" in /etc/rc.conf"
- elog
}
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"