summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-04-21 04:26:48 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-04-21 04:26:48 +0000
commitc4a52d0d212625bc6f9a294f88eea68548e0b5a6 (patch)
tree43ecec89a0f9648ce0276d01afd209a20561c360 /xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
parentVersion bump for xfce-4.6.1 release, remove old (diff)
downloadgentoo-2-c4a52d0d212625bc6f9a294f88eea68548e0b5a6.tar.gz
gentoo-2-c4a52d0d212625bc6f9a294f88eea68548e0b5a6.tar.bz2
gentoo-2-c4a52d0d212625bc6f9a294f88eea68548e0b5a6.zip
Version bump for xfce-4.6.1 release, remove old
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild')
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
new file mode 100644
index 000000000000..760b50c1ea18
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild,v 1.1 2009/04/21 04:26:48 darkside Exp $
+
+EAPI="1"
+
+inherit xfce4
+
+xfce4_core
+
+DESCRIPTION="Xfce4 settings"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +keyboard libnotify sound"
+
+RDEPEND=">=dev-libs/glib-2.12:2
+ dev-libs/dbus-glib
+ gnome-base/libglade
+ >=x11-libs/gtk+-2.10:2
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libwnck
+ >=x11-base/xorg-server-1.5.3
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ >=xfce-base/libxfcegui4-${XFCE_VERSION}
+ >=xfce-base/xfconf-${XFCE_VERSION}
+ !xfce-base/xfce-mcs-manager
+ !xfce-base/xfce-mcs-plugins
+ >=xfce-extra/exo-0.3.100
+ libnotify? ( x11-libs/libnotify )
+ keyboard? ( x11-libs/libxklavier )
+ sound? ( media-libs/libcanberra )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ x11-proto/inputproto
+ x11-proto/xf86vidmodeproto"
+
+XFCE_CONFIG+=" $(use_enable libnotify) $(use_enable keyboard libxklavier)
+ $(use_enable sound sound-settings) --enable-xcursor"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"