summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-01 22:24:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-01 22:24:07 +0000
commitc7041c6228e57e1c9b184ef187c67ae371427025 (patch)
tree219671e097b5e857d8861a325e35576f1c47f2bb /xfce-base/xfce4-settings
parentModify mirror://xfce - remove mocha.xfce.org because it's naming doesn't comp... (diff)
downloadgentoo-2-c7041c6228e57e1c9b184ef187c67ae371427025.tar.gz
gentoo-2-c7041c6228e57e1c9b184ef187c67ae371427025.tar.bz2
gentoo-2-c7041c6228e57e1c9b184ef187c67ae371427025.zip
Use xfconf.eclass.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce4-settings')
-rw-r--r--xfce-base/xfce4-settings/ChangeLog6
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.6.1-r1.ebuild43
2 files changed, 28 insertions, 21 deletions
diff --git a/xfce-base/xfce4-settings/ChangeLog b/xfce-base/xfce4-settings/ChangeLog
index 641666f0bd54..5c94056d7ec0 100644
--- a/xfce-base/xfce4-settings/ChangeLog
+++ b/xfce-base/xfce4-settings/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/xfce4-settings
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.15 2009/07/27 17:48:01 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.16 2009/08/01 22:24:07 ssuominen Exp $
+
+ 01 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-settings-4.6.1-r1.ebuild:
+ Use xfconf.eclass.
27 Jul 2009; nixnut <nixnut@gentoo.org> xfce4-settings-4.6.1.ebuild:
ppc stable #265587
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.6.1-r1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.6.1-r1.ebuild
index 2b07dccf4e22..fe265b29b24b 100644
--- a/xfce-base/xfce4-settings/xfce4-settings-4.6.1-r1.ebuild
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.6.1-r1.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.1-r1.ebuild,v 1.1 2009/07/20 09:11:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.1-r1.ebuild,v 1.2 2009/08/01 22:24:07 ssuominen Exp $
-EAPI=1
-inherit eutils xfce4
+EAPI=2
+inherit xfconf
-xfce4_core
+DESCRIPTION="Settings daemon for Xfce4"
+HOMEPAGE="http://www.xfce.org"
-DESCRIPTION="Xfce4 settings"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug +keyboard libnotify sound"
@@ -21,28 +23,29 @@ RDEPEND=">=dev-libs/glib-2.12:2
x11-libs/libXrandr
x11-libs/libwnck
>=x11-base/xorg-server-1.5.3
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- >=xfce-base/libxfcegui4-${XFCE_VERSION}
- >=xfce-base/xfconf-${XFCE_VERSION}
- !xfce-base/xfce-mcs-manager
- !xfce-base/xfce-mcs-plugins
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
>=xfce-extra/exo-0.3.100
libnotify? ( x11-libs/libnotify )
keyboard? ( >=x11-libs/libxklavier-4 )
sound? ( media-libs/libcanberra )"
DEPEND="${RDEPEND}
dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig
x11-proto/inputproto
- x11-proto/xf86vidmodeproto"
+ x11-proto/xf86vidmodeproto
+ !xfce-base/xfce-mcs-manager
+ !xfce-base/xfce-mcs-plugins"
pkg_setup() {
- XFCE_CONFIG+=" $(use_enable libnotify) $(use_enable keyboard libxklavier)
- $(use_enable sound sound-settings) --enable-xcursor"
- DOCS="AUTHORS ChangeLog NEWS README TODO"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-libxklavier.patch
+ XFCONF="--disable-dependency-tracking
+ $(use_enable libnotify)
+ --enable-xcursor
+ $(use_enable keyboard libxklavier)
+ $(use_enable sound sound-settings)
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+ PATCHES=( "${FILESDIR}/${P}-libxklavier.patch" )
}