summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-12-11 04:00:52 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-12-11 04:00:52 +0000
commit3cd239641d5be137155ae63c845a4960a01cee48 (patch)
treea13353d4ba77f3a6f4588ef24184b508a213f6e8 /xfce-base
parentPull in python when USE=python #157787. (diff)
downloadgentoo-2-3cd239641d5be137155ae63c845a4960a01cee48.tar.gz
gentoo-2-3cd239641d5be137155ae63c845a4960a01cee48.tar.bz2
gentoo-2-3cd239641d5be137155ae63c845a4960a01cee48.zip
Fleshed out and cleaned up dependencies. Added use flags for freetype, exif, jpeg, and pcre. Added doc use flag, for bug #157315.
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog9
-rw-r--r--xfce-base/thunar/files/digest-thunar-0.5.0_rc2-r13
-rw-r--r--xfce-base/thunar/thunar-0.5.0_rc2-r1.ebuild77
3 files changed, 88 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 749ec466cc9f..402732ab4d4d 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.7 2006/12/07 02:49:37 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.8 2006/12/11 04:00:52 nichoj Exp $
+
+*thunar-0.5.0_rc2-r1 (11 Dec 2006)
+
+ 11 Dec 2006; Joshua Nichols <nichoj@gentoo.org>
+ +thunar-0.5.0_rc2-r1.ebuild:
+ Fleshed out and cleaned up dependencies. Added use flags for freetype, exif,
+ jpeg, and pcre. Added doc use flag, for bug #157315.
07 Dec 2006; Joshua Nichols <nichoj@gentoo.org>
-thunar-0.3.0_beta1.ebuild, -thunar-0.3.2_beta2.ebuild:
diff --git a/xfce-base/thunar/files/digest-thunar-0.5.0_rc2-r1 b/xfce-base/thunar/files/digest-thunar-0.5.0_rc2-r1
new file mode 100644
index 000000000000..5235171cba6f
--- /dev/null
+++ b/xfce-base/thunar/files/digest-thunar-0.5.0_rc2-r1
@@ -0,0 +1,3 @@
+MD5 c97f6a011eb72b8653ad799290c71d52 Thunar-0.5.0rc2.tar.bz2 1832838
+RMD160 243d353cc64912cc30df1d44f2470baed9713284 Thunar-0.5.0rc2.tar.bz2 1832838
+SHA256 019b937e1cdbc3d554eea4230e10351355316dc4a3ffb65eaf0a927351e780cd Thunar-0.5.0rc2.tar.bz2 1832838
diff --git a/xfce-base/thunar/thunar-0.5.0_rc2-r1.ebuild b/xfce-base/thunar/thunar-0.5.0_rc2-r1.ebuild
new file mode 100644
index 000000000000..20b6aa84ab8c
--- /dev/null
+++ b/xfce-base/thunar/thunar-0.5.0_rc2-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.5.0_rc2-r1.ebuild,v 1.1 2006/12/11 04:00:52 nichoj Exp $
+
+inherit xfce44 versionator
+
+
+MY_PN="Thunar"
+MY_PV="$(replace_version_separator 3 '')"
+MY_P="${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+xfce44_beta
+xfce44_extra_package # technically, it's core, but in terms of what the eclass
+ # does, it's more akin to 'extra' -nichoj
+
+DESCRIPTION="Xfce 4 file manager"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc dbus exif freetype hal jpeg pcre startup-notification thumbnail xslt"
+
+# The order of RDEPEND is based on the list in README, by:
+# required packages
+# required packages not listed in README
+# optional packages
+# optional packages not listed
+RDEPEND="
+ >=dev-lang/perl-5.6
+ >=x11-libs/gtk+-2.6.4
+ >=dev-libs/glib-2.6.4
+ >=xfce-extra/exo-0.3.1.12_rc2
+ >=dev-util/intltool-0.30
+ >=media-libs/libpng-1.2.0
+ >=x11-misc/shared-mime-info-0.15
+ >=dev-util/desktop-file-utils-0.10
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ virtual/fam
+ doc? ( >=dev-util/gtk-doc-1 )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) )
+ )
+ hal? ( >=sys-apps/hal-0.5
+ || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) )
+ )
+ freetype? ( >=media-libs/freetype-2.0 )
+ thumbnail? ( >=gnome-base/gconf-2.4 )
+ exif? ( >=media-libs/libexif-0.6 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ pcre? ( >=dev-libs/libpcre-6.0 )
+ xslt? ( dev-libs/libxslt )
+ "
+
+DEPEND="${RDEPEND}
+ || ( x11-proto/xproto virtual/x11 )"
+
+# TODO report upstream:
+# --enable/disable for jpeg
+# --enable/disable for freetype
+XFCE_CONFIG="
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable exif) \
+ $(use_enable pcre) \
+ $(use_enable startup-notification) \
+ $(use_enable thumbnail gnome-thumbnailers) \
+ $(use_enable xslt xsltproc) \
+ "
+
+if use hal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=hal"
+else
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
+fi