summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-05 16:31:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-05 16:31:21 +0000
commite417b4394b7ec9575597bbe682d683ecae680430 (patch)
tree550d5c9e2231814d42e5367f8be1fe6c6d03b1f0 /xfce-base
parentold (diff)
downloadgentoo-2-e417b4394b7ec9575597bbe682d683ecae680430.tar.gz
gentoo-2-e417b4394b7ec9575597bbe682d683ecae680430.tar.bz2
gentoo-2-e417b4394b7ec9575597bbe682d683ecae680430.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4util/ChangeLog11
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild32
2 files changed, 40 insertions, 3 deletions
diff --git a/xfce-base/libxfce4util/ChangeLog b/xfce-base/libxfce4util/ChangeLog
index efaa5175ae0d..c9663770c103 100644
--- a/xfce-base/libxfce4util/ChangeLog
+++ b/xfce-base/libxfce4util/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/libxfce4util
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4util/ChangeLog,v 1.184 2012/11/28 12:28:12 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4util/ChangeLog,v 1.185 2013/05/05 16:31:21 ssuominen Exp $
+
+*libxfce4util-4.10.1 (05 May 2013)
+
+ 05 May 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +libxfce4util-4.10.1.ebuild:
+ Version bump.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
libxfce4util-4.10.0.ebuild:
@@ -712,4 +718,3 @@
13 Jun 2003; Brad Cowan <bcowan@gentoo.org> libxfce4util-3.90.0.ebuild:
Initial import.
-
diff --git a/xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild b/xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild
new file mode 100644
index 000000000000..0aaac3bd786f
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild,v 1.1 2013/05/05 16:31:21 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}