summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-07 13:05:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-07 13:05:08 +0000
commit3f5e5f282afc74c210021ffc6d6bba1bb236de3c (patch)
treef4e8b8e44e285132f8120188ddfd2366bcffd188 /xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.9.ebuild
parentUpdate init script to better handle x32 containers. (diff)
downloadgentoo-2-3f5e5f282afc74c210021ffc6d6bba1bb236de3c.tar.gz
gentoo-2-3f5e5f282afc74c210021ffc6d6bba1bb236de3c.tar.bz2
gentoo-2-3f5e5f282afc74c210021ffc6d6bba1bb236de3c.zip
Version bump wrt #419683 by Michael Orlitzky
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.9.ebuild')
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.9.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.9.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.9.ebuild
new file mode 100644
index 000000000000..e34f08183729
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.9.ebuild,v 1.1 2012/06/07 13:05:08 ssuominen Exp $
+
+EAPI=4
+inherit linux-info xfconf
+
+DESCRIPTION="A plugin to indicate the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.php"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8"
+RDEPEND="${COMMON_DEPEND}
+ >=app-laptop/hdapsd-20090101
+ >=app-laptop/tp_smapi-0.39"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog README TODO )
+
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 28; then
+ echo
+ ewarn "Unsupported kernel detected. Upgrade to 2.6.28 or above."
+ echo
+ fi
+}