summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-07 01:38:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-07 01:38:15 +0000
commitaffe4a02b30ebff304135d11283b773a3110033a (patch)
treedafd3cae4e47b53dc87e43f3c56bdcfdf1de00f6 /xfce-extra/xfce4-hdaps
parentcompilefix >=vdr-1.7.27 (diff)
downloadgentoo-2-affe4a02b30ebff304135d11283b773a3110033a.tar.gz
gentoo-2-affe4a02b30ebff304135d11283b773a3110033a.tar.bz2
gentoo-2-affe4a02b30ebff304135d11283b773a3110033a.zip
Version bump.
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-hdaps')
-rw-r--r--xfce-extra/xfce4-hdaps/ChangeLog10
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.8.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-hdaps/ChangeLog b/xfce-extra/xfce4-hdaps/ChangeLog
index a360fc4e5f0f..4fc7333ca611 100644
--- a/xfce-extra/xfce4-hdaps/ChangeLog
+++ b/xfce-extra/xfce4-hdaps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-hdaps
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/ChangeLog,v 1.7 2011/05/20 11:21:23 tomka Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/ChangeLog,v 1.8 2012/04/07 01:38:15 ssuominen Exp $
+
+*xfce4-hdaps-0.0.8 (07 Apr 2012)
+
+ 07 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-hdaps-0.0.8.ebuild:
+ Version bump.
20 May 2011; Thomas Kahle <tomka@gentoo.org> xfce4-hdaps-0.0.7.ebuild:
x86 stable per bug 342239
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.8.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.8.ebuild
new file mode 100644
index 000000000000..b56cc35203c6
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.8.ebuild,v 1.1 2012/04/07 01:38:15 ssuominen Exp $
+
+EAPI=4
+inherit linux-info xfconf
+
+DESCRIPTION="A plugin to indicate the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.php"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8"
+RDEPEND="${COMMON_DEPEND}
+ >=app-laptop/hdapsd-20081213
+ >=app-laptop/tp_smapi-0.39"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-option-checking
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 28; then
+ echo
+ ewarn "Unsupported kernel detected. Upgrade to 2.6.28 or above."
+ echo
+ fi
+}