summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-01-29 19:50:49 +0000
committerPeter Weller <welp@gentoo.org>2007-01-29 19:50:49 +0000
commitd55defae94568f04e17b53b4a4758b1fe1f93ae3 (patch)
tree0549d0e947daa67b33f7066afcfb3ecb619304a8 /xfce-extra
parentAdded missing part of changelog. (diff)
downloadgentoo-2-d55defae94568f04e17b53b4a4758b1fe1f93ae3.tar.gz
gentoo-2-d55defae94568f04e17b53b4a4758b1fe1f93ae3.tar.bz2
gentoo-2-d55defae94568f04e17b53b4a4758b1fe1f93ae3.zip
A number of fixes, patch to make it work on gentoo/freebsd
(Portage version: 2.1.2-r5)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-battery/ChangeLog6
-rw-r--r--xfce-extra/xfce4-battery/files/xfce4-battery-0.5.0-freebsd.patch32
-rw-r--r--xfce-extra/xfce4-battery/xfce4-battery-0.5.0.ebuild12
3 files changed, 46 insertions, 4 deletions
diff --git a/xfce-extra/xfce4-battery/ChangeLog b/xfce-extra/xfce4-battery/ChangeLog
index 54b774b4f40a..8a464bb1c85e 100644
--- a/xfce-extra/xfce4-battery/ChangeLog
+++ b/xfce-extra/xfce4-battery/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/xfce4-battery
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery/ChangeLog,v 1.37 2007/01/23 21:24:24 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery/ChangeLog,v 1.38 2007/01/29 19:50:49 welp Exp $
+
+ 29 Jan 2007; Peter Weller <welp@gentoo.org>
+ +files/xfce4-battery-0.5.0-freebsd.patch, xfce4-battery-0.5.0.ebuild:
+ A number of fixes, patch to make it work on gentoo/freebsd
23 Jan 2007; Peter Weller <welp@gentoo.org> xfce4-battery-0.5.0.ebuild:
Fix depends for bug 163244. Fix meta builds.
diff --git a/xfce-extra/xfce4-battery/files/xfce4-battery-0.5.0-freebsd.patch b/xfce-extra/xfce4-battery/files/xfce4-battery-0.5.0-freebsd.patch
new file mode 100644
index 000000000000..b4644fef4b3e
--- /dev/null
+++ b/xfce-extra/xfce4-battery/files/xfce4-battery-0.5.0-freebsd.patch
@@ -0,0 +1,32 @@
+--- panel-plugin/battery.c.orig Wed Jan 24 20:42:09 2007
++++ panel-plugin/battery.c Wed Jan 24 20:46:51 2007
+@@ -378,6 +378,7 @@
+ rate = last_rate;
+ }
+
++#ifdef __linux__
+ charge = (((float)ccapacity)/((float)lcapacity))*100;
+
+ if ( last_acline )
+@@ -389,6 +390,20 @@
+ time_remaining = 0;
+
+ last_acline = acline;
++
++#elif __FreeBSD__
++ charge = acpistate->percentage;
++
++ if ( last_acline )
++ time_remaining = acpistate->rtime;
++ else
++ time_remaining = acpistate->rtime;
++
++ if ( time_remaining < 0 )
++ time_remaining = 0;
++
++ last_acline = acline;
++#endif
+
+ }
+ #ifdef __linux__
+
diff --git a/xfce-extra/xfce4-battery/xfce4-battery-0.5.0.ebuild b/xfce-extra/xfce4-battery/xfce4-battery-0.5.0.ebuild
index a0ac094fb34e..98306ebcb7d0 100644
--- a/xfce-extra/xfce4-battery/xfce4-battery-0.5.0.ebuild
+++ b/xfce-extra/xfce4-battery/xfce4-battery-0.5.0.ebuild
@@ -1,15 +1,21 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery/xfce4-battery-0.5.0.ebuild,v 1.2 2007/01/23 21:24:24 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery/xfce4-battery-0.5.0.ebuild,v 1.3 2007/01/29 19:50:49 welp Exp $
-inherit xfce44
+inherit eutils xfce44
xfce44_beta
xfce44_goodies_panel_plugin
-DESCRIPTION="Xfce4 battery status panel plugin"
+DESCRIPTION="Battery status panel plugin"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug"
DEPEND="dev-util/intltool"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-freebsd.patch"
+}