summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-28 22:16:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-28 22:16:59 +0000
commitea0526ca73f646322656c5c631bfde4735fbf31a (patch)
tree31c518e15de126dee982f22fc8e62c4a4ee331b3 /xfce-extra
parentAdd more envvar cleanup to src_test, bug #246136. Clean up revisions. (diff)
downloadgentoo-2-ea0526ca73f646322656c5c631bfde4735fbf31a.tar.gz
gentoo-2-ea0526ca73f646322656c5c631bfde4735fbf31a.tar.bz2
gentoo-2-ea0526ca73f646322656c5c631bfde4735fbf31a.zip
Fix configure.in to detect >=exo-0.5.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-media-tags-plugin/ChangeLog7
-rw-r--r--xfce-extra/thunar-media-tags-plugin/files/thunar-media-tags-plugin-0.1.2-exo.patch13
-rw-r--r--xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2.ebuild4
3 files changed, 22 insertions, 2 deletions
diff --git a/xfce-extra/thunar-media-tags-plugin/ChangeLog b/xfce-extra/thunar-media-tags-plugin/ChangeLog
index 1a9a65ffb5f9..6c96c6c7d643 100644
--- a/xfce-extra/thunar-media-tags-plugin/ChangeLog
+++ b/xfce-extra/thunar-media-tags-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/thunar-media-tags-plugin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-media-tags-plugin/ChangeLog,v 1.2 2009/10/08 17:19:41 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-media-tags-plugin/ChangeLog,v 1.3 2009/10/28 22:16:59 ssuominen Exp $
+
+ 28 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ thunar-media-tags-plugin-0.1.2.ebuild,
+ +files/thunar-media-tags-plugin-0.1.2-exo.patch:
+ Fix configure.in to detect >=exo-0.5.
08 Oct 2009; Jeremy Olexa <darkside@gentoo.org>
thunar-media-tags-plugin-0.1.2.ebuild:
diff --git a/xfce-extra/thunar-media-tags-plugin/files/thunar-media-tags-plugin-0.1.2-exo.patch b/xfce-extra/thunar-media-tags-plugin/files/thunar-media-tags-plugin-0.1.2-exo.patch
new file mode 100644
index 000000000000..880f7dff5fd1
--- /dev/null
+++ b/xfce-extra/thunar-media-tags-plugin/files/thunar-media-tags-plugin-0.1.2-exo.patch
@@ -0,0 +1,13 @@
+diff -ur thunar-media-tags-plugin-0.1.2.orig/configure.in thunar-media-tags-plugin-0.1.2/configure.in
+--- thunar-media-tags-plugin-0.1.2.orig/configure.in 2007-01-20 17:29:39.000000000 +0200
++++ thunar-media-tags-plugin-0.1.2/configure.in 2009-10-29 01:12:19.000000000 +0200
+@@ -64,7 +64,8 @@
+ dnl ***********************************
+ dnl *** Check for required packages ***
+ dnl ***********************************
+-XDT_CHECK_PACKAGE([EXO], [exo-0.3], [0.3.1.3])
++XDT_CHECK_PACKAGE([EXO], [exo-0.3], [0.3.1.3], [],
++ [XDT_CHECK_PACKAGE([EXO], [exo-1], [0.5.0])])
+ XDT_CHECK_PACKAGE([THUNARX], [thunarx-1], [0.2.3svn-r20526])
+ XDT_CHECK_PACKAGE([THUNARVFS], [thunar-vfs-1], [0.2.3svn-r20526])
+ XDT_CHECK_PACKAGE([TAGLIB], [taglib], [1.4])
diff --git a/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2.ebuild b/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2.ebuild
index 7ce7fef561d6..c94a829d981b 100644
--- a/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2.ebuild
+++ b/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2.ebuild,v 1.2 2009/10/08 17:19:41 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2.ebuild,v 1.3 2009/10/28 22:16:59 ssuominen Exp $
EAPI=2
+EAUTORECONF=yes
inherit xfconf
DESCRIPTION="Thunar media tags plugin"
@@ -24,4 +25,5 @@ pkg_setup() {
DOCS="AUTHORS ChangeLog README TODO"
XFCONF="--disable-dependency-tracking
$(use_enable debug)"
+ PATCHES=( "${FILESDIR}/${P}-exo.patch" )
}