summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/allegro/ChangeLog10
-rw-r--r--media-libs/allegro/Manifest7
-rw-r--r--media-libs/allegro/allegro-4.0.2.ebuild126
-rw-r--r--media-libs/allegro/allegro-4.0.3.ebuild141
-rw-r--r--media-libs/allegro/allegro-4.1.9.ebuild73
-rw-r--r--media-libs/allegro/files/digest-allegro-4.0.21
-rw-r--r--media-libs/allegro/files/digest-allegro-4.1.91
7 files changed, 131 insertions, 228 deletions
diff --git a/media-libs/allegro/ChangeLog b/media-libs/allegro/ChangeLog
index c292c26e6ddf..1faedf3daf12 100644
--- a/media-libs/allegro/ChangeLog
+++ b/media-libs/allegro/ChangeLog
@@ -1,9 +1,17 @@
# ChangeLog for media-libs/allegro
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.10 2003/04/25 13:42:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.11 2003/06/19 18:17:07 vapier Exp $
+
+*allegro-4.1.9 (19 Jun 2003)
+
+ 19 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + cleanup #11148.
*allegro-4.0.3 (25 Apr 2003)
+ 19 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Cleanup + arts USE support #20195.
+
25 Apr 2003; Mike Frysinger <vapier@gentoo.org> :
Version bump.
diff --git a/media-libs/allegro/Manifest b/media-libs/allegro/Manifest
index 861bed92699b..0c172d00e0a3 100644
--- a/media-libs/allegro/Manifest
+++ b/media-libs/allegro/Manifest
@@ -1,4 +1,5 @@
-MD5 d0eb5f156646bcdc93d4c02db6e4982a allegro-4.1.9.ebuild 1929
-MD5 d0eb5f156646bcdc93d4c02db6e4982a allegro-4.0.3.ebuild 1929
-MD5 c90f16d8551022cebbcc631c02b4ef24 files/digest-allegro-4.1.9 66
MD5 9f28e5d796c572eb801998504cf84fbb files/digest-allegro-4.0.3 66
+MD5 c90f16d8551022cebbcc631c02b4ef24 files/digest-allegro-4.1.9 66
+MD5 59fae8ade2fcf7651f6e9ded80fdc1d6 ChangeLog 1933
+MD5 f1ee72e3d74459509187ee99ba171b8a allegro-4.0.3.ebuild 1927
+MD5 dad3947a4258b2bd29bd07fa8b36c530 allegro-4.1.9.ebuild 1929
diff --git a/media-libs/allegro/allegro-4.0.2.ebuild b/media-libs/allegro/allegro-4.0.2.ebuild
deleted file mode 100644
index 505e16360867..000000000000
--- a/media-libs/allegro/allegro-4.0.2.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.2.ebuild,v 1.8 2003/04/25 13:08:16 vapier Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="cross-platform multimedia library"
-SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
-HOMEPAGE="http://alleg.sourceforge.net/"
-
-LICENSE="Allegro"
-SLOT="0"
-KEYWORDS="x86 sparc"
-IUSE="mmx esd static tetex X fbcon oss svga alsa"
-
-RDEPEND="X? ( virtual/x11 )
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- svga? ( media-libs/svgalib )"
-DEPEND="${RDEPEND}
- tetex? ( app-text/tetex )"
-
-src_compile() {
- # Always enable Linux console support and accompanying drivers
- confopts="${confopts} --enable-linux --enable-vga"
-
- # if USE static defined, use static library as default to link with
- use static \
- && confopts="${confopts} --enable-staticprog --enable-static"
-
- # Pentium optimizations
- if [ ${CHOST} = "i586-pc-linux-gnu" -o ${CHOST} = "i686-pc-linux-gnu" ]
- then
- confopts="${confopts} --enable-pentiumopts"
- fi
-
- # Use MMX instructions
- use mmx \
- && confopts="${confopts} --enable-mmx" \
- || confopts="${confopts} --enable-mmx=no"
-
- # Have OSS support
- use oss \
- && confopts="${confopts} --enable-ossdigi --enable-ossmidi" \
- || confopts="${confopts} --disable-ossdigi --disable-ossmidi"
-
- # Have ALSA support
- use alsa \
- && confopts="${confopts} --enable-alsadigi --enable-alsamidi" \
- || confopts="${confopts} --disable-alsadigi --disable-alsamidi"
-
- # Have ESD support
- use esd \
- && confopts="${confopts} --enable-esddigi" \
- || confopts="${confopts} --disable-esddigi"
-
- # Have X11 support
- use X \
- && confopts="${confopts} \
- --with-x \
- --enable-xwin-shm \
- --enable-xwin-vidmode \
- --enable-xwin-dga \
- --enable-xwin-dga2" \
- || confopts="${confopts} \
- --without-x \
- --disable-xwin-shm \
- --disable-xwin-vidmode \
- --disable-xwin-dga \
- --disable-xwin-dga2"
-
- # Have SVGALib support
- use svga \
- && confopts="${confopts} --enable-svgalib" \
- || confopts="${confopts} --disable-svgalib"
-
- # Have fbcon support
- use fbcon \
- && confopts="${confopts} --enable-fbcon" \
- || confopts="${confopts} --disable-fbcon"
-
- # --------------
-
- econf ${confopts} || die
-
- # emake doesn't work
- filter-flags -fPIC
- make CFLAGS="${CFLAGS/-fPIC/}" || die
-
- if use tetex;
- then
- addwrite "/var/lib/texmf"
- addwrite "/usr/share/texmf"
- addwrite "/var/cache/fonts"
- make docs-dvi docs-ps || die
- fi
-
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install install-gzipped-man install-gzipped-info || die
-
- # Different format versions of the Allegro documentation
-
- dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
-
- if use tetex;
- then
- dodoc docs/allegro.dvi docs/allegro.ps
- fi
-
- dohtml docs/html/*
-
- docinto txt
- dodoc docs/txt/*.txt
-
- docinto rtf
- dodoc docs/rtf/*.rtf
-
- docinto build
- dodoc docs/build/*.txt
-}
diff --git a/media-libs/allegro/allegro-4.0.3.ebuild b/media-libs/allegro/allegro-4.0.3.ebuild
index 82104be6dd6e..13362fac22d6 100644
--- a/media-libs/allegro/allegro-4.0.3.ebuild
+++ b/media-libs/allegro/allegro-4.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.1 2003/04/25 13:42:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.2 2003/06/19 18:17:07 vapier Exp $
inherit flag-o-matic
@@ -10,117 +10,64 @@ HOMEPAGE="http://alleg.sourceforge.net/"
LICENSE="Allegro"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
-IUSE="mmx esd static tetex X fbcon oss svga alsa"
+KEYWORDS="x86 sparc"
+IUSE="static mmx sse oss alsa esd arts X fbcon svga tetex"
-RDEPEND="X? ( virtual/x11 )
- alsa? ( media-libs/alsa-lib )
+RDEPEND="alsa? ( media-libs/alsa-lib )
esd? ( media-sound/esound )
+ arts? ( kde-base/arts )
+ X? ( virtual/x11 )
svga? ( media-libs/svgalib )"
DEPEND="${RDEPEND}
tetex? ( app-text/tetex )"
src_compile() {
- # Always enable Linux console support and accompanying drivers
- confopts="${confopts} --enable-linux --enable-vga"
-
- # if USE static defined, use static library as default to link with
- use static \
- && confopts="${confopts} --enable-staticprog --enable-static"
-
- # Pentium optimizations
- if [ ${CHOST} = "i586-pc-linux-gnu" -o ${CHOST} = "i686-pc-linux-gnu" ]
- then
- confopts="${confopts} --enable-pentiumopts"
- fi
-
- # Use MMX instructions
- use mmx \
- && confopts="${confopts} --enable-mmx" \
- || confopts="${confopts} --enable-mmx=no"
-
- # Have OSS support
- use oss \
- && confopts="${confopts} --enable-ossdigi --enable-ossmidi" \
- || confopts="${confopts} --disable-ossdigi --disable-ossmidi"
-
- # Have ALSA support
- use alsa \
- && confopts="${confopts} --enable-alsadigi --enable-alsamidi" \
- || confopts="${confopts} --disable-alsadigi --disable-alsamidi"
-
- # Have ESD support
- use esd \
- && confopts="${confopts} --enable-esddigi" \
- || confopts="${confopts} --disable-esddigi"
-
- # Have X11 support
- use X \
- && confopts="${confopts} \
- --with-x \
- --enable-xwin-shm \
- --enable-xwin-vidmode \
- --enable-xwin-dga \
- --enable-xwin-dga2" \
- || confopts="${confopts} \
- --without-x \
- --disable-xwin-shm \
- --disable-xwin-vidmode \
- --disable-xwin-dga \
- --disable-xwin-dga2"
-
- # Have SVGALib support
- use svga \
- && confopts="${confopts} --enable-svgalib" \
- || confopts="${confopts} --disable-svgalib"
-
- # Have fbcon support
- use fbcon \
- && confopts="${confopts} --enable-fbcon" \
- || confopts="${confopts} --disable-fbcon"
+ filter-flags -fPIC
- # --------------
+ econf \
+ --enable-linux \
+ --enable-vga \
+ `use_enable static` \
+ `use_enable static staticprog` \
+ `use_enable mmx` \
+ `use_enable sse` \
+ `use_enable oss ossdigi` \
+ `use_enable oss ossmidi` \
+ `use_enable alsa alsadigi` \
+ `use_enable alsa alsamidi` \
+ `use_enable esd esddigi` \
+ `use_enable arts artsdigi` \
+ `use_with X x` \
+ `use_enable X xwin-shm` \
+ `use_enable X xwin-vidmode` \
+ `use_enable X xwin-dga` \
+ `use_enable X xwin-dga2` \
+ `use_enable fbcon` \
+ `use_enable svga svgalib` \
+ || die
- econf ${confopts} || die
-
- # emake doesn't work
- filter-flags -fPIC
- make CFLAGS="${CFLAGS/-fPIC/}" || die
-
- if use tetex;
- then
- addwrite "/var/lib/texmf"
- addwrite "/usr/share/texmf"
- addwrite "/var/cache/fonts"
+ cp makefile{,.orig}
+ sed -e "/CFLAGS =.*/s:$: ${CFLAGS}:" \
+ makefile.orig > makefile
+ make || die # emake fails
+
+ if [ `use tetex` ] ; then
+ addwrite /var/lib/texmf
+ addwrite /usr/share/texmf
+ addwrite /var/cache/fonts
make docs-dvi docs-ps || die
fi
-
}
src_install() {
- make \
- prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install install-gzipped-man install-gzipped-info || die
-
- # Different format versions of the Allegro documentation
+ addpredict /usr/share/info
+ make DESTDIR=${D} install install-gzipped-man install-gzipped-info || die
+ # Different format versions of the Allegro documentation
dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
-
- if use tetex;
- then
- dodoc docs/allegro.dvi docs/allegro.ps
- fi
-
+ [ `use tetex` ] && dodoc docs/allegro.{dvi,ps}
dohtml docs/html/*
-
- docinto txt
- dodoc docs/txt/*.txt
-
- docinto rtf
- dodoc docs/rtf/*.rtf
-
- docinto build
- dodoc docs/build/*.txt
+ docinto txt ; dodoc docs/txt/*.txt
+ docinto rtf ; dodoc docs/rtf/*.rtf
+ docinto build ; dodoc docs/build/*.txt
}
diff --git a/media-libs/allegro/allegro-4.1.9.ebuild b/media-libs/allegro/allegro-4.1.9.ebuild
new file mode 100644
index 000000000000..a4769eb62852
--- /dev/null
+++ b/media-libs/allegro/allegro-4.1.9.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.1.9.ebuild,v 1.1 2003/06/19 18:17:07 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="cross-platform multimedia library"
+SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
+HOMEPAGE="http://alleg.sourceforge.net/"
+
+LICENSE="Allegro"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="static mmx sse oss alsa esd arts X fbcon svga tetex"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ arts? ( kde-base/arts )
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )"
+DEPEND="${RDEPEND}
+ tetex? ( app-text/tetex )"
+
+src_compile() {
+ filter-flags -fPIC
+
+ econf \
+ --enable-linux \
+ --enable-vga \
+ `use_enable static` \
+ `use_enable static staticprog` \
+ `use_enable mmx` \
+ `use_enable sse` \
+ `use_enable oss ossdigi` \
+ `use_enable oss ossmidi` \
+ `use_enable alsa alsadigi` \
+ `use_enable alsa alsamidi` \
+ `use_enable esd esddigi` \
+ `use_enable arts artsdigi` \
+ `use_with X x` \
+ `use_enable X xwin-shm` \
+ `use_enable X xwin-vidmode` \
+ `use_enable X xwin-dga` \
+ `use_enable X xwin-dga2` \
+ `use_enable fbcon` \
+ `use_enable svga svgalib` \
+ || die
+
+ cp makefile{,.orig}
+ sed -e "/CFLAGS =.*/s:$: ${CFLAGS}:" \
+ makefile.orig > makefile
+ make || die # emake fails
+
+ if [ `use tetex` ] ; then
+ addwrite /var/lib/texmf
+ addwrite /usr/share/texmf
+ addwrite /var/cache/fonts
+ make docs-dvi docs-ps || die
+ fi
+}
+
+src_install() {
+ addpredict /usr/share/info
+ make DESTDIR=${D} install install-gzipped-man install-gzipped-info || die
+
+ # Different format versions of the Allegro documentation
+ dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
+ [ `use tetex` ] && dodoc docs/allegro.{dvi,ps}
+ dohtml docs/html/*
+ docinto txt ; dodoc docs/txt/*.txt
+ docinto rtf ; dodoc docs/rtf/*.rtf
+ docinto build ; dodoc docs/build/*.txt
+}
diff --git a/media-libs/allegro/files/digest-allegro-4.0.2 b/media-libs/allegro/files/digest-allegro-4.0.2
deleted file mode 100644
index 0712ede593aa..000000000000
--- a/media-libs/allegro/files/digest-allegro-4.0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c9b610c7868d0986dfb3153ca9d12f2a allegro-4.0.2.tar.gz 2398855
diff --git a/media-libs/allegro/files/digest-allegro-4.1.9 b/media-libs/allegro/files/digest-allegro-4.1.9
new file mode 100644
index 000000000000..6ffc17f1401e
--- /dev/null
+++ b/media-libs/allegro/files/digest-allegro-4.1.9
@@ -0,0 +1 @@
+MD5 d4423486f7aed064e10071a19fd06b1e allegro-4.1.9.tar.gz 2567371