summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libmemcached/ChangeLog8
-rw-r--r--dev-libs/libmemcached/libmemcached-0.34-r1.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-libs/libmemcached/ChangeLog b/dev-libs/libmemcached/ChangeLog
index b5708be00147..ce1555840657 100644
--- a/dev-libs/libmemcached/ChangeLog
+++ b/dev-libs/libmemcached/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libmemcached
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.16 2009/10/23 14:12:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.17 2009/10/24 07:53:24 patrick Exp $
+
+*libmemcached-0.34-r1 (24 Oct 2009)
+
+ 24 Oct 2009; Patrick Lauer <patrick@gentoo.org>
+ +libmemcached-0.34-r1.ebuild:
+ eapi2 and small cleanups from Johan Bergstrom
23 Oct 2009; Jeroen Roovers <jer@gentoo.org> libmemcached-0.31.ebuild:
Stable for HPPA (bug #288166).
diff --git a/dev-libs/libmemcached/libmemcached-0.34-r1.ebuild b/dev-libs/libmemcached/libmemcached-0.34-r1.ebuild
new file mode 100644
index 000000000000..0d5d365c1fcc
--- /dev/null
+++ b/dev-libs/libmemcached/libmemcached-0.34-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-0.34-r1.ebuild,v 1.1 2009/10/24 07:53:24 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="a C client library to the memcached server"
+HOMEPAGE="http://tangent.org/552/libmemcached.html"
+SRC_URI="http://download.tangent.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd"
+IUSE="debug hsieh"
+
+DEPEND="net-misc/memcached"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.28-runtestsasuser.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_with debug debug) \
+ $(use_enable hsieh hsieh_hash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
+
+src_test() {
+ cd tests || die "Tests failed"
+ emake testapp testplus library_test || die "Tests failed"
+} \ No newline at end of file