summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/hal/ChangeLog7
-rw-r--r--sys-apps/hal/Manifest4
-rw-r--r--sys-apps/hal/files/digest-hal-0.5.5.11
-rw-r--r--sys-apps/hal/hal-0.5.5.1.ebuild114
4 files changed, 124 insertions, 2 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 18223707e844..99ddd356817d 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.52 2005/11/08 17:25:24 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.53 2005/11/22 01:26:42 compnerd Exp $
+
+*hal-0.5.5.1 (22 Nov 2005)
+
+ 22 Nov 2005; Saleem Abdulrasool <compnerd@gentoo.org> +hal-0.5.5.1.ebuild:
+ Version bumping with upstream. Resolves bug #112881
08 Nov 2005; Saleem Abdulrasool <compnerd@gentoo.org> hal-0.5.4.ebuild:
Fixing the deps for doc building. Resolves bug #108994
diff --git a/sys-apps/hal/Manifest b/sys-apps/hal/Manifest
index 3b2622ca3d8f..bb096f415103 100644
--- a/sys-apps/hal/Manifest
+++ b/sys-apps/hal/Manifest
@@ -1,9 +1,10 @@
-MD5 d64a1aa1fb6c47e26b067ba48869720d ChangeLog 7381
+MD5 073fe245cc82f779db7769b824088641 ChangeLog 7542
MD5 40a7b45f127bfdcacaa142660ad8b5f9 files/0.5-hald.rc 537
MD5 ada3b2801b82813b4f10fd6f6caf9d6f files/digest-hal-0.4.5-r2 62
MD5 3031a9fe74f43859c313d5f3076e68cd files/digest-hal-0.4.7-r2 62
MD5 2bbbb519c89110dfec96cf63cf541afc files/digest-hal-0.4.8 62
MD5 27cab5d91e93d8b692246d0ce4110122 files/digest-hal-0.5.4 62
+MD5 cf6c7a60aee75f95022e5d25562468eb files/digest-hal-0.5.5.1 64
MD5 a0ce1c268e0b7d0967ec7b8e0d0d26d2 files/hal-0.4.1-old_storage_policy.patch 1216
MD5 b0e12a62ce698e1eb2a32139498330cd files/hal-0.4.5-gentoo_gphoto2_usermap.patch 817
MD5 f3ba6ada28cf947f8a7b7ec8fdd708ba files/hal-0.4.5-net_lockup.patch 2429
@@ -20,4 +21,5 @@ MD5 2cf5b3c9219c87b1d9aee01f4f5f19bb hal-0.4.5-r2.ebuild 3118
MD5 1a146b79d18a689bbc8a96b81f74c7f6 hal-0.4.7-r2.ebuild 3455
MD5 8420501e80e55b313d30f4e0309c08dd hal-0.4.8.ebuild 3419
MD5 4b5c3135d20b391903d7a8e2626313dd hal-0.5.4.ebuild 3443
+MD5 83651a0b40fbf2f49cca629f10fbbbe1 hal-0.5.5.1.ebuild 3507
MD5 a60767d83157413d549c69b98fac962c metadata.xml 303
diff --git a/sys-apps/hal/files/digest-hal-0.5.5.1 b/sys-apps/hal/files/digest-hal-0.5.5.1
new file mode 100644
index 000000000000..9dfb57f4441c
--- /dev/null
+++ b/sys-apps/hal/files/digest-hal-0.5.5.1
@@ -0,0 +1 @@
+MD5 2abd81ed3f5a37789f4fbda2f6a61270 hal-0.5.5.1.tar.gz 1517882
diff --git a/sys-apps/hal/hal-0.5.5.1.ebuild b/sys-apps/hal/hal-0.5.5.1.ebuild
new file mode 100644
index 000000000000..12fdd1faf77c
--- /dev/null
+++ b/sys-apps/hal/hal-0.5.5.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.5.1.ebuild,v 1.1 2005/11/22 01:26:43 compnerd Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="Hardware Abstraction Layer"
+HOMEPAGE="http://www.freedesktop.org/Software/hal"
+SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.0 )"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~ppc64 ~sparc"
+IUSE="acpi debug doc pam_console pcmcia"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=sys-apps/dbus-0.50
+ >=sys-fs/udev-071
+ >=sys-apps/util-linux-2.12i
+ ||( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ dev-libs/expat
+ dev-libs/libusb
+ sys-apps/hotplug
+ pam_console? ( sys-libs/pam )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ doc? ( app-doc/doxygen app-text/docbook-sgml-utils )"
+
+## HAL Daemon drops privledges so we need group access to read disks
+HALDAEMON_GROUPS="haldaemon,disk,cdrom,cdrw,floppy,usb"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ kernel_is ge 2 6 13 \
+ || die "You need a 2.6.13 or newer kernel to run this package"
+
+ if use acpi ; then
+ linux_chkconfig_present PROC_FS \
+ || die "ACPI support requires PROC_FS support in kernel"
+ fi
+
+ if use pam_console && ! built_with_use sys-libs/pam pam_console ; then
+ eerror "You need to build pam with pam_console support"
+ eerror "Please remerge sys-libs/pam with USE=pam_console"
+ die "pam without pam_console detected"
+ fi
+
+ if [ -d ${ROOT}/etc/hal/device.d ]; then
+ eerror "HAL 0.5.x will not run with the HAL 0.4.x series of"
+ eerror "/etc/hal/device.d/ so please remove this directory"
+ eerror "with rm -rf /etc/hal/device.d/ and then re-emerge."
+ eerror "This is due to configuration protection of /etc/"
+ die "remove /etc/hal/device.d/"
+ fi
+}
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # remove pamconsole option
+ use pam_console || epatch ${FILESDIR}/${PN}-0.5.1-old_storage_policy.patch
+}
+
+src_compile() {
+ econf \
+ --with-os-type=gentoo \
+ --with-pid-file=/var/run/hald.pid \
+ $(use_enable debug verbose-mode) \
+ $(use_enable pcmcia pcmcia-support) \
+ $(use_enable acpi acpi-proc) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable doc doxygen-docs) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # We install this in a seperate package to avoid gnome-python dep
+ rm ${D}/usr/bin/hal-device-manager
+
+ # initscript
+ newinitd ${FILESDIR}/0.5-hald.rc hald
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+ # Script to unmount devices if they are yanked out (from upstream)
+ exeinto /etc/dev.d/default
+ doexe ${FILESDIR}/hal-unmount.dev
+}
+
+pkg_postinst() {
+ ## We need to add the user/groups *after* package compilation/installation, so that we
+ ## don't change the user without the package being installed.
+ ##
+ enewgroup haldaemon || die "Problem adding haldaemon group"
+ # HAL drops priviledges by default now ...
+ # ... so we must make sure it can read disk/cdrom info (ie. be in ${HALDAEMON_GROUPS} groups)
+ enewuser haldaemon -1 "-1" /dev/null ${HALDAEMON_GROUPS} || die "Problem adding haldaemon user"
+
+ # Make sure that the haldaemon user is in the ${HALDAEMON_GROUPS}
+ # If users have a problem with this, let them file a bug
+ usermod -G ${HALDAEMON_GROUPS} haldaemon
+
+ einfo "The HAL daemon needs to be running for certain applications to"
+ einfo "work. Suggested is to add the init script to your start-up"
+ einfo "scripts, this should be done like this :"
+ einfo "\`rc-update add hald default\`"
+}