summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/hivex/ChangeLog7
-rw-r--r--app-misc/hivex/hivex-1.3.5-r1.ebuild83
-rw-r--r--app-misc/hivex/hivex-1.3.6-r1.ebuild104
-rw-r--r--app-misc/hivex/hivex-1.3.6-r2.ebuild114
-rw-r--r--app-misc/hivex/hivex-1.3.6.ebuild83
-rw-r--r--app-misc/hivex/hivex-1.3.7.ebuild108
6 files changed, 6 insertions, 493 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index 0ccf12c0e722..7d7f62ee81b1 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/hivex
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.22 2013/03/31 09:03:29 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.23 2013/07/14 07:34:54 qnikst Exp $
+
+ 14 Jul 2013; Alexander Vershilov <qnikst@gentoo.org> -hivex-1.3.5-r1.ebuild,
+ -hivex-1.3.6-r1.ebuild, -hivex-1.3.6-r2.ebuild, -hivex-1.3.6.ebuild,
+ -hivex-1.3.7.ebuild:
+ remove old unstable versions (thanks to slepnoga)
*hivex-1.3.7-r1 (31 Mar 2013)
diff --git a/app-misc/hivex/hivex-1.3.5-r1.ebuild b/app-misc/hivex/hivex-1.3.5-r1.ebuild
deleted file mode 100644
index cabce4aec22d..000000000000
--- a/app-misc/hivex/hivex-1.3.5-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.5-r1.ebuild,v 1.1 2012/05/02 12:24:25 maksbotan Exp $
-
-EAPI=4
-
-WANT_AUTOMAKE="1.11"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-AUTOTOOLS_AUTORECONF=1
-
-USE_RUBY="ruby18"
-RUBY_OPTIONAL=yes
-PYTHON_DEPEND="python? 2:2.6"
-
-inherit base autotools-utils perl-app python
-
-DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
-HOMEPAGE="http://libguestfs.org"
-SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ocaml readline perl python test static-libs ruby"
-
-RDEPEND="virtual/libiconv
- virtual/libintl
- dev-libs/libxml2:2
- ocaml? ( dev-lang/ocaml[ocamlopt]
- dev-ml/findlib[ocamlopt]
- )
- readline? ( sys-libs/readline )
- perl? ( dev-perl/IO-stringy )
- "
-
-DEPEND="${RDEPEND}
- dev-lang/perl
- perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage ) )
- ruby? ( dev-ruby/rake )
- "
-PATCHES=("${FILESDIR}"/"${PV}"/*.patch)
-DOCS=(README)
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- python_need_rebuild
- fi
-}
-
-src_prepare() {
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with readline)
- $(use_enable ocaml)
- $(use_enable perl)
- --enable-nls
- $(use_enable python)
- $(use_enable ruby)
- --disable-rpath )
-
- autotools-utils_src_configure
-}
-
-src_test() {
- autotools-utils_src_compile check
-}
-
-src_install() {
- strip-linguas -i po
-
- autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
-
- if use perl; then
- fixlocalpod
- fi
-}
diff --git a/app-misc/hivex/hivex-1.3.6-r1.ebuild b/app-misc/hivex/hivex-1.3.6-r1.ebuild
deleted file mode 100644
index 0fbac038d33a..000000000000
--- a/app-misc/hivex/hivex-1.3.6-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.6-r1.ebuild,v 1.1 2012/09/16 08:59:18 pinkbyte Exp $
-
-EAPI=4
-
-WANT_AUTOMAKE="1.11"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-AUTOTOOLS_AUTORECONF=1
-
-USE_RUBY="ruby18"
-RUBY_OPTIONAL=yes
-PYTHON_DEPEND="python? 2:2.6"
-
-inherit autotools-utils eutils perl-app python
-
-DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
-HOMEPAGE="http://libguestfs.org"
-SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ocaml readline perl python test static-libs ruby"
-
-RDEPEND="virtual/libiconv
- virtual/libintl
- dev-libs/libxml2:2
- ocaml? ( dev-lang/ocaml[ocamlopt]
- dev-ml/findlib[ocamlopt]
- )
- readline? ( sys-libs/readline )
- perl? ( dev-perl/IO-stringy )
- "
-
-DEPEND="${RDEPEND}
- dev-lang/perl
- perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage )
- )
- ruby? ( dev-ruby/rake )
- "
-PATCHES=("${FILESDIR}"/"${PVR}"/disable_automagic_cumulative_patch.patch )
-
-DOCS=(README)
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- python_need_rebuild
- fi
- if use perl; then
- perl-module_pkg_setup
- fi
-}
-
-src_prepare() {
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with readline)
- $(use_enable ocaml)
- $(use_enable perl)
- --enable-nls
- $(use_enable python)
- $(use_enable ruby)
- --disable-rpath )
-
- autotools-utils_src_configure
-
- if use perl; then
- pushd perl
- perl-app_src_configure
- popd
- fi
-}
-
-src_compile() {
- autotools-utils_src_compile
-}
-
-src_test() {
- if use perl;then
- pushd perl
- perl-app_src_install
- popd
- fi
-
- autotools-utils_src_compile check
-}
-
-src_install() {
- strip-linguas -i po
-
- autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
-
- if use perl; then
- fixlocalpod
- fi
-}
diff --git a/app-misc/hivex/hivex-1.3.6-r2.ebuild b/app-misc/hivex/hivex-1.3.6-r2.ebuild
deleted file mode 100644
index 85bccd73db8c..000000000000
--- a/app-misc/hivex/hivex-1.3.6-r2.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.6-r2.ebuild,v 1.1 2012/09/17 12:54:42 maksbotan Exp $
-
-EAPI=4
-
-WANT_AUTOMAKE="1.11"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-AUTOTOOLS_AUTORECONF=1
-
-USE_RUBY="ruby18"
-RUBY_OPTIONAL=yes
-PYTHON_DEPEND="python? 2:2.6"
-SUPPORT_PYTHON_ABIS=1
-
-inherit autotools-utils eutils perl-app python
-
-DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
-HOMEPAGE="http://libguestfs.org"
-SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ocaml readline perl python test static-libs ruby"
-
-RDEPEND="virtual/libiconv
- virtual/libintl
- dev-libs/libxml2:2
- ocaml? ( dev-lang/ocaml[ocamlopt]
- dev-ml/findlib[ocamlopt]
- )
- readline? ( sys-libs/readline )
- perl? ( dev-perl/IO-stringy )
- "
-
-DEPEND="${RDEPEND}
- dev-lang/perl
- perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage )
- )
- ruby? ( dev-ruby/rake )
- "
-PATCHES=( "${FILESDIR}"/${PV}-r1/disable_automagic_cumulative_patch.patch
- "${FILESDIR}"/${PV}-r1/fix_python_linking.patch )
-
-DOCS=(README)
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
- if use perl; then
- perl-module_pkg_setup
- fi
-}
-
-src_prepare() {
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with readline)
- $(use_enable ocaml)
- $(use_enable perl)
- --enable-nls
- $(use_enable python)
- $(use_enable ruby)
- --disable-rpath )
-
- autotools-utils_src_configure
-
- if use perl; then
- pushd perl
- perl-app_src_configure
- popd
- fi
-}
-
-src_compile() {
- autotools-utils_src_compile
-}
-
-src_test() {
- if use perl;then
- pushd perl
- perl-app_src_install
- popd
- fi
-
- autotools-utils_src_compile check
-}
-
-src_install() {
- strip-linguas -i po
-
- autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
-
- if use perl; then
- fixlocalpod
- fi
- if use python; then
- compile_and_install() {
- emake -C python clean
- emake -C python PYTHON_VERSION="${PYTHON_ABI}" \
- PYTHON_INCLUDEDIR="$(python_get_includedir)" \
- PYTHON_INSTALLDIR="$(python_get_sitedir)" \
- DESTDIR="${ED}" install
- }
- python_execute_function compile_and_install
- fi
-}
diff --git a/app-misc/hivex/hivex-1.3.6.ebuild b/app-misc/hivex/hivex-1.3.6.ebuild
deleted file mode 100644
index 62c89c2d5e1a..000000000000
--- a/app-misc/hivex/hivex-1.3.6.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.6.ebuild,v 1.1 2012/06/21 18:35:22 maksbotan Exp $
-
-EAPI=4
-
-WANT_AUTOMAKE="1.11"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-AUTOTOOLS_AUTORECONF=1
-
-USE_RUBY="ruby18"
-RUBY_OPTIONAL=yes
-PYTHON_DEPEND="python? 2:2.6"
-
-inherit base autotools-utils perl-app python
-
-DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
-HOMEPAGE="http://libguestfs.org"
-SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ocaml readline perl python test static-libs ruby"
-
-RDEPEND="virtual/libiconv
- virtual/libintl
- dev-libs/libxml2:2
- ocaml? ( dev-lang/ocaml[ocamlopt]
- dev-ml/findlib[ocamlopt]
- )
- readline? ( sys-libs/readline )
- perl? ( dev-perl/IO-stringy )
- "
-
-DEPEND="${RDEPEND}
- dev-lang/perl
- perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage ) )
- ruby? ( dev-ruby/rake )
- "
-PATCHES=("${FILESDIR}"/"${PV}"/*.patch)
-DOCS=(README)
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- python_need_rebuild
- fi
-}
-
-src_prepare() {
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with readline)
- $(use_enable ocaml)
- $(use_enable perl)
- --enable-nls
- $(use_enable python)
- $(use_enable ruby)
- --disable-rpath )
-
- autotools-utils_src_configure
-}
-
-src_test() {
- autotools-utils_src_compile check
-}
-
-src_install() {
- strip-linguas -i po
-
- autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
-
- if use perl; then
- fixlocalpod
- fi
-}
diff --git a/app-misc/hivex/hivex-1.3.7.ebuild b/app-misc/hivex/hivex-1.3.7.ebuild
deleted file mode 100644
index 4657fedde4a5..000000000000
--- a/app-misc/hivex/hivex-1.3.7.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.7.ebuild,v 1.1 2012/10/21 15:37:45 maksbotan Exp $
-
-EAPI=4
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-USE_RUBY="ruby18"
-RUBY_OPTIONAL=yes
-PYTHON_DEPEND="python? 2:2.6"
-SUPPORT_PYTHON_ABIS=1
-
-inherit autotools-utils eutils perl-app python
-
-DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
-HOMEPAGE="http://libguestfs.org"
-SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ocaml readline +perl python test static-libs ruby"
-
-RDEPEND="
- virtual/libiconv
- virtual/libintl
- dev-libs/libxml2:2
- ocaml? ( dev-lang/ocaml[ocamlopt]
- dev-ml/findlib[ocamlopt]
- )
- readline? ( sys-libs/readline )
- perl? ( dev-perl/IO-stringy )
- "
-
-DEPEND="${RDEPEND}
- dev-lang/perl
- perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage )
- )
- ruby? ( dev-ruby/rake )
- "
-# Patches added to apstream
-
-DOCS=(README)
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
- if use perl; then
- perl-module_pkg_setup
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with readline)
- $(use_enable ocaml)
- $(use_enable perl)
- --enable-nls
- $(use_enable python)
- $(use_enable ruby)
- --disable-rpath )
-
- autotools-utils_src_configure
-
- if use perl; then
- pushd perl
- perl-app_src_configure
- popd
- fi
-}
-
-src_compile() {
- autotools-utils_src_compile
-}
-
-src_test() {
- if use perl;then
- pushd perl
- perl-app_src_install
- popd
- fi
-
- autotools-utils_src_compile check
-}
-
-src_install() {
- strip-linguas -i po
-
- autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
-
- if use perl; then
- fixlocalpod
- fi
- if use python; then
- compile_and_install() {
- emake -C python clean
- emake -C python PYTHON_VERSION="${PYTHON_ABI}" \
- PYTHON_INCLUDEDIR="$(python_get_includedir)" \
- PYTHON_INSTALLDIR="$(python_get_sitedir)" \
- DESTDIR="${ED}" install
- }
- python_execute_function compile_and_install
- fi
-}