summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/cryptokit/ChangeLog7
-rw-r--r--dev-ml/cryptokit/cryptokit-1.5.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ml/cryptokit/ChangeLog b/dev-ml/cryptokit/ChangeLog
index dab2e82d92c4..71e63b57d0a9 100644
--- a/dev-ml/cryptokit/ChangeLog
+++ b/dev-ml/cryptokit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/cryptokit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/ChangeLog,v 1.9 2012/03/15 18:21:08 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/ChangeLog,v 1.10 2012/03/27 21:08:33 aballier Exp $
+
+*cryptokit-1.5 (27 Mar 2012)
+
+ 27 Mar 2012; Alexis Ballier <aballier@gentoo.org> +cryptokit-1.5.ebuild:
+ version bump
15 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> cryptokit-1.4.ebuild:
x86 stable wrt bug #405959
diff --git a/dev-ml/cryptokit/cryptokit-1.5.ebuild b/dev-ml/cryptokit/cryptokit-1.5.ebuild
new file mode 100644
index 000000000000..97c57448479e
--- /dev/null
+++ b/dev-ml/cryptokit/cryptokit-1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/cryptokit-1.5.ebuild,v 1.1 2012/03/27 21:08:33 aballier Exp $
+
+EAPI="3"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cryptographic primitives library for Objective Caml"
+HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/639/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="zlib"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable zlib)" \
+ oasis_src_configure
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This library uses the /dev/random device to generate "
+ elog "random data and RSA keys. The device should either be"
+ elog "built into the kernel or provided as a module. An"
+ elog "alternative is to use the Entropy Gathering Daemon"
+ elog "(http://egd.sourceforge.net). Please note that the"
+ elog "remainder of the library will still work even in the"
+ elog "absence of a one of these sources of randomness."
+ elog ""
+}
+
+src_test() {
+ echo ""
+ einfo "You must have either /dev/random or the Entropy Gathering"
+ einfo "Daemon (EGD) for this test to succeed!"
+ echo ""
+
+ oasis_src_test
+}