summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/fvwm-themes/ChangeLog13
-rw-r--r--x11-themes/fvwm-themes/files/fvwm-themes-0.7.0-posix-sort.patch11
-rw-r--r--x11-themes/fvwm-themes/fvwm-themes-0.7.0.ebuild44
3 files changed, 29 insertions, 39 deletions
diff --git a/x11-themes/fvwm-themes/ChangeLog b/x11-themes/fvwm-themes/ChangeLog
index cd28cdd7fb8d..c6d7955caa11 100644
--- a/x11-themes/fvwm-themes/ChangeLog
+++ b/x11-themes/fvwm-themes/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-themes/fvwm-themes
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-themes/ChangeLog,v 1.17 2008/01/06 08:57:22 omp Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-themes/ChangeLog,v 1.18 2010/05/28 12:39:31 xarthisius Exp $
+
+ 28 May 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ fvwm-themes-0.7.0.ebuild, files/fvwm-themes-0.7.0-posix-sort.patch:
+ Fixing autotools rebuilt through maintainer-mode wrt bug 226397, thanks to
+ Diego for report.
+ Fixing dependency on media-gfx/{image,graphics}magick wrt bug 314415,
+ thanks to
+ Wojciech Porczyk for report.
+ Simplifying configure phase, skipping useless einfo, don't copy INSTALL
06 Jan 2008; David Shakaryan <omp@gentoo.org>
+files/fvwm-themes-0.7.0-gentoo1.patch, fvwm-themes-0.7.0.ebuild:
diff --git a/x11-themes/fvwm-themes/files/fvwm-themes-0.7.0-posix-sort.patch b/x11-themes/fvwm-themes/files/fvwm-themes-0.7.0-posix-sort.patch
index 8d2bb1fc4524..3974f95c5c51 100644
--- a/x11-themes/fvwm-themes/files/fvwm-themes-0.7.0-posix-sort.patch
+++ b/x11-themes/fvwm-themes/files/fvwm-themes-0.7.0-posix-sort.patch
@@ -9,14 +9,3 @@
:
# fvwm version is ok
else
---- fvwm-themes-0.7.0/configure
-+++ fvwm-themes-0.7.0/configure
-@@ -4863,7 +4863,7 @@
-
- # Hopefully this "sort" is portable (after many tries using awk and expr)
- if (echo $REQUIRED_FVWM_VERSION; echo $FVWM_VERSION) \
--| sed 's/\./ /g' | uniq | sort -n +0 -1 +1 -2 +2 -3 -c 2>/dev/null; then
-+| sort -c -n -t . -k 1,1 -k 2,2 -k 3,3 2>/dev/null; then
- :
- # fvwm version is ok
- else
diff --git a/x11-themes/fvwm-themes/fvwm-themes-0.7.0.ebuild b/x11-themes/fvwm-themes/fvwm-themes-0.7.0.ebuild
index a8d0b9b4b7e4..80a2aaf7ab5c 100644
--- a/x11-themes/fvwm-themes/fvwm-themes-0.7.0.ebuild
+++ b/x11-themes/fvwm-themes/fvwm-themes-0.7.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-themes/fvwm-themes-0.7.0.ebuild,v 1.16 2008/01/06 08:57:22 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-themes/fvwm-themes-0.7.0.ebuild,v 1.17 2010/05/28 12:39:31 xarthisius Exp $
-inherit eutils
+EAPI="2"
+
+inherit autotools eutils
DESCRIPTION="A configuration framework for the fvwm window manager"
HOMEPAGE="http://fvwm-themes.sourceforge.net/"
@@ -13,38 +15,28 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE="gnome"
-DEPEND=">=x11-wm/fvwm-2.5.8
- gnome? ( media-gfx/imagemagick )"
-RDEPEND="x11-wm/fvwm"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+RDEPEND=">=x11-wm/fvwm-2.5.8"
+DEPEND="${RDEPEND}
+ gnome? ( || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick] ) )"
- epatch "${FILESDIR}/${P}-gentoo.patch"
- epatch "${FILESDIR}/${P}-gentoo1.patch"
- epatch "${FILESDIR}/${P}-posix-sort.patch"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch" \
+ "${FILESDIR}/${P}-posix-sort.patch"
+ eautoreconf
}
-src_compile() {
- local myconf
-
- use gnome && myconf="--enable-gnome-icons"
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ econf $(use_enable gnome gnome-icons)
}
src_install () {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
}
pkg_postinst() {
- einfo
- einfo "Configuring ${P}"
- einfo
-
fvwm-themes-config --site --reset
fvwm-themes-menuapp --site --build-menus --remove-popup