summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/mupdf/ChangeLog8
-rw-r--r--app-text/mupdf/files/mupdf-0.8.165-buildsystem.patch24
-rw-r--r--app-text/mupdf/files/mupdf-0.8.165-zoom.patch57
-rw-r--r--app-text/mupdf/mupdf-0.8.165.ebuild62
4 files changed, 150 insertions, 1 deletions
diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index 80225c977c81..384d135ee920 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/mupdf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.15 2011/03/30 09:29:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.16 2011/06/12 15:22:00 xmw Exp $
+
+*mupdf-0.8.165 (12 Jun 2011)
+
+ 12 Jun 2011; Michael Weber <xmw@gentoo.org> +mupdf-0.8.165.ebuild,
+ +files/mupdf-0.8.165-buildsystem.patch, +files/mupdf-0.8.165-zoom.patch:
+ Version bump
30 Mar 2011; Michael Weber <xmw@gentoo.org> -mupdf-0.7-r1.ebuild,
-mupdf-0.7_p20110212.ebuild, -files/mupdf-0.7-buildsystem.patch,
diff --git a/app-text/mupdf/files/mupdf-0.8.165-buildsystem.patch b/app-text/mupdf/files/mupdf-0.8.165-buildsystem.patch
new file mode 100644
index 000000000000..cc04f8d93740
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-0.8.165-buildsystem.patch
@@ -0,0 +1,24 @@
+--- mupdf-0.8.165/Makerules
++++ mupdf-0.8.165/Makerules
+@@ -3,10 +3,10 @@
+ OS ?= $(shell uname)
+ OS := $(OS:MINGW%=MINGW)
+
+-CFLAGS += -Wall
++CFLAGS +=
+
+ ifeq "$(build)" "debug"
+-CFLAGS += -pipe -g
++CFLAGS +=
+ else ifeq "$(build)" "profile"
+ CFLAGS += -pipe -O2 -DNDEBUG -pg
+ LDFLAGS += -pg
+@@ -20,7 +20,7 @@
+
+ ifeq "$(OS)" "Linux"
+ SYS_FREETYPE_INC := `pkg-config --cflags freetype2`
+-X11_LIBS := -lX11 -lXext
++X11_LIBS := `pkg-config --libs x11 xext`
+ endif
+
+ ifeq "$(OS)" "FreeBSD"
diff --git a/app-text/mupdf/files/mupdf-0.8.165-zoom.patch b/app-text/mupdf/files/mupdf-0.8.165-zoom.patch
new file mode 100644
index 000000000000..9f98ff766b16
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-0.8.165-zoom.patch
@@ -0,0 +1,57 @@
+--- mupdf-0.8.165/apps/man/mupdf.1
++++ mupdf-0.8.165/apps/man/mupdf.1
+@@ -37,6 +37,15 @@
+ .B \+, \-
+ Zoom in or out.
+ .TP
++.B _
++Reset zoom to default (72dpi).
++.TP
++.B z
++Zoom page size to fit into the window frame.
++.TP
++.B Z
++Zoom page size to fill the window frame.
++.TP
+ .B w
+ Shrinkwrap window to fit the page.
+ .TP
+--- mupdf-0.8.165/apps/pdfapp.c
++++ mupdf-0.8.165/apps/pdfapp.c
+@@ -736,6 +736,20 @@
+ pdfapp_showpage(app, 0, 1, 1);
+ break;
+
++ case '_': // zoom to default resolution
++ app->resolution = 72;
++ pdfapp_showpage(app, 0, 1, 1);
++ break;
++
++ case 'z': // zoom to fit window
++ case 'Z': // zoom to fill window
++ if ( ( c == 'Z' ) ^ ( app->image->w * app->winh > app->winw * app->image->h ) )
++ app->resolution = ( app->resolution * app->winw ) / app->image->w;
++ else
++ app->resolution = ( app->resolution * app->winh ) / app->image->h;
++ pdfapp_showpage(app, 0, 1, 1);
++ break;
++
+ case 'L':
+ app->rotate -= 90;
+ pdfapp_showpage(app, 0, 1, 1);
+@@ -859,6 +873,7 @@
+ break;
+
+ case 'b':
++ case '\b': //backspace
+ panto = DONT_PAN;
+ if (app->numberlen > 0)
+ app->pageno -= atoi(app->number);
+@@ -867,6 +882,7 @@
+ break;
+
+ case ' ':
++ case 'f':
+ panto = DONT_PAN;
+ if (app->numberlen > 0)
+ app->pageno += atoi(app->number);
diff --git a/app-text/mupdf/mupdf-0.8.165.ebuild b/app-text/mupdf/mupdf-0.8.165.ebuild
new file mode 100644
index 000000000000..c0d2d691e515
--- /dev/null
+++ b/app-text/mupdf/mupdf-0.8.165.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-0.8.165.ebuild,v 1.1 2011/06/12 15:22:00 xmw Exp $
+
+EAPI=2
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="a lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="http://mupdf.com/"
+SRC_URI="http://mupdf.com/download/${P}-source.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X vanilla"
+
+RDEPEND="media-libs/freetype:2
+ media-libs/jbig2dec
+ virtual/jpeg
+ media-libs/openjpeg
+ X? ( x11-libs/libX11
+ x11-libs/libXext )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+
+ use vanilla || epatch "${FILESDIR}"/${P}-zoom.patch
+}
+
+src_compile() {
+ local my_pdfexe=
+ use X || my_nox11="NOX11=yes MUPDF= "
+
+ emake CC="$(tc-getCC)" \
+ build=debug verbose=true ${my_nox11} -j1 || die
+}
+
+src_install() {
+ emake prefix="${D}usr" LIBDIR="${D}usr/$(get_libdir)" \
+ build=debug verbose=true ${my_nox11} install || die
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins debian/mupdf.pc || die
+
+ if use X ; then
+ domenu debian/mupdf.desktop || die
+ doicon debian/mupdf.xpm || die
+ doman apps/man/mupdf.1 || die
+ fi
+ doman apps/man/pdf{clean,draw,show}.1 || die
+ dodoc README || die
+
+ # avoid collision with app-text/poppler-utils
+ mv "${D}"usr/bin/pdfinfo "${D}"usr/bin/mupdf_pdfinfo || die
+}
+
+pkg_postinst() {
+ elog "pdfinfo was renamed to mupdf_pdfinfo"
+}