summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/which/files/which-2.12-r2-gentoo.diff14
-rw-r--r--sys-apps/which/which-2.12-r2.ebuild33
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/which/files/which-2.12-r2-gentoo.diff b/sys-apps/which/files/which-2.12-r2-gentoo.diff
new file mode 100644
index 000000000000..9d4828e60408
--- /dev/null
+++ b/sys-apps/which/files/which-2.12-r2-gentoo.diff
@@ -0,0 +1,14 @@
+diff -r -C2 which-2.12.orig/which.texinfo which-2.12/which.texinfo
+*** which-2.12.orig/which.texinfo Thu Jul 6 07:26:39 2000
+--- which-2.12/which.texinfo Fri Aug 3 17:23:52 2001
+***************
+*** 9,12 ****
+--- 9,16 ----
+
+ @ifinfo
++ @direntry
++ * which: (which). show full path of commands.
++ @end direntry
++
+ @format
+
diff --git a/sys-apps/which/which-2.12-r2.ebuild b/sys-apps/which/which-2.12-r2.ebuild
new file mode 100644
index 000000000000..f7e2a04fc700
--- /dev/null
+++ b/sys-apps/which/which-2.12-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/which-2.12-r2.ebuild,v 1.1 2001/08/03 21:36:59 chadh Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Prints out location of specified executables that are in your path"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/which/${A}
+ ftp://prep.ai.mit.edu/gnu/which/${A}"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ try ./configure --prefix=/usr
+ try make
+}
+
+src_install() {
+
+ dobin which
+ doman which.1
+ doinfo which.info
+ dodoc AUTHORS COPYING EXAMPLES NEWS README*
+}
+