summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lisp/cl-binary-types/ChangeLog6
-rw-r--r--dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild44
-rw-r--r--dev-lisp/cl-binary-types/cl-binary-types-0.84.ebuild26
-rw-r--r--dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild4
-rw-r--r--dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch22
-rw-r--r--dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.841
-rw-r--r--dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84.12
-rw-r--r--dev-lisp/cl-blowfish/ChangeLog7
-rw-r--r--dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild34
-rw-r--r--dev-lisp/cl-blowfish/cl-blowfish-0.3.ebuild33
-rw-r--r--dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild6
-rw-r--r--dev-lisp/cl-blowfish/files/digest-cl-blowfish-0.31
-rw-r--r--dev-lisp/cl-blowfish/files/digest-cl-blowfish-0.3-r12
-rw-r--r--dev-lisp/cl-bouquet/ChangeLog5
-rw-r--r--dev-lisp/cl-bouquet/cl-bouquet-0.1.ebuild4
15 files changed, 22 insertions, 175 deletions
diff --git a/dev-lisp/cl-binary-types/ChangeLog b/dev-lisp/cl-binary-types/ChangeLog
index 7f8c747b15e0..4f19e41d4fba 100644
--- a/dev-lisp/cl-binary-types/ChangeLog
+++ b/dev-lisp/cl-binary-types/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-binary-types
# Copyright 2000-2005 Gentoo Foundation and Matthew Kennedy <mkennedy@gentoo.org>; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/ChangeLog,v 1.7 2005/03/18 08:19:56 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/ChangeLog,v 1.8 2005/04/15 18:54:54 mkennedy Exp $
+
+ 15 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ cl-binary-types-0.90.ebuild:
+ Keywording ~ppc, x86
18 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org>
cl-binary-types-0.90.ebuild:
diff --git a/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild b/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild
deleted file mode 100644
index 6f4fb92c8631..000000000000
--- a/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild,v 1.4 2004/07/14 15:22:14 agriffis Exp $
-
-inherit common-lisp eutils
-
-DEB_PV=1
-
-DESCRIPTION="Binary-types is a Library for accessing binary files with fixed bit-length code-words. Binary-types provides macros that are used to declare the mapping between Common Lisp objects and some binary (i.e. octet-based) representation."
-HOMEPAGE="http://www.cliki.net/Binary-types http://www.cs.uit.no/~frodef/sw/binary-types/"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-binary-types/cl-binary-types_${PV}.orig.tar.gz
- http://ftp.debian.org/debian/pool/main/c/cl-binary-types/cl-binary-types_${PV}-${DEB_PV}.diff.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=binary-types
-
-
-src_unpack() {
- unpack ${A}
- epatch cl-binary-types_${PV}-${DEB_PV}.diff
- epatch ${FILESDIR}/${PV}-gentoo.patch
-}
-
-src_install() {
- common-lisp-install ${FILESDIR}/binary-types.asd *.lisp
- common-lisp-system-symlink
- dodoc README-bitfield COPYING ChangeLog type-hierarchy.ps README example.lisp
- do-debian-credits
-}
-
-pkg_preinst() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
-}
-
-pkg_postrm() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
-}
diff --git a/dev-lisp/cl-binary-types/cl-binary-types-0.84.ebuild b/dev-lisp/cl-binary-types/cl-binary-types-0.84.ebuild
deleted file mode 100644
index d699081f7c3e..000000000000
--- a/dev-lisp/cl-binary-types/cl-binary-types-0.84.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.84.ebuild,v 1.2 2004/06/24 23:41:36 agriffis Exp $
-
-inherit common-lisp
-
-DESCRIPTION="Binary-types is a Library for accessing binary files with fixed bit-length code-words. Binary-types provides macros that are used to declare the mapping between Common Lisp objects and some binary (i.e. octet-based) representation."
-HOMEPAGE="http://www.cliki.net/Binary-types
- http://www.cs.uit.no/~frodef/sw/binary-types/"
-SRC_URI="http://www.cs.uit.no/~frodef/sw/binary-types/binary-types-${PV}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=binary-types
-
-S=${WORKDIR}/${P/cl-/}
-
-src_install() {
- common-lisp-install ${FILESDIR}/binary-types.asd *.lisp
- common-lisp-system-symlink
- dodoc README-bitfield COPYING ChangeLog type-hierarchy.ps README example.lisp
-}
diff --git a/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild b/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild
index aeb0d6421dc2..9a5507374966 100644
--- a/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild
+++ b/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild,v 1.5 2005/03/18 08:19:56 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.90.ebuild,v 1.6 2005/04/15 18:54:54 mkennedy Exp $
inherit common-lisp eutils
@@ -12,7 +12,7 @@ SRC_URI="http://www.cs.uit.no/~frodef/sw/binary-types/binary-types-0.90.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="x86 ~amd64 ~ppc"
IUSE=""
DEPEND="dev-lisp/common-lisp-controller
diff --git a/dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch b/dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch
deleted file mode 100644
index da20f49ed079..000000000000
--- a/dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -u cl-binary-types-0.84.1.orig/binary-types.lisp cl-binary-types-0.84.1/binary-types.lisp
---- cl-binary-types-0.84.1.orig/binary-types.lisp 2002-10-25 06:20:52.000000000 -0500
-+++ cl-binary-types-0.84.1/binary-types.lisp 2003-10-15 15:47:45.949101320 -0500
-@@ -1,7 +1,7 @@
- ;;;;------------------------------------------------------------------
- ;;;;
- ;;;; Copyright (C) 200120001999,
--;;;; Department of Computer Science, University of Tromsø, Norway
-+;;;; Department of Computer Science, University of Tromso, Norway
- ;;;;
- ;;;; Filename: binary-types.lisp
- ;;;; Description: Reading and writing of binary data in streams.
-@@ -433,7 +433,7 @@
- (unless (typep type 'binary-record)
- (setf type (find-binary-type type)))
- (unless (typep type 'binary-record)
-- (error "~S is not of RECORD type."))
-+ (error "~S is not of RECORD type." type))
- (unless (find-if #'(lambda (slot)
- (eq slot-name (record-slot-name slot)))
- (binary-record-slots type))
-Only in cl-binary-types-0.84.1: binary-types.lisp~
diff --git a/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84 b/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84
deleted file mode 100644
index 70358376d3f4..000000000000
--- a/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84
+++ /dev/null
@@ -1 +0,0 @@
-MD5 25b0397203e0129f63fd3d48ce515dc5 binary-types-0.84.tar.gz 18616
diff --git a/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84.1 b/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84.1
deleted file mode 100644
index 9ea2fb3fef2d..000000000000
--- a/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84.1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 f8c7d587976b043c2777aa80fbc5cc68 cl-binary-types_0.84.1.orig.tar.gz 18536
-MD5 177c24987328d5b1e3b1ced0cbcf28b6 cl-binary-types_0.84.1-1.diff.gz 2847
diff --git a/dev-lisp/cl-blowfish/ChangeLog b/dev-lisp/cl-blowfish/ChangeLog
index 1d0f6a04720c..c7a16acaa290 100644
--- a/dev-lisp/cl-blowfish/ChangeLog
+++ b/dev-lisp/cl-blowfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-blowfish
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/ChangeLog,v 1.7 2005/03/18 07:41:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/ChangeLog,v 1.8 2005/04/15 18:56:57 mkennedy Exp $
+
+ 15 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ -cl-blowfish-0.3.ebuild, -cl-blowfish-0.3-r1.ebuild,
+ cl-blowfish-0.6.ebuild:
+ Remove old ebuilds; Keywording x86
18 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> cl-blowfish-0.6.ebuild:
Keywording for ~amd64
diff --git a/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild b/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild
deleted file mode 100644
index 4f2103c6d0bd..000000000000
--- a/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/cl-blowfish-0.3-r1.ebuild,v 1.4 2004/07/14 15:22:45 agriffis Exp $
-
-inherit common-lisp eutils
-
-DEB_PV=2
-
-DESCRIPTION="Common Lisp implementation of the Blowfish encryption algorithm."
-HOMEPAGE="http://packages.debian.org/unstable/devel/cl-blowfish.html http://members.optusnet.com.au/apicard/"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-blowfish/cl-blowfish_${PV}.orig.tar.gz
- http://ftp.debian.org/debian/pool/main/c/cl-blowfish/cl-blowfish_0.3-2.diff.gz"
-
-LICENSE="LLGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=blowfish
-
-
-src_unpack() {
- unpack ${A}
- epatch ${PN}_${PV}-${DEB_PV}.diff
-}
-
-src_install() {
- common-lisp-install *.lisp *.asd
- common-lisp-system-symlink
- do-debian-credits
-}
diff --git a/dev-lisp/cl-blowfish/cl-blowfish-0.3.ebuild b/dev-lisp/cl-blowfish/cl-blowfish-0.3.ebuild
deleted file mode 100644
index 406ca42b5f1e..000000000000
--- a/dev-lisp/cl-blowfish/cl-blowfish-0.3.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/cl-blowfish-0.3.ebuild,v 1.6 2004/07/14 15:22:45 agriffis Exp $
-
-inherit common-lisp
-
-DESCRIPTION="Common Lisp implementation of the Blowfish encryption algorithm."
-HOMEPAGE="http://packages.debian.org/unstable/devel/cl-blowfish.html
- http://members.optusnet.com.au/apicard/"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-blowfish/cl-blowfish_${PV}.orig.tar.gz"
-LICENSE="LLGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=blowfish
-
-
-src_install() {
- common-lisp-install *.lisp *.asd
- common-lisp-system-symlink
- do-debian-credits
-}
-
-pkg_preinst() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
-}
-
-pkg_postrm() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
-}
diff --git a/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild b/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild
index 300ce382f134..cf1740fbb01b 100644
--- a/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild
+++ b/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild,v 1.5 2005/03/18 07:41:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-blowfish/cl-blowfish-0.6.ebuild,v 1.6 2005/04/15 18:56:57 mkennedy Exp $
inherit common-lisp eutils
@@ -13,7 +13,7 @@ SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-blowfish/cl-blowfish_${PV}.
LICENSE="LLGPL-2.1"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="x86 ~ppc ~amd64"
IUSE=""
DEPEND="dev-lisp/common-lisp-controller
@@ -24,7 +24,7 @@ CLPACKAGE=blowfish
src_unpack() {
unpack ${A}
- epatch ${PN}_${PV}-${DEB_PV}.diff
+ epatch ${PN}_${PV}-${DEB_PV}.diff || die
}
src_install() {
diff --git a/dev-lisp/cl-blowfish/files/digest-cl-blowfish-0.3 b/dev-lisp/cl-blowfish/files/digest-cl-blowfish-0.3
deleted file mode 100644
index 6e214e0566fa..000000000000
--- a/dev-lisp/cl-blowfish/files/digest-cl-blowfish-0.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 495cdbeeacea0d6f5a70c4af03a7dfe8 cl-blowfish_0.3.orig.tar.gz 41516
diff --git a/dev-lisp/cl-blowfish/files/digest-cl-blowfish-0.3-r1 b/dev-lisp/cl-blowfish/files/digest-cl-blowfish-0.3-r1
deleted file mode 100644
index 853dc52f4ff1..000000000000
--- a/dev-lisp/cl-blowfish/files/digest-cl-blowfish-0.3-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 495cdbeeacea0d6f5a70c4af03a7dfe8 cl-blowfish_0.3.orig.tar.gz 41516
-MD5 18ced387a466081a557707f5cbb33318 cl-blowfish_0.3-2.diff.gz 3554
diff --git a/dev-lisp/cl-bouquet/ChangeLog b/dev-lisp/cl-bouquet/ChangeLog
index 4f5cf5694fbb..7a7fe3c915f8 100644
--- a/dev-lisp/cl-bouquet/ChangeLog
+++ b/dev-lisp/cl-bouquet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lisp/cl-bouquet
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-bouquet/ChangeLog,v 1.5 2005/03/18 07:42:10 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-bouquet/ChangeLog,v 1.6 2005/04/15 18:59:50 mkennedy Exp $
+
+ 15 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org> cl-bouquet-0.1.ebuild:
+ Keywording stable x86, ~ppc
18 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> cl-bouquet-0.1.ebuild:
Keywording for ~amd64
diff --git a/dev-lisp/cl-bouquet/cl-bouquet-0.1.ebuild b/dev-lisp/cl-bouquet/cl-bouquet-0.1.ebuild
index e312164ea8ed..1e3a7633676f 100644
--- a/dev-lisp/cl-bouquet/cl-bouquet-0.1.ebuild
+++ b/dev-lisp/cl-bouquet/cl-bouquet-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-bouquet/cl-bouquet-0.1.ebuild,v 1.7 2005/03/18 07:42:10 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-bouquet/cl-bouquet-0.1.ebuild,v 1.8 2005/04/15 18:59:50 mkennedy Exp $
inherit common-lisp eutils
@@ -9,7 +9,7 @@ HOMEPAGE="http://sourceforge.net/projects/bouquet/"
SRC_URI="mirror://sourceforge/bouquet/bouquet-${PV}.tar.gz"
LICENSE="LLGPL-2.1"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="x86 ~amd64 ~ppc"
IUSE=""
DEPEND="virtual/commonlisp
dev-lisp/common-lisp-controller"