summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-auth/consolekit/ChangeLog11
-rw-r--r--sys-auth/consolekit/consolekit-0.3.0-r1.ebuild104
-rw-r--r--sys-auth/consolekit/files/consolekit-0.3.0-allow-setidle.patch12
3 files changed, 126 insertions, 1 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index dff0b0c9a7bb..bf1056a1f649 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.45 2009/03/17 22:48:43 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.46 2009/04/27 19:31:44 dang Exp $
+
+*consolekit-0.3.0-r1 (27 Apr 2009)
+
+ 27 Apr 2009; Daniel Gryniewicz <dang@gentoo.org>
+ +files/consolekit-0.3.0-allow-setidle.patch, +consolekit-0.3.0-r1.ebuild:
+ Bump to consolekit-0.3.0-r1
+
+ - Add SetIdleHint to the dbus policy to handle the new default-deny on
+ dbus
17 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
consolekit-0.2.10.ebuild, consolekit-0.2.10-r1.ebuild,
diff --git a/sys-auth/consolekit/consolekit-0.3.0-r1.ebuild b/sys-auth/consolekit/consolekit-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..c4766a221bc6
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-0.3.0-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.3.0-r1.ebuild,v 1.1 2009/04/27 19:31:44 dang Exp $
+
+EAPI="2"
+
+inherit autotools eutils multilib pam
+
+MY_PN="ConsoleKit"
+MY_PV="${PV//_pre*/}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/ConsoleKit"
+SRC_URI="http://people.freedesktop.org/~mccann/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc pam policykit"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=dev-libs/dbus-glib-0.61
+ >=x11-libs/libX11-1.0.0
+ pam? ( virtual/pam )
+ policykit? ( >=sys-auth/policykit-0.7 )
+ elibc_glibc? ( !=sys-libs/glibc-2.4* )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ doc? ( app-text/xmlto )"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ # Fix directory leaks, bug #258685
+ epatch "${FILESDIR}/${PN}-0.2.10-directory-leak.patch"
+
+ # Clean up at_console compat files, bug #257761
+ epatch "${FILESDIR}/${PN}-0.2.10-cleanup_console_tags.patch"
+
+ # Add nox11 option to no interfere with Xsession script, bug #257763
+ epatch "${FILESDIR}/${PN}-0.2.10-pam-add-nox11.patch"
+
+ # Fix automagic dependency on policykit
+ epatch "${FILESDIR}/${PN}-0.2.10-polkit-automagic.patch"
+
+ # Fix inability to shutdown/restart
+ epatch "${FILESDIR}/${P}-shutdown.patch"
+
+ # Add SetIdleHint policy to handle new default deny on dbus
+ epatch "${FILESDIR}/${P}-allow-setidle.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable pam pam-module) \
+ $(use_enable policykit polkit) \
+ --with-pam-module-dir=/$(getpam_mod_dir) \
+ --with-dbus-services=/usr/share/dbus-1/services/ \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # crappy Redhat init script
+ rm -f "${D}/etc/rc.d/init.d/ConsoleKit"
+
+ # Portage barfs on .la files
+ rm -f "${D}/$(get_libdir)/security/pam_ck_connector.la"
+
+ # Gentoo style init script
+ newinitd "${FILESDIR}"/${PN}-0.1.rc consolekit
+
+ # Some PM drop empty dirs, bug #257164
+ keepdir /usr/$(get_libdir)/ConsoleKit/run-session.d
+ keepdir /etc/ConsoleKit/run-session.d
+ keepdir /var/run/ConsoleKit
+ keepdir /var/log/ConsoleKit
+
+ insinto /etc/X11/xinit/xinitrc.d/
+ doins "${FILESDIR}/90-consolekit" || die "doins failed"
+
+ exeinto /usr/$(get_libdir)/ConsoleKit/run-session.d/
+ doexe "${FILESDIR}/pam-foreground-compat.ck" || die "doexe failed"
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You need to restart ConsoleKit to get the new features."
+ ewarn "This can be done with /etc/init.d/consolekit restart"
+ ewarn "but make sure you do this and then restart your session"
+ ewarn "otherwise you will get access denied for certain actions"
+
+ ewarn
+ ewarn "You need to chmod +x /etc/X11/xinit/xinitrc.d/90-consolekit"
+ ewarn "to benefit of consolekit if you are not using gdm or pam integration."
+}
diff --git a/sys-auth/consolekit/files/consolekit-0.3.0-allow-setidle.patch b/sys-auth/consolekit/files/consolekit-0.3.0-allow-setidle.patch
new file mode 100644
index 000000000000..27aa96a1e92d
--- /dev/null
+++ b/sys-auth/consolekit/files/consolekit-0.3.0-allow-setidle.patch
@@ -0,0 +1,12 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN ConsoleKit-0.3.0.orig/data/ConsoleKit.conf ConsoleKit-0.3.0/data/ConsoleKit.conf
+--- ConsoleKit-0.3.0.orig/data/ConsoleKit.conf 2008-04-19 01:39:49.000000000 -0400
++++ ConsoleKit-0.3.0/data/ConsoleKit.conf 2009-04-27 15:20:57.000000000 -0400
+@@ -90,6 +90,8 @@
+ <allow send_interface="org.freedesktop.ConsoleKit.Session"
+ send_member="GetIdleHint"/>
+ <allow send_interface="org.freedesktop.ConsoleKit.Session"
++ send_member="SetIdleHint"/>
++ <allow send_interface="org.freedesktop.ConsoleKit.Session"
+ send_member="GetIdleSinceHint"/>
+ </policy>
+