summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-misc/boinc/ChangeLog7
-rw-r--r--sci-misc/boinc/boinc-5.2.14.ebuild3
-rw-r--r--sci-misc/boinc/files/boinc-5.2.14-gcc-4.1.patch13
3 files changed, 21 insertions, 2 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 82c48cb5f97b..7e243af48ccd 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.19 2006/02/25 19:44:22 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.20 2006/04/14 19:14:47 cryos Exp $
+
+ 14 Apr 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/boinc-5.2.14-gcc-4.1.patch, boinc-5.2.14.ebuild:
+ Added GCC 4.1 patch supplied by Mark Loeser <halcy0n@gentoo.org>, closes bug
+ 129592.
25 Feb 2006; Marcus D. Hanwell <cryos@gentoo.org> boinc-5.2.14.ebuild:
Add warning about client password, bug 121896.
diff --git a/sci-misc/boinc/boinc-5.2.14.ebuild b/sci-misc/boinc/boinc-5.2.14.ebuild
index fbbf2960ebe9..497a55284855 100644
--- a/sci-misc/boinc/boinc-5.2.14.ebuild
+++ b/sci-misc/boinc/boinc-5.2.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.4 2006/02/25 19:44:22 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.5 2006/04/14 19:14:47 cryos Exp $
inherit eutils
@@ -44,6 +44,7 @@ src_unpack() {
# Applu patches, most of which from Debian
EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" epatch
epatch ${FILESDIR}/08_all_Makefile.patch
+ epatch ${FILESDIR}/${P}-gcc-4.1.patch
# point to a proper mouse device
sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
diff --git a/sci-misc/boinc/files/boinc-5.2.14-gcc-4.1.patch b/sci-misc/boinc/files/boinc-5.2.14-gcc-4.1.patch
new file mode 100644
index 000000000000..6f350aed7801
--- /dev/null
+++ b/sci-misc/boinc/files/boinc-5.2.14-gcc-4.1.patch
@@ -0,0 +1,13 @@
+diff -ur boinc-5.2.14-orig/clientgui/BOINCTaskBar.h boinc-5.2.14/clientgui/BOINCTaskBar.h
+--- boinc-5.2.14-orig/clientgui/BOINCTaskBar.h 2006-04-13 14:09:32.000000000 -0400
++++ boinc-5.2.14/clientgui/BOINCTaskBar.h 2006-04-13 14:10:03.000000000 -0400
+@@ -76,7 +76,7 @@
+ #endif
+
+ #ifndef __WXMSW__
+- inline bool CTaskBarIcon::IsBalloonsSupported() {
++ inline bool IsBalloonsSupported() {
+ return false;
+ }
+ #endif
+