summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/zenirc/ChangeLog12
-rw-r--r--app-emacs/zenirc/files/50zenirc-gentoo.el4
-rw-r--r--app-emacs/zenirc/zenirc-2.112-r1.ebuild43
3 files changed, 53 insertions, 6 deletions
diff --git a/app-emacs/zenirc/ChangeLog b/app-emacs/zenirc/ChangeLog
index 26c86b0ea739..50801ab727ac 100644
--- a/app-emacs/zenirc/ChangeLog
+++ b/app-emacs/zenirc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/zenirc
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/zenirc/ChangeLog,v 1.11 2014/02/10 08:12:44 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/zenirc/ChangeLog,v 1.12 2014/02/10 17:00:43 ulm Exp $
+
+*zenirc-2.112-r1 (10 Feb 2014)
+
+ 10 Feb 2014; Ulrich Müller <ulm@gentoo.org> +zenirc-2.112-r1.ebuild:
+ Use install functions from elisp-common.eclass instead of make install, in
+ order to avoid double byte-compilation of elisp files. Update to EAPI 5.
+ Specify LICENSE more precisely. Use readme.gentoo.eclass instead of elog for
+ message display.
20 Nov 2007; Christian Faulhammer <opfer@gentoo.org> zenirc-2.112.ebuild:
amd64 stable, bug 195512
diff --git a/app-emacs/zenirc/files/50zenirc-gentoo.el b/app-emacs/zenirc/files/50zenirc-gentoo.el
index 7b77cf3b7df3..c52c190d214a 100644
--- a/app-emacs/zenirc/files/50zenirc-gentoo.el
+++ b/app-emacs/zenirc/files/50zenirc-gentoo.el
@@ -1,6 +1,2 @@
-
-;;; zenirc site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'zenirc "zenirc" "Start ZenIRC" t)
-
diff --git a/app-emacs/zenirc/zenirc-2.112-r1.ebuild b/app-emacs/zenirc/zenirc-2.112-r1.ebuild
new file mode 100644
index 000000000000..8fed426afb14
--- /dev/null
+++ b/app-emacs/zenirc/zenirc-2.112-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/zenirc/zenirc-2.112-r1.ebuild,v 1.1 2014/02/10 17:00:43 ulm Exp $
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="A full-featured scriptable IRC client for the Emacs text editor"
+HOMEPAGE="http://www.zenirc.org/"
+SRC_URI="ftp://ftp.zenirc.org/pub/zenirc/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ # econf won't work because of unknown options
+ ./configure --prefix="${EPREFIX}/usr/" || die "configure failed"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ elisp-install ${PN} src/*.el src/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo doc/zenirc.info
+ dodoc BUGS INSTALL NEWS README TODO
+
+ cd doc
+ docinto doc
+ dodoc 666.conspiracy FAQ README-OLD ctcp.doc irc-operators \
+ server-list tao-of-irc tour.of.irc undernet
+
+ DOC_CONTENTS="Refer to the Info documentation and
+ ${SITELISP}/${PN}/zenirc-example.el for customization hints."
+ readme.gentoo_create_doc
+}