summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-openid/ChangeLog11
-rw-r--r--dev-python/python-openid/files/digest-python-openid-1.2.0-r1 (renamed from dev-python/python-openid/files/digest-python-openid-1.2.0)0
-rw-r--r--dev-python/python-openid/python-openid-1.2.0-r1.ebuild (renamed from dev-python/python-openid/python-openid-1.2.0.ebuild)19
3 files changed, 23 insertions, 7 deletions
diff --git a/dev-python/python-openid/ChangeLog b/dev-python/python-openid/ChangeLog
index f958dd4710b0..6f321048b644 100644
--- a/dev-python/python-openid/ChangeLog
+++ b/dev-python/python-openid/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/python-openid
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.1 2007/02/27 23:29:23 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.2 2007/05/31 19:01:26 pythonhead Exp $
+
+*python-openid-1.2.0-r1 (31 May 2007)
+
+ 31 May 2007; Rob Cakebread <pythonhead@gentoo.org>
+ -python-openid-1.2.0.ebuild, +python-openid-1.2.0-r1.ebuild:
+ Dropped amd64 keyword due to two missing deps bug#180397 - Thanks Paul Rauch
+ <LightLan@lightlan.de>. Added src_test, missing deps for python-yadis,
+ python-urljr and USE/dep for postgres/pyscopg, added PYTHON_MODNAME. Dropped
+ old version.
04 Feb 2007; Tiziano Müller <dev-zero@gentoo.org>
python-openid-1.2.0.ebuild:
diff --git a/dev-python/python-openid/files/digest-python-openid-1.2.0 b/dev-python/python-openid/files/digest-python-openid-1.2.0-r1
index d140bccdfeeb..d140bccdfeeb 100644
--- a/dev-python/python-openid/files/digest-python-openid-1.2.0
+++ b/dev-python/python-openid/files/digest-python-openid-1.2.0-r1
diff --git a/dev-python/python-openid/python-openid-1.2.0.ebuild b/dev-python/python-openid/python-openid-1.2.0-r1.ebuild
index d5e8f41e20fa..29058697083b 100644
--- a/dev-python/python-openid/python-openid-1.2.0.ebuild
+++ b/dev-python/python-openid/python-openid-1.2.0-r1.ebuild
@@ -1,22 +1,25 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-1.2.0.ebuild,v 1.1 2007/02/27 23:29:23 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-1.2.0-r1.ebuild,v 1.1 2007/05/31 19:01:26 pythonhead Exp $
-NEED_PYTHON=2.2
+NEED_PYTHON=2.3
+PYTHON_MODNAME="openid"
inherit distutils
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~x86"
DESCRIPTION="OpenID support for servers and consumers."
HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
SRC_URI="http://www.openidenabled.com/resources/downloads/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="doc examples"
+IUSE="doc examples postgres"
-DEPEND=""
-RDEPEND=""
+RDEPEND=">=dev-python/python-yadis-1.1.0
+ >=dev-python/python-urljr-1.0.1
+ postgres? ( dev-python/psycopg )"
+DEPEND="${RDEPEND}"
src_install() {
distutils_src_install
@@ -26,3 +29,7 @@ src_install() {
doins -r examples
fi
}
+
+src_test() {
+ PYTHONPATH=. "${python}" admin/runtests || die "tests failed"
+}