summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/argus/ChangeLog6
-rw-r--r--net-analyzer/argus/argus-3.0.5.6.ebuild3
-rw-r--r--net-analyzer/argus/files/argus-3.0.5-Makefile.patch13
3 files changed, 16 insertions, 6 deletions
diff --git a/net-analyzer/argus/ChangeLog b/net-analyzer/argus/ChangeLog
index 8af18649e0dd..4ee1ef77407b 100644
--- a/net-analyzer/argus/ChangeLog
+++ b/net-analyzer/argus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/argus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.36 2011/11/15 20:43:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.37 2011/11/15 21:18:38 jer Exp $
+
+ 15 Nov 2011; Jeroen Roovers <jer@gentoo.org> argus-3.0.5.6.ebuild,
+ files/argus-3.0.5-Makefile.patch:
+ Remove redundant sed script. Tweak Makefile patch to actually die properly.
15 Nov 2011; Jeroen Roovers <jer@gentoo.org> argus-3.0.5.6.ebuild,
+files/argus-3.0.5-Makefile.patch:
diff --git a/net-analyzer/argus/argus-3.0.5.6.ebuild b/net-analyzer/argus/argus-3.0.5.6.ebuild
index 77fbc2f2b685..e057e0e18742 100644
--- a/net-analyzer/argus/argus-3.0.5.6.ebuild
+++ b/net-analyzer/argus/argus-3.0.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.5.6.ebuild,v 1.2 2011/11/15 20:43:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.5.6.ebuild,v 1.3 2011/11/15 21:18:38 jer Exp $
EAPI="4"
@@ -34,7 +34,6 @@ src_prepare() {
-e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
-e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
-i support/Config/argus.conf || die
-# sed -e 's:.*="-O.*":true:g' -i acsite.m4 || die
epatch \
"${FILESDIR}"/${PN}-3.0.4-disable-tcp-wrappers-automagic.patch \
"${FILESDIR}"/${PN}-3.0.5-Makefile.patch
diff --git a/net-analyzer/argus/files/argus-3.0.5-Makefile.patch b/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
index e4c3e1981c2f..87b1c155caf8 100644
--- a/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
+++ b/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
@@ -2,12 +2,19 @@ Do not continue when a sub-make errors (bug #380953).
--- a/Makefile.in
+++ b/Makefile.in
-@@ -55,7 +55,7 @@
+@@ -55,11 +55,11 @@
.PHONY: install installdirs all
all: force
- @-for d in $(DIRS);\
+ @for d in $(DIRS);\
do \
- (cd $$d; echo "### Making in" `pwd`;\
- $(MAKE) $(MFLAGS) ;\
+- (cd $$d; echo "### Making in" `pwd`;\
+- $(MAKE) $(MFLAGS) ;\
+- echo "### Done with" `pwd`);\
++ echo "### Making in" $$d;\
++ $(MAKE) -C $$d $(MFLAGS) || exit 1;\
++ echo "### Done with" $$d;\
+ done
+
+ install: force