summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/gnome-media/ChangeLog9
-rw-r--r--gnome-extra/gnome-media/files/gnome-media-2.30.0-lamemp3enc.patch26
-rw-r--r--gnome-extra/gnome-media/files/gnome-media-2.30.0-microphone-icon.patch27
-rw-r--r--gnome-extra/gnome-media/gnome-media-2.30.0-r1.ebuild73
4 files changed, 134 insertions, 1 deletions
diff --git a/gnome-extra/gnome-media/ChangeLog b/gnome-extra/gnome-media/ChangeLog
index b266a3c5adb8..f7708c4fb63d 100644
--- a/gnome-extra/gnome-media/ChangeLog
+++ b/gnome-extra/gnome-media/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/gnome-media
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-media/ChangeLog,v 1.215 2010/06/04 20:31:04 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-media/ChangeLog,v 1.216 2010/06/13 19:14:28 pacho Exp $
+
+*gnome-media-2.30.0-r1 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org> +gnome-media-2.30.0-r1.ebuild,
+ +files/gnome-media-2.30.0-lamemp3enc.patch,
+ +files/gnome-media-2.30.0-microphone-icon.patch:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org> gnome-media-2.28.5.ebuild:
x86 stable, bug #314899
diff --git a/gnome-extra/gnome-media/files/gnome-media-2.30.0-lamemp3enc.patch b/gnome-extra/gnome-media/files/gnome-media-2.30.0-lamemp3enc.patch
new file mode 100644
index 000000000000..6a0230b48fff
--- /dev/null
+++ b/gnome-extra/gnome-media/files/gnome-media-2.30.0-lamemp3enc.patch
@@ -0,0 +1,26 @@
+From d81e10b63f5a38a5004ff2486e679608cb7dbab9 Mon Sep 17 00:00:00 2001
+From: Pascal de Bruijn <pmjdebruijn@pcode.nl>
+Date: Sat, 29 May 2010 05:54:58 +0000
+Subject: profiles: Use lamemp3enc and xingmux instead of the deprecated lame element
+
+The lame element has a broken interface and results in worse
+quality encodings. The xingmux element is added to allow correct
+duration reporting and seeking for VBR files.
+
+Fixes bug #619642.
+---
+diff --git a/profiles/gnome-audio-profiles.schemas.in.in b/profiles/gnome-audio-profiles.schemas.in.in
+index bd5ab06..d29ac57 100644
+--- a/profiles/gnome-audio-profiles.schemas.in.in
++++ b/profiles/gnome-audio-profiles.schemas.in.in
+@@ -496,7 +496,7 @@
+ <applyto>/system/gstreamer/@GST_MAJORMINOR@/audio/profiles/mp3/pipeline</applyto>
+ <owner>gnome-media</owner>
+ <type>string</type>
+- <default>audio/x-raw-int,rate=44100,channels=2 ! lame name=enc mode=0 vbr-quality=6 ! id3v2mux</default>
++ <default>audio/x-raw-int,rate=44100,channels=2 ! lamemp3enc name=enc target=0 quality=6 ! xingmux ! id3v2mux</default>
+ <locale name="C">
+ <short>The partial GStreamer pipeline used</short>
+ <long>
+--
+cgit v0.8.3.1
diff --git a/gnome-extra/gnome-media/files/gnome-media-2.30.0-microphone-icon.patch b/gnome-extra/gnome-media/files/gnome-media-2.30.0-microphone-icon.patch
new file mode 100644
index 000000000000..9e9a0686cbfc
--- /dev/null
+++ b/gnome-extra/gnome-media/files/gnome-media-2.30.0-microphone-icon.patch
@@ -0,0 +1,27 @@
+From 23f2b45b0d152c115efbcdb72f37c2a75351bbf6 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Thu, 10 Jun 2010 13:56:39 +0000
+Subject: Show a microphone icon even if the stream has no ID
+
+Just because the stream has no ID doesn't mean that we shouldn't
+show the microphone icon.
+---
+diff --git a/gnome-volume-control/src/gvc-applet.c b/gnome-volume-control/src/gvc-applet.c
+index 8de0f43..1b311e4 100644
+--- a/gnome-volume-control/src/gvc-applet.c
++++ b/gnome-volume-control/src/gvc-applet.c
+@@ -94,8 +94,10 @@ maybe_show_status_icons (GvcApplet *applet)
+ const char *id;
+
+ id = gvc_mixer_stream_get_application_id (s);
+- if (id == NULL)
+- continue;
++ if (id == NULL) {
++ show = TRUE;
++ break;
++ }
+
+ if (!g_str_equal (id, "org.gnome.VolumeControl") &&
+ !g_str_equal (id, "org.PulseAudio.pavucontrol")) {
+--
+cgit v0.8.3.1
diff --git a/gnome-extra/gnome-media/gnome-media-2.30.0-r1.ebuild b/gnome-extra/gnome-media/gnome-media-2.30.0-r1.ebuild
new file mode 100644
index 000000000000..f7bcc875a149
--- /dev/null
+++ b/gnome-extra/gnome-media/gnome-media-2.30.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-media/gnome-media-2.30.0-r1.ebuild,v 1.1 2010/06/13 19:14:28 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Multimedia related programs for the GNOME desktop"
+HOMEPAGE="http://ronald.bitfreak.net/gnome-media.php"
+
+LICENSE="LGPL-2 GPL-2 FDL-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="pulseaudio"
+
+RDEPEND=">=dev-libs/glib-2.18.2:2
+ >=x11-libs/gtk+-2.15.1:2
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2.6.1
+ >=media-libs/gstreamer-0.10.23
+ >=media-libs/gst-plugins-base-0.10.23
+ >=media-libs/gst-plugins-good-0.10
+ >=dev-libs/libunique-1
+
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
+ >=media-libs/libcanberra-0.4[gtk]
+ dev-libs/libxml2
+ >=media-libs/gst-plugins-base-0.10.23:0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-gconf-0.10.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=app-text/scrollkeeper-0.3.11
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/intltool-0.35.0"
+
+DOCS="AUTHORS ChangeLog* NEWS MAINTAINERS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-scrollkeeper
+ --disable-schemas-install
+ --enable-gstprops
+ --enable-grecord
+ --enable-profiles
+ $(use_enable pulseaudio)
+ $(use_enable !pulseaudio gstmix)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use lamemp3enc and xingmux instead of the deprecated lame element
+ epatch "${FILESDIR}/${P}-lamemp3enc.patch"
+
+ # Show a microphone icon even if the stream has no ID
+ epatch "${FILESDIR}/${P}-microphone-icon.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ewarn
+ ewarn "If you cannot play some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+ if use pulseaudio; then
+ ewarn "You have enabled pulseaudio support, gstmixer will not be built"
+ ewarn "If you do not use pulseaudio, you do not want this"
+ fi
+}