summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/Manifest22
-rw-r--r--net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild71
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-3.4.2-r21
4 files changed, 85 insertions, 16 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 1d89d2862aa3..3212a93f7678 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.35 2004/09/05 08:16:57 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.36 2004/10/11 21:16:26 squinky86 Exp $
+
+*bittorrent-3.4.2-r2 (11 Oct 2004)
+
+ 11 Oct 2004; Jon Hood <squinky86@gentoo.org> +bittorrent-3.4.2-r2.ebuild:
+ Fix installation; thanks Nico Erfurth <masta-gentoo@perlgolf.de>, #67073.
05 Sep 2004; Sven Wegener <swegener@gentoo.org> :
Fixed ChangeLog header.
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index 7f7090f425ff..a8220a338b6b 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -1,21 +1,13 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 1bf39d5d4008accad1bc32b07ae4db66 bittorrent-3.4.1a.ebuild 1718
+MD5 542fe0d98f4d796a00147c457eff0407 bittorrent-3.4.2-r2.ebuild 1923
MD5 8a2dbf77a8de56d7bc2c77c12ca32a99 bittorrent-3.4.2-r1.ebuild 1872
+MD5 da54049280af86cd24637b113b1cd8f8 ChangeLog 5289
MD5 6a1b2acac30de0cc4703c999e1c4e709 bittorrent-3.4.2.ebuild 1681
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
-MD5 da54049280af86cd24637b113b1cd8f8 ChangeLog 5289
-MD5 a94d4e97cceef0143a1a5c8784b6f70c files/bttrack.conf 728
-MD5 8254615ee527cd608123c83de2616ede files/bttrack.rc 631
+MD5 7779a7eaf51eb9f84da8a588050f53fa files/favicon.ico 1406
MD5 041cb026a6f1c38c3ceef68e3a3001de files/digest-bittorrent-3.4.1a 66
-MD5 13f6b888eed806a8d4ce9cea22a7bacc files/digest-bittorrent-3.4.2 65
MD5 13f6b888eed806a8d4ce9cea22a7bacc files/digest-bittorrent-3.4.2-r1 65
-MD5 7779a7eaf51eb9f84da8a588050f53fa files/favicon.ico 1406
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBOst/I1lqEGTUzyQRAjWTAKCC8NgRs+qSrJwkzVxZvLREorL2fACfe/ZU
-LDKxqlpkhsbqu/3aSYsd9Z0=
-=y2F4
------END PGP SIGNATURE-----
+MD5 13f6b888eed806a8d4ce9cea22a7bacc files/digest-bittorrent-3.4.2-r2 65
+MD5 8254615ee527cd608123c83de2616ede files/bttrack.rc 631
+MD5 a94d4e97cceef0143a1a5c8784b6f70c files/bttrack.conf 728
+MD5 13f6b888eed806a8d4ce9cea22a7bacc files/digest-bittorrent-3.4.2 65
diff --git a/net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild b/net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild
new file mode 100644
index 000000000000..27902776dfde
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild,v 1.1 2004/10/11 21:16:26 squinky86 Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+MY_P="${MY_P/\.0/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://bitconjurer.org/BitTorrent"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~amd64"
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxpython-2.2 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+DOCS="credits.txt"
+PYTHON_MODULE="BitTorrent"
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+
+ insinto /usr/share/bittorrent
+ doins ${FILESDIR}/favicon.ico
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc bttrack
+}
+
+pkg_postinst() {
+ einfo "unofficial feature additions. If you would like statistics, please"
+ einfo "install net-p2p/bittorrent-stats."
+ distutils_pkg_postinst
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-3.4.2-r2 b/net-p2p/bittorrent/files/digest-bittorrent-3.4.2-r2
new file mode 100644
index 000000000000..3ea4d81b56f2
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-3.4.2-r2
@@ -0,0 +1 @@
+MD5 6ad4e128ddc82f8ebef6fbef59872f0d BitTorrent-3.4.2.zip 244989