summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/phpmyadmin/ChangeLog7
-rw-r--r--dev-db/phpmyadmin/Manifest2
-rw-r--r--dev-db/phpmyadmin/files/digest-phpmyadmin-2.5.71
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.5.7.ebuild93
4 files changed, 102 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 4724bdcd2787..fa11df1f6bcf 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.48 2004/06/24 21:59:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.49 2004/06/27 11:31:40 twp Exp $
+
+*phpmyadmin-2.5.7 (27 Jun 2004)
+
+ 27 Jun 2004; <twp@gentoo.org> +phpmyadmin-2.5.7.ebuild:
+ Version bump. Bug # 53422.
08 May 2004; <twp@gentoo.org> phpmyadmin-2.5.6-r1.ebuild:
Mark ~all-ARCHs, block earlier versions to force uninstall pre-emerge.
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
index c3780c8ba6bf..c9f2223d49be 100644
--- a/dev-db/phpmyadmin/Manifest
+++ b/dev-db/phpmyadmin/Manifest
@@ -1,8 +1,10 @@
+MD5 24d7b43b89dd98ad9968a2c78c2be68b phpmyadmin-2.5.7.ebuild 2605
MD5 069d2a2a19bf52163dd8921042bd23e1 phpmyadmin-2.5.6.ebuild 2991
MD5 01dd872ea161e68e8d2478837140e585 ChangeLog 7552
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
MD5 24d7b43b89dd98ad9968a2c78c2be68b phpmyadmin-2.5.6-r1.ebuild 2605
MD5 5367bc809b77e6374f18d126990fba75 files/digest-phpmyadmin-2.5.6 70
+MD5 09deb77d7dc18f657af1dc07afa81072 files/digest-phpmyadmin-2.5.7 70
MD5 56dcb2efb84915a521c18a004f96d37c files/postinstall-en.txt 506
MD5 85a86432c3f64acb068a7d2cfab311a9 files/config.inc.php-2.5.6.patch 5525
MD5 c6a79ab6f3c9e6d657a5bee36b1f6565 files/phpmyadmin-config.patch 4857
diff --git a/dev-db/phpmyadmin/files/digest-phpmyadmin-2.5.7 b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.5.7
new file mode 100644
index 000000000000..c620fe541456
--- /dev/null
+++ b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.5.7
@@ -0,0 +1 @@
+MD5 f0f06811aa4f7c14e053ddd23002f40d phpMyAdmin-2.5.7.tar.bz2 1121972
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.5.7.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.5.7.ebuild
new file mode 100644
index 000000000000..dfb08871e529
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-2.5.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.5.7.ebuild,v 1.1 2004/06/27 11:31:40 twp Exp $
+
+inherit eutils webapp
+
+MY_P=phpMyAdmin-${PV/_p/-pl}
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://phpmyadmin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~alpha -arm ~ppc -hppa -mips ~sparc ~x86 ~amd64"
+DEPEND=">=net-www/apache-1.3
+ >=dev-db/mysql-3.23.32 <dev-db/mysql-5.0
+ >=dev-php/mod_php-3.0.8
+ sys-apps/findutils
+ !<=dev-db/phpmyadmin-2.5.6"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/config.inc.php-2.5.6.patch
+
+ # Remove .cvs* files and CVS directories
+ find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
+}
+
+src_compile() {
+ einfo "Setting random user/password details for the controluser"
+
+ local pmapass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
+ mv config.inc.php ${T}/config.inc.php
+ sed -e "s/@pmapass@/${pmapass}/g" \
+ ${T}/config.inc.php > config.inc.php
+ sed -e "s/@pmapass@/${pmapass}/g" \
+ ${FILESDIR}/mysql-setup.sql.in-${PV} > ${T}/mysql-setup.sql
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="ANNOUNCE.txt CREDITS Documentation.txt RELEASE-DATE-${PV} TODO ChangeLog LICENSE README"
+
+ # install the SQL scripts available to us
+ #
+ # unfortunately, we do not have scripts to upgrade from older versions
+ # these are things we need to add at a later date
+
+ webapp_sqlscript mysql ${T}/mysql-setup.sql
+
+ # handle documentation files
+ #
+ # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+ # get installed per vhost!
+
+ dodoc ${docs}
+ for doc in ${docs} INSTALL; do
+ rm -f ${doc}
+ done
+
+ # Copy the app's main files
+
+ einfo "Installing main files"
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ # Identify the configuration files that this app uses
+
+ webapp_configfile ${MY_HTDOCSDIR}/config.inc.php
+
+ # Identify any script files that need #! headers adding to run under
+ # a CGI script (such as PHP/CGI)
+ #
+ # for phpmyadmin, we *assume* that all .php files that don't end in
+ # .inc.php need to have CGI/BIN support added
+
+ for x in `find . -name '*.php' -print | grep -v 'inc.php'` ; do
+ webapp_runbycgibin php ${MY_HTDOCSDIR}/$x
+ done
+
+ # there are no files which need to be owned by the web server
+
+ # add the post-installation instructions
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ # all done
+ #
+ # now we let the eclass strut its stuff ;-)
+
+ webapp_src_install
+}