summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/qgtkstyle/ChangeLog13
-rw-r--r--x11-themes/qgtkstyle/files/main.cpp4
-rw-r--r--x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild35
-rw-r--r--x11-themes/qgtkstyle/qgtkstyle-4.7.1-r2.ebuild (renamed from x11-themes/qgtkstyle/qgtkstyle-4.7.1-r1.ebuild)12
-rw-r--r--x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild35
-rw-r--r--x11-themes/qgtkstyle/qgtkstyle-4.7.2.ebuild (renamed from x11-themes/qgtkstyle/qgtkstyle-4.6.3-r1.ebuild)18
6 files changed, 36 insertions, 81 deletions
diff --git a/x11-themes/qgtkstyle/ChangeLog b/x11-themes/qgtkstyle/ChangeLog
index 6f5321832b7f..686ab14a3766 100644
--- a/x11-themes/qgtkstyle/ChangeLog
+++ b/x11-themes/qgtkstyle/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-themes/qgtkstyle
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/ChangeLog,v 1.5 2010/11/13 20:53:07 wired Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/ChangeLog,v 1.6 2011/03/02 01:00:27 wired Exp $
+
+*qgtkstyle-4.7.2 (02 Mar 2011)
+*qgtkstyle-4.7.1-r2 (02 Mar 2011)
+
+ 02 Mar 2011; Alex Alexander <wired@gentoo.org> -qgtkstyle-4.6.3.ebuild,
+ -qgtkstyle-4.6.3-r1.ebuild, -qgtkstyle-4.7.1.ebuild,
+ -qgtkstyle-4.7.1-r1.ebuild, +qgtkstyle-4.7.1-r2.ebuild,
+ +qgtkstyle-4.7.2.ebuild, files/main.cpp:
+ version bump, renamed style to GTK+, removed old
13 Nov 2010; Alex Alexander <wired@gentoo.org> qgtkstyle-4.6.3-r1.ebuild,
qgtkstyle-4.7.1-r1.ebuild:
diff --git a/x11-themes/qgtkstyle/files/main.cpp b/x11-themes/qgtkstyle/files/main.cpp
index 51f2ad7cbfee..12786b4f5f3d 100644
--- a/x11-themes/qgtkstyle/files/main.cpp
+++ b/x11-themes/qgtkstyle/files/main.cpp
@@ -37,12 +37,12 @@ QGtkStylePlugin::QGtkStylePlugin()
QStyle *QGtkStylePlugin::create(const QString &key)
{
- return (key.toLower() == "gtk") ? new QGtkStyle : 0;
+ return (key.toLower() == "gtk+") ? new QGtkStyle : 0;
}
QStringList QGtkStylePlugin::keys() const
{
- return QStringList() << "GTK";
+ return QStringList() << "GTK+";
}
Q_EXPORT_PLUGIN2(qgtkstyle, QGtkStylePlugin)
diff --git a/x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild b/x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild
deleted file mode 100644
index 3f28afc92181..000000000000
--- a/x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild,v 1.3 2010/11/10 21:29:11 hwoarang Exp $
-
-EAPI="3"
-inherit qt4-r2
-
-MY_PV=${PV/_/-}
-MY_P=qt-everywhere-opensource-src-${MY_PV}
-
-DESCRIPTION="Qt style that uses the active GTK theme."
-HOMEPAGE="http://qt.nokia.com/"
-SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 GPL-3 )"
-SLOT="4"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-COMMON_DEPEND="
- x11-libs/gtk+:2
- >=x11-libs/qt-gui-${PV}-r1
-"
-DEPEND="${COMMON_DEPEND}
- x11-libs/cairo
-"
-RDEPEND="${COMMON_DEPEND}
- !>x11-libs/qt-gui-${PV}-r9999
-"
-
-src_unpack() {
- tar xzf "${DISTDIR}"/${MY_P}.tar.gz ${MY_P}/src/gui/styles/ || die
- mv ${MY_P}/src/gui/styles "${S}" || die
- cp "${FILESDIR}"/qgtkstyle.pro "${S}"/ || die
-}
diff --git a/x11-themes/qgtkstyle/qgtkstyle-4.7.1-r1.ebuild b/x11-themes/qgtkstyle/qgtkstyle-4.7.1-r2.ebuild
index 812dab03394f..a481bced1e31 100644
--- a/x11-themes/qgtkstyle/qgtkstyle-4.7.1-r1.ebuild
+++ b/x11-themes/qgtkstyle/qgtkstyle-4.7.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/qgtkstyle-4.7.1-r1.ebuild,v 1.2 2010/11/13 20:53:07 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/qgtkstyle-4.7.1-r2.ebuild,v 1.1 2011/03/02 01:00:27 wired Exp $
EAPI="3"
inherit confutils qt4-build
@@ -64,3 +64,11 @@ src_install() {
insinto /usr/$(get_libdir)/qt4/plugins/styles/ || die
doins lib/libgtkstyle.so || die
}
+
+pkg_postinst() {
+ ewarn
+ ewarn "The style provided by this package has been renamed to GTK+ (from GTK)"
+ ewarn "to match upstream naming. You may have to re-select it using"
+ ewarn "qtconfig or systemsettings (in KDE)."
+ ewarn
+}
diff --git a/x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild b/x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild
deleted file mode 100644
index 0304d3c2d65e..000000000000
--- a/x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild,v 1.1 2010/11/10 10:52:13 wired Exp $
-
-EAPI="3"
-inherit qt4-r2
-
-MY_PV=${PV/_/-}
-MY_P=qt-everywhere-opensource-src-${MY_PV}
-
-DESCRIPTION="Qt style that uses the active GTK theme."
-HOMEPAGE="http://qt.nokia.com/"
-SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 GPL-3 )"
-SLOT="4"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-COMMON_DEPEND="
- x11-libs/gtk+:2
- >=x11-libs/qt-gui-${PV}-r1
-"
-DEPEND="${COMMON_DEPEND}
- x11-libs/cairo
-"
-RDEPEND="${COMMON_DEPEND}
- !>x11-libs/qt-gui-${PV}-r9999
-"
-
-src_unpack() {
- tar xzf "${DISTDIR}"/${MY_P}.tar.gz ${MY_P}/src/gui/styles/ || die
- mv ${MY_P}/src/gui/styles "${S}" || die
- cp "${FILESDIR}"/qgtkstyle.pro "${S}"/ || die
-}
diff --git a/x11-themes/qgtkstyle/qgtkstyle-4.6.3-r1.ebuild b/x11-themes/qgtkstyle/qgtkstyle-4.7.2.ebuild
index 65d8d3aeb232..c34a6ea8632e 100644
--- a/x11-themes/qgtkstyle/qgtkstyle-4.6.3-r1.ebuild
+++ b/x11-themes/qgtkstyle/qgtkstyle-4.7.2.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/qgtkstyle-4.6.3-r1.ebuild,v 1.2 2010/11/13 20:53:07 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/qgtkstyle-4.7.2.ebuild,v 1.1 2011/03/02 01:00:27 wired Exp $
EAPI="3"
inherit confutils qt4-build
DESCRIPTION="Qt style that uses the active GTK theme."
SLOT="4"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE=""
COMMON_DEPEND="
x11-libs/gtk+:2
- >=x11-libs/qt-gui-${PV}-r1
+ ~x11-libs/qt-gui-${PV}
"
DEPEND="${COMMON_DEPEND}
|| ( >=x11-libs/cairo-1.10.0[-qt4] <x11-libs/cairo-1.10.0 )
@@ -53,7 +53,7 @@ src_configure() {
myconf="${myconf} -qt-gif -system-libpng -system-libjpeg
-no-sql-mysql -no-sql-psql -no-sql-ibase -no-sql-sqlite -no-sql-sqlite2
-no-sql-odbc -no-xrender -no-xrandr -no-xkb -no-xshape -no-sm -no-svg -no-webkit
- -no-cups -no-glib -no-libmng -no-nis -no-libtiff -no-dbus -no-qdbus
+ -no-cups -no-glib -no-libmng -no-nis -no-libtiff -no-dbus -no-qdbus -no-egl
-no-qt3support -no-xinerama -no-phonon -no-opengl -no-accessibility
-gtkstyle"
@@ -64,3 +64,11 @@ src_install() {
insinto /usr/$(get_libdir)/qt4/plugins/styles/ || die
doins lib/libgtkstyle.so || die
}
+
+pkg_postinst() {
+ ewarn
+ ewarn "The style provided by this package has been renamed to GTK+ (from GTK)"
+ ewarn "to match upstream naming. You may have to re-select it using"
+ ewarn "qtconfig or systemsettings (in KDE)."
+ ewarn
+}