summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/abiword-1.0.4_pre1-r2.ebuild79
-rw-r--r--app-office/abiword/files/digest-abiword-1.0.4_pre1-r21
3 files changed, 86 insertions, 1 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 3ccdeeff1869..2d642aa0be57 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.21 2002/12/15 21:34:48 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.22 2002/12/22 21:59:19 foser Exp $
+
+*abiword-1.0.4_pre1-r2 (22 Dec 2002)
+
+ 22 Dec 2002; foser <foser@gentoo.org> abiword-1.0.4_pre1-r2.ebuild :
+ And we're giving the perl stuff a chance again
*abiword-1.0.4_pre1-r1 (19 Nov 2002)
diff --git a/app-office/abiword/abiword-1.0.4_pre1-r2.ebuild b/app-office/abiword/abiword-1.0.4_pre1-r2.ebuild
new file mode 100644
index 000000000000..061442c22afc
--- /dev/null
+++ b/app-office/abiword/abiword-1.0.4_pre1-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.0.4_pre1-r2.ebuild,v 1.1 2002/12/22 21:59:19 foser Exp $
+
+IUSE="perl nls gnome build spell jpeg xml2"
+S=${WORKDIR}/${P}/abi
+DESCRIPTION="Text processor"
+SRC_URI="http://download.sourceforge.net/abiword/abiword-${PV}.tar.gz"
+HOMEPAGE="http://www.abisource.com"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="virtual/x11
+ media-libs/libpng
+ >=dev-libs/libunicode-0.4-r1
+ =x11-libs/gtk+-1.2*
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ spell? ( >=app-text/aspell-0.50.2-r1 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-base/bonobo-1.0.9-r1 )
+ perl? ( >=sys-devel/perl-5.6 )
+ !app-shells/bash-completion"
+
+src_compile() {
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --with-gnome --enable-gnome"; \
+ export ABI_OPT_BONOBO=1
+
+ use perl \
+ && myconf="${myconf} --enable-scripting" \
+ || myconf="${myconf} --disable-scripting"
+
+ use spell \
+ && myconf="${myconf} --with-pspell --disable-static"
+
+ use xml2 \
+ && myconf="${myconf} --with-libxml2"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg"
+
+ use nls \
+ && myconf="${myconf} --enable-bidi"
+
+ ./autogen.sh
+
+ einfo "Ignore above ERROR as it does not cause build to fail."
+
+ CFLAGS="${CFLAGS} `gdk-pixbuf-config --cflags`"
+
+ econf ${myconf}
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ einstall PERLDEST=${D}
+
+ dosed "s:${D}::g" /usr/bin/AbiWord
+
+ rm -f ${D}/usr/bin/abiword
+ dosym /usr/bin/AbiWord /usr/bin/abiword
+
+ dodoc BUILD COPYING *.txt, *.TXT
+
+ # Install icon and .desktop for menu entry
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ )
+}
diff --git a/app-office/abiword/files/digest-abiword-1.0.4_pre1-r2 b/app-office/abiword/files/digest-abiword-1.0.4_pre1-r2
new file mode 100644
index 000000000000..dd402c5595f5
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-1.0.4_pre1-r2
@@ -0,0 +1 @@
+MD5 ed6e30c33f1bfcff16a31737ee69b1db abiword-1.0.4_pre1.tar.gz 19231850