summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/libskk/ChangeLog7
-rw-r--r--app-i18n/libskk/libskk-1.0.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-i18n/libskk/ChangeLog b/app-i18n/libskk/ChangeLog
index 9544db70bbcf..fe8d1ebe0c20 100644
--- a/app-i18n/libskk/ChangeLog
+++ b/app-i18n/libskk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/libskk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/libskk/ChangeLog,v 1.6 2013/05/04 00:09:34 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libskk/ChangeLog,v 1.7 2013/08/03 14:06:54 hattya Exp $
+
+*libskk-1.0.1 (03 Aug 2013)
+
+ 03 Aug 2013; Akinori Hattori <hattya@gentoo.org> +libskk-1.0.1.ebuild:
+ new upstream release
04 May 2013; Naohiro Aota <naota@gentoo.org> libskk-0.0.11.ebuild,
libskk-0.0.12.ebuild, libskk-0.0.9.ebuild:
diff --git a/app-i18n/libskk/libskk-1.0.1.ebuild b/app-i18n/libskk/libskk-1.0.1.ebuild
new file mode 100644
index 000000000000..c0404550b602
--- /dev/null
+++ b/app-i18n/libskk/libskk-1.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libskk/libskk-1.0.1.ebuild,v 1.1 2013/08/03 14:06:54 hattya Exp $
+
+EAPI="5"
+
+VALA_MIN_API_VERSION="0.14"
+
+inherit virtualx vala
+
+DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
+HOMEPAGE="https://github.com/ueno/libskk"
+SRC_URI="mirror://bitbucket/${PN}/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls +introspection static-libs"
+
+RDEPEND=">=dev-libs/glib-2.16
+ dev-libs/libgee:0
+ dev-libs/json-glib
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+# doc? ( >=dev-util/valadoc-0.3.1 )
+
+DOCS="ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable introspection)
+}
+
+src_test() {
+ Xemake check || die "emake check failed."
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/lib*/lib*.la
+}