summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/gdl/ChangeLog7
-rw-r--r--dev-libs/gdl/gdl-3.12.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-libs/gdl/ChangeLog b/dev-libs/gdl/ChangeLog
index 965a4ee2bdc9..edb5d8417a56 100644
--- a/dev-libs/gdl/ChangeLog
+++ b/dev-libs/gdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gdl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/ChangeLog,v 1.104 2014/04/25 18:59:53 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/ChangeLog,v 1.105 2014/04/27 16:04:09 eva Exp $
+
+*gdl-3.12.0 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +gdl-3.12.0.ebuild:
+ Version bump for Gnome 3.12.
25 Apr 2014; Pacho Ramos <pacho@gentoo.org> -gdl-2.30.1.ebuild,
-gdl-3.6.2.ebuild, -gdl-3.8.1.ebuild:
diff --git a/dev-libs/gdl/gdl-3.12.0.ebuild b/dev-libs/gdl/gdl-3.12.0.ebuild
new file mode 100644
index 000000000000..f9fa173a5d41
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/gdl-3.12.0.ebuild,v 1.1 2014/04/27 16:04:09 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://developer.gnome.org/gdl/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure $(use_enable introspection)
+}