summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tcltk/snack/ChangeLog5
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r4.ebuild105
2 files changed, 4 insertions, 106 deletions
diff --git a/dev-tcltk/snack/ChangeLog b/dev-tcltk/snack/ChangeLog
index 65737ee8b380..83e08cf98703 100644
--- a/dev-tcltk/snack/ChangeLog
+++ b/dev-tcltk/snack/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/snack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/ChangeLog,v 1.59 2013/09/05 19:44:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/ChangeLog,v 1.60 2013/09/11 10:06:18 pinkbyte Exp $
+
+ 11 Sep 2013; Sergey Popov <pinkbyte@gentoo.org> -snack-2.2.10-r4.ebuild:
+ Cleanup vulnerable revision, wrt bug #446822
05 Sep 2013; Michał Górny <mgorny@gentoo.org> snack-2.2.10-r6.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-tcltk/snack/snack-2.2.10-r4.ebuild b/dev-tcltk/snack/snack-2.2.10-r4.ebuild
deleted file mode 100644
index 9a7a5514f135..000000000000
--- a/dev-tcltk/snack/snack-2.2.10-r4.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.10-r4.ebuild,v 1.10 2011/04/12 18:13:12 arfrever Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit eutils distutils multilib
-
-DESCRIPTION="The Snack Sound Toolkit (Tcl)"
-HOMEPAGE="http://www.speech.kth.se/snack/"
-SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-SLOT="0"
-IUSE="alsa examples python threads vorbis"
-
-RESTRICT="test" # Bug 78354
-
-DEPEND="
- >dev-lang/tcl-8.4.3
- >dev-lang/tk-8.4.3
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}${PV}/unix"
-
-PYTHON_MODNAME="tkSnack.py"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # bug 226137 - snack depends on alsa private symbol _snd_pcm_mmap_hw_ptr
- epatch "${FILESDIR}"/alsa-undef-sym.patch
- # bug 270839 - error from /usr/include/bits/mathcalls.h:310
- sed -i -e 's|^\(#define roundf(.*\)|//\1|' ../generic/jkFormatMP3.c
-
- # adds -install_name (soname on Darwin)
- [[ ${CHOST} == *-darwin* ]] && epatch "${FILESDIR}"/${P}-darwin.patch
-}
-
-src_configure() {
- local myconf="--libdir="${EPREFIX}"/usr/$(get_libdir) --includedir="${EPREFIX}"/usr/include"
-
- use alsa && myconf="${myconf} --enable-alsa"
- use threads && myconf="${myconf} --enable-threads"
-
- if use vorbis ; then
- myconf="${myconf} --with-ogg-include="${EPREFIX}"/usr/include"
- myconf="${myconf} --with-ogg-lib="${EPREFIX}"/usr/$(get_libdir)"
- fi
-
- econf ${myconf} || die "configure failed"
-}
-
-src_compile() {
- # We do not want to run distutils_src_compile
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- if use python ; then
- cd "${S}"/../python
- distutils_src_install
- fi
-
- cd "${S}"/..
-
- dodoc README changes || die
- dohtml doc/* || die
-
- if use examples ; then
- sed -i -e 's/wish[0-9.]+/wish/g' demos/tcl/* || die
- docinto examples/tcl
- dodoc demos/tcl/* || die
-
- if use python ; then
- docinto examples/python
- dodoc demos/python/* || die
- fi
- fi
-}
-
-pkg_postinst() {
- if use python; then
- distutils_pkg_postinst
- fi
-}
-
-pkg_postrm() {
- if use python; then
- distutils_pkg_postrm
- fi
-}