summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/geany-plugins/ChangeLog11
-rw-r--r--dev-util/geany-plugins/files/geany-plugins-0.20-geanyprj-outsrc-tests.patch15
-rw-r--r--dev-util/geany-plugins/geany-plugins-0.20.ebuild56
-rw-r--r--dev-util/geany-plugins/metadata.xml2
4 files changed, 82 insertions, 2 deletions
diff --git a/dev-util/geany-plugins/ChangeLog b/dev-util/geany-plugins/ChangeLog
index 7f7895fc4674..d966c1299bf8 100644
--- a/dev-util/geany-plugins/ChangeLog
+++ b/dev-util/geany-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/geany-plugins
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/ChangeLog,v 1.1 2010/07/08 07:39:30 polynomial-c Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/ChangeLog,v 1.2 2011/01/21 11:19:29 polynomial-c Exp $
+
+*geany-plugins-0.20 (21 Jan 2011)
+
+ 21 Jan 2011; Lars Wendler <polynomial-c@gentoo.org>
+ +geany-plugins-0.20.ebuild,
+ +files/geany-plugins-0.20-geanyprj-outsrc-tests.patch, metadata.xml:
+ Version bump by Nathan (bug #352172).
*geany-plugins-0.19 (08 Jul 2010)
diff --git a/dev-util/geany-plugins/files/geany-plugins-0.20-geanyprj-outsrc-tests.patch b/dev-util/geany-plugins/files/geany-plugins-0.20-geanyprj-outsrc-tests.patch
new file mode 100644
index 000000000000..a8aa4c13f7f1
--- /dev/null
+++ b/dev-util/geany-plugins/files/geany-plugins-0.20-geanyprj-outsrc-tests.patch
@@ -0,0 +1,15 @@
+Author: Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+Date: 2011/01/20
+Purpose: Fix test compilation failure in geanyprj for out-of-source builds.
+Bug: https://sourceforge.net/tracker/?func=detail&aid=3163117&group_id=222729&atid=1056532
+
+--- a/geany-plugins/geanyprj/tests/Makefile.am
++++ b/geany-plugins/geanyprj/tests/Makefile.am
+@@ -1,6 +1,6 @@
+ if UNITTESTS
+ include $(top_srcdir)/build/vars.build.mk
+-INCLUDES = $(GEANY_CFLAGS) -I../src -DUNITTESTS
++INCLUDES = $(GEANY_CFLAGS) -I$(srcdir)/../src -DUNITTESTS
+ TESTS=unittests
+ noinst_PROGRAMS=unittests
+ unittests_SOURCES = unittests.c ../src/utils.c
diff --git a/dev-util/geany-plugins/geany-plugins-0.20.ebuild b/dev-util/geany-plugins/geany-plugins-0.20.ebuild
new file mode 100644
index 000000000000..41dd265c2067
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-0.20.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/geany-plugins-0.20.ebuild,v 1.1 2011/01/21 11:19:29 polynomial-c Exp $
+
+EAPI="2"
+
+inherit autotools autotools-utils eutils versionator
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="http://plugins.geany.org/geany-plugins"
+SRC_URI="http://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="enchant gtkspell lua nls soup webkit"
+
+LINGUAS="be ca da de es fr gl ja pt pt_BR ru tr zh_CN"
+
+RDEPEND="=dev-util/geany-$(get_version_component_range 1-2)*
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ enchant? ( app-text/enchant )
+ gtkspell? ( app-text/gtkspell )
+ lua? ( dev-lang/lua )
+ soup? ( net-libs/libsoup )
+ webkit? (
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # https://sourceforge.net/tracker/?func=detail&aid=3163117&group_id=222729&atid=1056532
+ epatch "${FILESDIR}"/${P}-geanyprj-outsrc-tests.patch
+
+ eautomake
+}
+
+src_configure() {
+ # GeanyGenDoc requires ctpl which isn't yet in portage
+ local myeconfargs=(
+ --disable-geanygendoc
+ $(use_enable enchant spellcheck)
+ $(use_enable gtkspell)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ $(use_enable soup updatechecker)
+ $(use_enable webkit webhelper)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/geany-plugins/metadata.xml b/dev-util/geany-plugins/metadata.xml
index 34e7bf8da600..68d999185325 100644
--- a/dev-util/geany-plugins/metadata.xml
+++ b/dev-util/geany-plugins/metadata.xml
@@ -14,5 +14,7 @@
<use>
<flag name='enchant'>Enable spell checking using enchant</flag>
<flag name='gtkspell'>Use gtkspell for dictionary support</flag>
+ <flag name='soup'>Enable updatechecker plugin which requires net-libs/libsoup</flag>
+ <flag name='webkit'>Enable webhelper plugin which requires net-libs/webkit-gtk</flag>
</use>
</pkgmetadata>