summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/tcvp/ChangeLog8
-rw-r--r--media-video/tcvp/Manifest4
-rw-r--r--media-video/tcvp/files/digest-tcvp-0.2.01
-rw-r--r--media-video/tcvp/metadata.xml9
-rw-r--r--media-video/tcvp/tcvp-0.2.0.ebuild50
5 files changed, 72 insertions, 0 deletions
diff --git a/media-video/tcvp/ChangeLog b/media-video/tcvp/ChangeLog
new file mode 100644
index 000000000000..45ad6bc2dfa7
--- /dev/null
+++ b/media-video/tcvp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-video/tcvp
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tcvp/ChangeLog,v 1.1 2004/06/04 10:39:12 zypher Exp $
+
+*tcvp-0.2.0 (31 May 2004)
+
+ 04 Jun 2004; Marc Hildebrand <zypher@gentoo.org> :
+ Initial ebuild.
diff --git a/media-video/tcvp/Manifest b/media-video/tcvp/Manifest
new file mode 100644
index 000000000000..574935584afd
--- /dev/null
+++ b/media-video/tcvp/Manifest
@@ -0,0 +1,4 @@
+MD5 233d77d3514274b28cd4e2f2584017d8 tcvp-0.2.0.ebuild 1415
+MD5 2c9d7b22bf2dad42aad1f5bf6ef371a6 ChangeLog 223
+MD5 eba326432d26a3e8eb926c52124bbb9c metadata.xml 257
+MD5 f0f7a5d05e5be4ecf1f0a478b739f10a files/digest-tcvp-0.2.0 63
diff --git a/media-video/tcvp/files/digest-tcvp-0.2.0 b/media-video/tcvp/files/digest-tcvp-0.2.0
new file mode 100644
index 000000000000..dbf1de92a6f6
--- /dev/null
+++ b/media-video/tcvp/files/digest-tcvp-0.2.0
@@ -0,0 +1 @@
+MD5 629d16dc49e01abfba6bf0bb0c76d4c5 tcvp-0.2.0.tar.bz2 400976
diff --git a/media-video/tcvp/metadata.xml b/media-video/tcvp/metadata.xml
new file mode 100644
index 000000000000..7e2267698e35
--- /dev/null
+++ b/media-video/tcvp/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-video</herd>
+<maintainer>
+ <email>zypher@gentoo.org</email>
+ <name>Marc Hildebrand</name>
+</maintainer>
+</pkgmetadata>
diff --git a/media-video/tcvp/tcvp-0.2.0.ebuild b/media-video/tcvp/tcvp-0.2.0.ebuild
new file mode 100644
index 000000000000..b60b9008a1bb
--- /dev/null
+++ b/media-video/tcvp/tcvp-0.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tcvp/tcvp-0.2.0.ebuild,v 1.1 2004/06/04 10:39:12 zypher Exp $
+
+DESCRIPTION="TCVP is a modular player and encoder/transcoder for music and video."
+HOMEPAGE="http://tcvp.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="OpenSoftware"
+KEYWORDS="~x86"
+
+IUSE="alsa cdr dvd encode ffmpeg oggvorbis oss static"
+
+RDEPEND="virtual/x11
+ >=media-libs/freetype-2.1.5-r1
+ >=media-libs/audiofile-0.2.5
+ >=media-libs/libmpeg2-0.4.0b
+ >=media-sound/madplay-0.15.2b
+ >=dev-libs/libtc-1.1.0
+ >=dev-libs/tc2-0.6.0
+ >=dev-libs/tc2-modules-0.6.0
+ >=media-libs/faac-1.23.5
+ alsa? ( >=media-libs/alsa-lib-1.0.3b-r2 )
+ encode? ( >=media-sound/lame-3.96 )
+ oggvorbis? ( >=media-libs/libogg-1.1
+ >=media-libs/libvorbis-1.0.1-r2 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.8 )
+ cdr? ( >=media-sound/cdparanoia-3.9.8-r1 )
+ dvd? ( >=media-libs/libdvdread-0.9.4
+ >=media-libs/a52dec-0.7.4 )"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+ use static && myconf="${myconf} --enable-static"
+ use alsa || myconf="${myconf} --disable-alsa"
+ use encode || myconf="${myconf} --disable-lame"
+ use dvd || myconf="${myconf} --disable-dvd --disable-a52"
+ use oss || myconf="${myconf} --disable-oss"
+ econf ${myconf} || die "configure failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING
+}
+
+