summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/commons-io/ChangeLog8
-rw-r--r--dev-java/commons-io/Manifest19
-rw-r--r--dev-java/commons-io/commons-io-1.1.ebuild56
-rw-r--r--dev-java/commons-io/files/commons-io-1.1-gentoo.diff11
-rw-r--r--dev-java/commons-io/files/digest-commons-io-1.11
5 files changed, 81 insertions, 14 deletions
diff --git a/dev-java/commons-io/ChangeLog b/dev-java/commons-io/ChangeLog
index 2b8f0cb7361c..1a53bcd0b2a6 100644
--- a/dev-java/commons-io/ChangeLog
+++ b/dev-java/commons-io/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-io
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.2 2005/05/04 16:59:57 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.3 2005/12/04 18:38:25 nichoj Exp $
+
+*commons-io-1.1 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Nichols <nichoj@gentoo.org>
+ +files/commons-io-1.1-gentoo.diff, +commons-io-1.1.ebuild:
+ Version bump. Thanks to bware for reporting (bug #113585).
04 May 2005; Jan Brinkmann <luckyduck@gentoo.org> commons-io-1.0.ebuild:
stable on amd64 and x86, added ~ppc to KEYWORDS. introduced support for the
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
index c24fa25fd6bc..e8a7bd003bc7 100644
--- a/dev-java/commons-io/Manifest
+++ b/dev-java/commons-io/Manifest
@@ -1,15 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 22ede968591534e009ed15edb74cfacf ChangeLog 855
MD5 19777a525a3840cd2f2d08d286e6f4ab commons-io-1.0.ebuild 1358
-MD5 1822014318ff58d7aeed32a1b9d1af96 ChangeLog 651
-MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-MD5 5c8037358c1bd4650695b23df55e89fe files/digest-commons-io-1.0 70
+MD5 e761bb1732f86e4719bd7ecbf4d02574 commons-io-1.1.ebuild 1540
MD5 d1ce414440c549e8c25716008f452630 files/commons-io-1.0-gentoo.diff 932
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC07Ev/rLF9B432nYRAnQJAJ9k78d6GLwdcDlmR4+Da4BjxqAqeQCfei+O
-/YjwegOLhAqRMHTl9sAxrW8=
-=AjXR
------END PGP SIGNATURE-----
+MD5 c85588e58e9dcc2fcde64e1d4615bb12 files/commons-io-1.1-gentoo.diff 508
+MD5 5c8037358c1bd4650695b23df55e89fe files/digest-commons-io-1.0 70
+MD5 bfb5089b2c9985a4bcb9e9ff84e022a7 files/digest-commons-io-1.1 70
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
diff --git a/dev-java/commons-io/commons-io-1.1.ebuild b/dev-java/commons-io/commons-io-1.1.ebuild
new file mode 100644
index 000000000000..3a9f37b8aad7
--- /dev/null
+++ b/dev-java/commons-io/commons-io-1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-1.1.ebuild,v 1.1 2005/12/04 18:38:25 nichoj Exp $
+
+inherit java-pkg eutils
+
+MY_P="${P}-src"
+DESCRIPTION="Commons-IO contains utility classes , stream implementations, file filters , and endian classes."
+HOMEPAGE="http://jakarta.apache.org/commons/io"
+SRC_URI="mirror://apache/jakarta/commons/io/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="1"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc jikes source"
+
+DEPEND="jikes? ( >=dev-java/jikes-1.21 )
+ dev-java/ant-core
+ source? ( app-arch/zip )
+ >=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+
+S="${WORKDIR}/${MY_P}"
+
+# junit tests are disabled for now.
+# one of the tests (FileUtilsCleanDirectoryTestCase) always fails when run as
+# root.
+# TODO report upstream
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ mkdir -p build/lib
+ cd build/lib
+# use junit && java-pkg_jar-from junit
+}
+
+src_compile() {
+ local antflags="jar -Dlibdir=build/lib"
+ use doc && antflags="${antflags} javadoc -Djavadocdir=dist/docs/api"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+# use junit && antflags="${antflags} test"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+ dohtml PROPOSAL.html STATUS.html usersguide.html
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-io/files/commons-io-1.1-gentoo.diff b/dev-java/commons-io/files/commons-io-1.1-gentoo.diff
new file mode 100644
index 000000000000..62a7c51550e9
--- /dev/null
+++ b/dev-java/commons-io/files/commons-io-1.1-gentoo.diff
@@ -0,0 +1,11 @@
+--- build.xml.orig 2005-11-25 19:53:06.000000000 +0000
++++ build.xml 2005-11-25 19:54:39.000000000 +0000
+@@ -92,7 +94,7 @@
+ </copy>
+ </target>
+
+- <target name="jar" description="o Create the jar" depends="compile,test">
++ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/*.html" basedir="${classesdir}" manifest="${basedir}/src/conf/MANIFEST.MF" />
+ </target>
+ <target name="dist-jar" depends="compile">
diff --git a/dev-java/commons-io/files/digest-commons-io-1.1 b/dev-java/commons-io/files/digest-commons-io-1.1
new file mode 100644
index 000000000000..be3229d48ab8
--- /dev/null
+++ b/dev-java/commons-io/files/digest-commons-io-1.1
@@ -0,0 +1 @@
+MD5 0a39b54885b86dc42169ffd761caf414 commons-io-1.1-src.tar.gz 197922