summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/mtpfs/ChangeLog7
-rw-r--r--sys-fs/mtpfs/mtpfs-1.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-fs/mtpfs/ChangeLog b/sys-fs/mtpfs/ChangeLog
index 65ee13ca2854..ac3cea35deed 100644
--- a/sys-fs/mtpfs/ChangeLog
+++ b/sys-fs/mtpfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/mtpfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtpfs/ChangeLog,v 1.3 2012/02/15 00:20:41 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtpfs/ChangeLog,v 1.4 2012/02/29 13:07:27 voyageur Exp $
+
+*mtpfs-1.1 (29 Feb 2012)
+
+ 29 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org> +mtpfs-1.1.ebuild:
+ Version bump, adds support for multiple storage areas
*mtpfs-1.0 (15 Feb 2012)
diff --git a/sys-fs/mtpfs/mtpfs-1.1.ebuild b/sys-fs/mtpfs/mtpfs-1.1.ebuild
new file mode 100644
index 000000000000..50cdf11048d8
--- /dev/null
+++ b/sys-fs/mtpfs/mtpfs-1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtpfs/mtpfs-1.1.ebuild,v 1.1 2012/02/29 13:07:27 voyageur Exp $
+
+EAPI=4
+
+DESCRIPTION="A FUSE filesystem providing access to MTP devices"
+HOMEPAGE="http://www.adebenham.com/mtpfs/"
+SRC_URI="http://www.adebenham.com/files/mtp/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/glib:2
+ media-libs/libid3tag
+ media-libs/libmad
+ >=media-libs/libmtp-1.1.2
+ sys-fs/fuse"
+RDEPEND="${DEPEND}"
+
+DOCS=(AUTHORS NEWS README)
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+pkg_postinst() {
+ einfo "To mount your MTP device, issue:"
+ einfo " /usr/bin/mtpfs <mountpoint>"
+ echo
+ einfo "To unmount your MTP device, issue:"
+ einfo " /usr/bin/fusermount -u <mountpoint>"
+
+ if use debug; then
+ echo
+ einfo "You have enabled debugging output."
+ einfo "Please make sure you run mtpfs with the -d flag."
+ fi
+}