summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/bittorrent/ChangeLog9
-rw-r--r--net-p2p/bittorrent/bittorrent-5.0.4.ebuild80
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-5.0.43
3 files changed, 90 insertions, 2 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 77fc38c41b9e..5a420d1592c5 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.94 2006/12/28 19:00:17 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.95 2007/01/16 15:53:09 armin76 Exp $
+
+*bittorrent-5.0.4 (16 Jan 2007)
+
+ 16 Jan 2007; Raúl Porcel <armin76@gentoo.org> +bittorrent-5.0.4.ebuild:
+ Version bump
28 Dec 2006; Mike Frysinger <vapier@gentoo.org>
files/bittorrent-tracker.confd, files/bittorrent-tracker.initd,
diff --git a/net-p2p/bittorrent/bittorrent-5.0.4.ebuild b/net-p2p/bittorrent/bittorrent-5.0.4.ebuild
new file mode 100644
index 000000000000..73b1976b776f
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-5.0.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.0.4.ebuild,v 1.1 2007/01/16 15:53:09 armin76 Exp $
+
+inherit distutils fdo-mime eutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://download.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gtk"
+
+RDEPEND=">=dev-lang/python-2.3
+ gtk? (
+ >=x11-libs/wxGTK-2.6
+ >=dev-python/wxpython-2.6
+ )
+ >=dev-python/pycrypto-2.0
+ >=dev-python/twisted-2
+ dev-python/twisted-web
+ net-zope/zopeinterface
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="README.txt TRACKERLESS.txt public.key credits.txt"
+PYTHON_MODNAME="BitTorrent"
+
+pkg_setup() {
+ if use gtk ; then
+ if ! built_with_use x11-libs/wxGTK unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ if ! built_with_use dev-python/wxpython unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # path for documentation is in lowercase #109743
+ sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
+}
+
+src_install() {
+ distutils_src_install
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
+ dohtml redirdonate.html
+
+ if use gtk ; then
+ doicon images/logo/bittorrent.ico
+ newicon images/logo/bittorrent_icon_32.png bittorrent.png
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent.png "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
+ fi
+
+ newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
+ newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ einfo "To run the init.d, please use /etc/init.d/bittorrent-tracker"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-5.0.4 b/net-p2p/bittorrent/files/digest-bittorrent-5.0.4
new file mode 100644
index 000000000000..e2767bea6f31
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-5.0.4
@@ -0,0 +1,3 @@
+MD5 3f6a1093102541e88a16d6c1c62e8bcc BitTorrent-5.0.4.tar.gz 2483141
+RMD160 7c0ca2c1a301461bb2b6f5ed2ea7decefb409602 BitTorrent-5.0.4.tar.gz 2483141
+SHA256 0f703639103f89b2b0184cef12e80aa1ee1565068c94280e3e93064b845408f2 BitTorrent-5.0.4.tar.gz 2483141