summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/selenium-webdriver/ChangeLog7
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.3.2.ebuild39
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.4.0.ebuild39
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.5.0.ebuild39
4 files changed, 6 insertions, 118 deletions
diff --git a/dev-ruby/selenium-webdriver/ChangeLog b/dev-ruby/selenium-webdriver/ChangeLog
index ce92ed6128fd..967cdca4a1a5 100644
--- a/dev-ruby/selenium-webdriver/ChangeLog
+++ b/dev-ruby/selenium-webdriver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/selenium-webdriver
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.10 2011/10/06 14:26:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.11 2011/10/26 17:58:42 graaff Exp $
+
+ 26 Oct 2011; Hans de Graaff <graaff@gentoo.org>
+ -selenium-webdriver-2.3.2.ebuild, -selenium-webdriver-2.4.0.ebuild,
+ -selenium-webdriver-2.5.0.ebuild:
+ Remove old versions.
*selenium-webdriver-2.8.0 (06 Oct 2011)
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.3.2.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.3.2.ebuild
deleted file mode 100644
index 297fdb210b04..000000000000
--- a/dev-ruby/selenium-webdriver/selenium-webdriver-2.3.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.3.2.ebuild,v 1.1 2011/08/06 06:27:19 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-# NOTE: this package contains precompiled code. It appears that all
-# source code can be found at http://code.google.com/p/selenium/ but the
-# repository is not organized in a way so that we can easily rebuild the
-# suited shared object. We'll just try our luck with the precompiled
-# objects for now.
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES README"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
-
-inherit ruby-fakegem
-
-DESCRIPTION="This gem provides Ruby bindings for WebDriver."
-HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/childprocess-0.1.9
- >=dev-ruby/ffi-1.0.7
- dev-ruby/json
- dev-ruby/rubyzip"
-
-all_ruby_prepare() {
- # Match gemspec metadata up with our dependency adjustments.
- sed -i -e 's/json_pure/json/' ../metadata || die
-}
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.4.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.4.0.ebuild
deleted file mode 100644
index 3638ca651d4f..000000000000
--- a/dev-ruby/selenium-webdriver/selenium-webdriver-2.4.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.4.0.ebuild,v 1.1 2011/08/12 06:16:13 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-# NOTE: this package contains precompiled code. It appears that all
-# source code can be found at http://code.google.com/p/selenium/ but the
-# repository is not organized in a way so that we can easily rebuild the
-# suited shared object. We'll just try our luck with the precompiled
-# objects for now.
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES README"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
-
-inherit ruby-fakegem
-
-DESCRIPTION="This gem provides Ruby bindings for WebDriver."
-HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/childprocess-0.1.9
- >=dev-ruby/ffi-1.0.7
- dev-ruby/json
- dev-ruby/rubyzip"
-
-all_ruby_prepare() {
- # Match gemspec metadata up with our dependency adjustments.
- sed -i -e 's/json_pure/json/' ../metadata || die
-}
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.5.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.5.0.ebuild
deleted file mode 100644
index 6f39f430c400..000000000000
--- a/dev-ruby/selenium-webdriver/selenium-webdriver-2.5.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.5.0.ebuild,v 1.1 2011/08/26 09:37:52 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-# NOTE: this package contains precompiled code. It appears that all
-# source code can be found at http://code.google.com/p/selenium/ but the
-# repository is not organized in a way so that we can easily rebuild the
-# suited shared object. We'll just try our luck with the precompiled
-# objects for now.
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES README"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
-
-inherit ruby-fakegem
-
-DESCRIPTION="This gem provides Ruby bindings for WebDriver."
-HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/childprocess-0.2.1
- >=dev-ruby/ffi-1.0.7
- dev-ruby/json
- dev-ruby/rubyzip"
-
-all_ruby_prepare() {
- # Match gemspec metadata up with our dependency adjustments.
- sed -i -e 's/json_pure/json/' ../metadata || die
-}