summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/pulseaudio/ChangeLog6
-rw-r--r--media-sound/pulseaudio/metadata.xml3
-rw-r--r--media-sound/pulseaudio/pulseaudio-3.0.ebuild10
-rw-r--r--media-sound/pulseaudio/pulseaudio-9999.ebuild10
4 files changed, 15 insertions, 14 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index 66c0f07213ce..fe778efee199 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.297 2013/02/15 08:51:56 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.298 2013/02/20 11:12:06 ford_prefect Exp $
+
+ 20 Feb 2013; Arun Raghavan <ford_prefect@gentoo.org> pulseaudio-3.0.ebuild,
+ pulseaudio-9999.ebuild, metadata.xml:
+ Switch USE=qt -> USE=qt4 to be able to reuse the global USE flag.
15 Feb 2013; Nirbheek Chauhan <nirbheek@gentoo.org> metadata.xml,
pulseaudio-3.0.ebuild, pulseaudio-9999.ebuild:
diff --git a/media-sound/pulseaudio/metadata.xml b/media-sound/pulseaudio/metadata.xml
index 748e8cf3e94d..af8e8805f59e 100644
--- a/media-sound/pulseaudio/metadata.xml
+++ b/media-sound/pulseaudio/metadata.xml
@@ -41,9 +41,6 @@
Makes PulseAudio use RealtimeKit (<pkg>sys-auth/rtkit</pkg>) to get
real-time priority while running.
</flag>
- <flag name="qt">
- Pull in deps for the equalizer GUI qpaeq (requires <pkg>dev-python/PyQt4</pkg>).
- </flag>
<flag name="equalizer">
Enable the equalizer module (requires <pkg>sci-libs/fftw</pkg>).
</flag>
diff --git a/media-sound/pulseaudio/pulseaudio-3.0.ebuild b/media-sound/pulseaudio/pulseaudio-3.0.ebuild
index 9df96e955049..1e45713d1548 100644
--- a/media-sound/pulseaudio/pulseaudio-3.0.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-3.0.ebuild,v 1.3 2013/02/15 08:51:56 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-3.0.ebuild,v 1.4 2013/02/20 11:12:06 ford_prefect Exp $
EAPI="4"
@@ -19,7 +19,7 @@ LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+alsa +asyncns avahi bluetooth +caps dbus doc equalizer +gdbm +glib gnome
-gtk ipv6 jack libsamplerate lirc neon +orc oss qt realtime ssl systemd
+gtk ipv6 jack libsamplerate lirc neon +orc oss qt4 realtime ssl systemd
system-wide tcpd test +udev +webrtc-aec +X xen"
RDEPEND=">=media-libs/libsndfile-1.0.20
@@ -80,7 +80,7 @@ PDEPEND="alsa? ( media-plugins/alsa-plugins[pulseaudio] )"
# bluez dep is for the bluetooth init.d script
# PyQt4 dep is for the qpaeq script
RDEPEND="${RDEPEND}
- equalizer? ( qt? ( dev-python/PyQt4[dbus] ) )
+ equalizer? ( qt4? ( dev-python/PyQt4[dbus] ) )
X? ( gnome-extra/gnome-audio )
system-wide? (
sys-apps/openrc
@@ -223,8 +223,8 @@ pkg_postinst() {
elog "your Bluetooth controller enabled and inserted at bootup or"
elog "PulseAudio will refuse to start."
fi
- if use equalizer && ! use qt; then
- elog "You've enabled the 'equalizer' USE-flag but not the 'qt' USE-flag."
+ if use equalizer && ! use qt4; then
+ elog "You've enabled the 'equalizer' USE-flag but not the 'qt4' USE-flag."
elog "This will build the equalizer module, but the 'qpaeq' tool"
elog "which is required to set equalizer levels will not work."
fi
diff --git a/media-sound/pulseaudio/pulseaudio-9999.ebuild b/media-sound/pulseaudio/pulseaudio-9999.ebuild
index 8db05fffb67a..e965c22194d3 100644
--- a/media-sound/pulseaudio/pulseaudio-9999.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-9999.ebuild,v 1.33 2013/02/15 08:51:56 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-9999.ebuild,v 1.34 2013/02/20 11:12:06 ford_prefect Exp $
EAPI="4"
@@ -19,7 +19,7 @@ LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
SLOT="0"
KEYWORDS=""
IUSE="+alsa +asyncns avahi bluetooth +caps dbus doc equalizer +gdbm +glib gnome
-gtk ipv6 jack libsamplerate lirc neon +orc oss qt realtime ssl systemd
+gtk ipv6 jack libsamplerate lirc neon +orc oss qt4 realtime ssl systemd
system-wide tcpd test +udev +webrtc-aec +X xen"
RDEPEND=">=media-libs/libsndfile-1.0.20
@@ -80,7 +80,7 @@ PDEPEND="alsa? ( media-plugins/alsa-plugins[pulseaudio] )"
# bluez dep is for the bluetooth init.d script
# PyQt4 dep is for the qpaeq script
RDEPEND="${RDEPEND}
- equalizer? ( qt? ( dev-python/PyQt4[dbus] ) )
+ equalizer? ( qt4? ( dev-python/PyQt4[dbus] ) )
X? ( gnome-extra/gnome-audio )
system-wide? (
sys-apps/openrc
@@ -225,8 +225,8 @@ pkg_postinst() {
elog "your Bluetooth controller enabled and inserted at bootup or"
elog "PulseAudio will refuse to start."
fi
- if use equalizer && ! use qt; then
- elog "You've enabled the 'equalizer' USE-flag but not the 'qt' USE-flag."
+ if use equalizer && ! use qt4; then
+ elog "You've enabled the 'equalizer' USE-flag but not the 'qt4' USE-flag."
elog "This will build the equalizer module, but the 'qpaeq' tool"
elog "which is required to set equalizer levels will not work."
fi