summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/nedit/ChangeLog7
-rw-r--r--app-editors/nedit/files/nedit-5.5_p20090914-ldflags.patch17
-rw-r--r--app-editors/nedit/nedit-5.5_p20090914.ebuild9
3 files changed, 30 insertions, 3 deletions
diff --git a/app-editors/nedit/ChangeLog b/app-editors/nedit/ChangeLog
index 50a4bdd3c896..f59074161c13 100644
--- a/app-editors/nedit/ChangeLog
+++ b/app-editors/nedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nedit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.55 2009/09/25 09:11:36 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.56 2009/10/25 17:36:06 vostorga Exp $
+
+ 25 Oct 2009; Víctor Ostorga <vostorga@gentoo.org>
+ nedit-5.5_p20090914.ebuild, +files/nedit-5.5_p20090914-ldflags.patch:
+ Respecting LDFLAGS, patch thanks to Justin Lecher <jlec@j-schmitz.net> bug
+ 290337
*nedit-5.5_p20090914 (25 Sep 2009)
diff --git a/app-editors/nedit/files/nedit-5.5_p20090914-ldflags.patch b/app-editors/nedit/files/nedit-5.5_p20090914-ldflags.patch
new file mode 100644
index 000000000000..4532c6251894
--- /dev/null
+++ b/app-editors/nedit/files/nedit-5.5_p20090914-ldflags.patch
@@ -0,0 +1,17 @@
+--- source/Makefile.common 2004-03-21 15:25:56.000000000 +0100
++++ source/Makefile.common.new 2009-10-24 10:47:03.667835157 +0200
+@@ -21,12 +21,12 @@
+ # we only want natural rebuilds to regenerate the link date.
+ nedit: $(OBJS) ../util/libNUtil.a $(XMLLIB) $(XLTLIB)
+ $(CC) $(CFLAGS) -c linkdate.c
+- $(CC) $(CFLAGS) $(OBJS) linkdate.o $(XMLLIB) \
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) linkdate.o $(XMLLIB) \
+ $(XLTLIB) ../util/libNUtil.a $(LIBS) -o $@
+
+ # Note LIBS isn't quite right here; it links unnecessarily against Motif
+ nc: nc.o server_common.o ../util/libNUtil.a
+- $(CC) $(CFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
+
+ help.o: help.c
+ $(CC) $(CFLAGS) $(BIGGER_STRINGS) -c help.c -o $@
diff --git a/app-editors/nedit/nedit-5.5_p20090914.ebuild b/app-editors/nedit/nedit-5.5_p20090914.ebuild
index 2619f589f21f..48bd19ba187f 100644
--- a/app-editors/nedit/nedit-5.5_p20090914.ebuild
+++ b/app-editors/nedit/nedit-5.5_p20090914.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5_p20090914.ebuild,v 1.1 2009/09/25 09:11:36 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5_p20090914.ebuild,v 1.2 2009/10/25 17:36:06 vostorga Exp $
EAPI=2
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="Multi-purpose text editor for the X Window System"
HOMEPAGE="http://nedit.org/"
@@ -25,6 +25,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}"
+src_prepare() {
+ #respecting LDFLAGS, bug #208189
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
src_configure() {
sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" -e "s:check_tif_rule::" \
makefiles/Makefile.linux || die