summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/submount/ChangeLog6
-rw-r--r--sys-fs/submount/submount-0.9-r2.ebuild12
2 files changed, 12 insertions, 6 deletions
diff --git a/sys-fs/submount/ChangeLog b/sys-fs/submount/ChangeLog
index d42dba214a5c..1c06a3d4e51f 100644
--- a/sys-fs/submount/ChangeLog
+++ b/sys-fs/submount/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/submount
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/ChangeLog,v 1.15 2005/02/17 19:39:23 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/ChangeLog,v 1.16 2005/03/28 11:48:13 genstef Exp $
+
+ 28 Mar 2005; Stefan Schweizer <genstef@gentoo.org> submount-0.9-r2.ebuild:
+ Resolve bug 86650 by setting S in every ebuild stage, also change KV_DIR to
+ KV_OUT_DIR thanks to johnm
17 Feb 2005; Stefan Schweizer <genstef@gentoo.org>
-submount-0.9-r1.ebuild:
diff --git a/sys-fs/submount/submount-0.9-r2.ebuild b/sys-fs/submount/submount-0.9-r2.ebuild
index 7204afdf6969..913b228310db 100644
--- a/sys-fs/submount/submount-0.9-r2.ebuild
+++ b/sys-fs/submount/submount-0.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/submount-0.9-r2.ebuild,v 1.3 2005/02/17 19:12:12 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/submount-0.9-r2.ebuild,v 1.4 2005/03/28 11:48:13 genstef Exp $
inherit linux-mod
@@ -12,10 +12,6 @@ LICENSE="GPL-2"
KEYWORDS="x86 ~alpha ppc ~sparc ~amd64"
IUSE=""
-MODULE_NAMES="subfs(fs:${S}/subfs-${MY_PV})"
-BUILD_PARAMS="KDIR=${KV_DIR}"
-BUILD_TARGETS="default"
-
pkg_setup() {
linux-mod_pkg_setup
if kernel_is 2 4
@@ -31,15 +27,20 @@ pkg_setup() {
MY_P="${PN}-${MY_PV}"
S="${WORKDIR}/${MY_P}"
+ MODULE_NAMES="subfs(fs:${S}/subfs-${MY_PV})"
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
+ BUILD_TARGETS="default"
}
src_unpack() {
+ S=${WORKDIR}/${MY_P}
unpack ${A}
cd ${S}
convert_to_m ${S}/subfs-${MY_PV}/Makefile
}
src_compile() {
+ S=${WORKDIR}/${MY_P}
cd ${S}/submountd-${MY_PV}
econf --sbindir=/sbin || die "econf failed"
emake || die "emake failed"
@@ -48,6 +49,7 @@ src_compile() {
}
src_install() {
+ S=${WORKDIR}/${MY_P}
cd ${S}/submountd-${MY_PV}
make install DESTDIR=${D} mandir=/usr/share/man || die "make install failed"