summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.5.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 79beea376a44..3ae223fd220a 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.183 2010/08/09 17:34:47 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.184 2010/09/05 23:24:33 tampakrap Exp $
+
+*kate-4.5.1 (05 Sep 2010)
+
+ 05 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org> +kate-4.5.1.ebuild:
+ Version bump
09 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org> kate-4.4.5.ebuild:
Drop alpha ia64 and sparc per the AT Lead permission.
diff --git a/kde-base/kate/kate-4.5.1.ebuild b/kde-base/kate/kate-4.5.1.ebuild
new file mode 100644
index 000000000000..319653b3cb96
--- /dev/null
+++ b/kde-base/kate/kate-4.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.5.1.ebuild,v 1.1 2010/09/05 23:24:33 tampakrap Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK=1
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS=""
+IUSE="debug +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}