summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/palo/ChangeLog9
-rw-r--r--sys-boot/palo/Manifest8
-rw-r--r--sys-boot/palo/files/digest-palo-1.5_pre200405151
-rw-r--r--sys-boot/palo/palo-1.5_pre20040515.ebuild38
4 files changed, 51 insertions, 5 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index 9bd9bd71ff5d..475c8223151b 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/palo
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.4 2004/03/26 19:08:53 gmsoft Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.5 2004/05/15 22:46:37 gmsoft Exp $
+
+*palo-1.5_pre20040515 (15 May 2004)
+
+ 15 May 2004; Guy Martin <gmsoft@gentoo.org> palo-1.5_pre20040515.ebuild:
+ Version bump. Add really cool options.
*palo-1.3_pre20040303 (26 Mar 2004)
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index cef4027249f3..b0b3aa8f5a1d 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1,7 +1,9 @@
-MD5 976dc147179cc0e2e54c219e32084c2c files/digest-palo-1.3_pre20040303 71
-MD5 7ee737710bef1fd5dd94d975eaf30721 files/digest-palo-1.2_pre20030630 71
-MD5 ad8b81577ffd8be90930cf8e02211313 files/palo.conf 214
MD5 eea605c64e6d9f10c11cf86eb1ea0a5f ChangeLog 1736
MD5 9eb3e7bb4ebac420842bd3e90dbf8726 metadata.xml 218
+MD5 97b2c344a0aa5c0aaa3a10fa4412ff11 palo-1.5_pre20040515.ebuild 940
MD5 a185017d3062d0b67cc8e14bf03a4539 palo-1.2_pre20030630.ebuild 939
MD5 97b2c344a0aa5c0aaa3a10fa4412ff11 palo-1.3_pre20040303.ebuild 940
+MD5 976dc147179cc0e2e54c219e32084c2c files/digest-palo-1.3_pre20040303 71
+MD5 7ee737710bef1fd5dd94d975eaf30721 files/digest-palo-1.2_pre20030630 71
+MD5 ad8b81577ffd8be90930cf8e02211313 files/palo.conf 214
+MD5 552150e078605c297602afb8d8d4c9fe files/digest-palo-1.5_pre20040515 72
diff --git a/sys-boot/palo/files/digest-palo-1.5_pre20040515 b/sys-boot/palo/files/digest-palo-1.5_pre20040515
new file mode 100644
index 000000000000..7a4138206f50
--- /dev/null
+++ b/sys-boot/palo/files/digest-palo-1.5_pre20040515
@@ -0,0 +1 @@
+MD5 6ba7ad22be32fc6593a7bfef3d0873a5 palo-1.5-CVS20040515.tar.gz 101107
diff --git a/sys-boot/palo/palo-1.5_pre20040515.ebuild b/sys-boot/palo/palo-1.5_pre20040515.ebuild
new file mode 100644
index 000000000000..4c7eb1022223
--- /dev/null
+++ b/sys-boot/palo/palo-1.5_pre20040515.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.5_pre20040515.ebuild,v 1.1 2004/05/15 22:46:37 gmsoft Exp $
+
+MY_V=${PV/_pre/-CVS}
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/"
+SRC_URI="http://ftp.parisc-linux.org/cvs/palo-${MY_V}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/bootloader"
+
+S=${WORKDIR}/palo
+
+src_compile() {
+ emake -C palo CFLAGS="${CFLAGS} -I../include -I../lib" || die
+ emake -C ipl CFLAGS="${CFLAGS} -I. -I../lib -I../include -fwritable-strings -mdisable-fpregs -Wall" || die
+ emake MACHINE=parisc iplboot
+ emake || die
+}
+
+src_install() {
+ dosbin palo/palo || die
+ doman palo.8
+ dohtml README.html
+ dodoc README palo.conf
+
+ insinto /etc
+ doins ${FILESDIR}/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+}