summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-auth/pambase/ChangeLog7
-rw-r--r--sys-auth/pambase/pambase-20120417-r2.ebuild8
2 files changed, 13 insertions, 2 deletions
diff --git a/sys-auth/pambase/ChangeLog b/sys-auth/pambase/ChangeLog
index dc2bb14545e8..9fd24e1152fa 100644
--- a/sys-auth/pambase/ChangeLog
+++ b/sys-auth/pambase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pambase
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.123 2013/08/03 07:48:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.124 2013/08/21 19:37:51 ssuominen Exp $
+
+ 21 Aug 2013; Samuli Suominen <ssuominen@gentoo.org>
+ pambase-20120417-r2.ebuild:
+ Warn people from enabling weird setup with USE="consolekit systemd" and
+ having 2 session trackers running at the same time wrt #478258
03 Aug 2013; Agostino Sarubbo <ago@gentoo.org> pambase-20120417-r2.ebuild:
Stable for sparc, wrt bug #454388
diff --git a/sys-auth/pambase/pambase-20120417-r2.ebuild b/sys-auth/pambase/pambase-20120417-r2.ebuild
index eb688b909083..daf1d8732254 100644
--- a/sys-auth/pambase/pambase-20120417-r2.ebuild
+++ b/sys-auth/pambase/pambase-20120417-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20120417-r2.ebuild,v 1.11 2013/08/03 07:48:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20120417-r2.ebuild,v 1.12 2013/08/21 19:37:51 ssuominen Exp $
EAPI=5
inherit eutils
@@ -103,4 +103,10 @@ pkg_postinst() {
elog "and that SHA512-hashed passwords will not work on earlier versions"
elog "of glibc or Linux-PAM."
fi
+
+ if use systemd && use consolekit; then
+ ewarn "You are enabling 2 session trackers, ConsoleKit and systemd-logind"
+ ewarn "at the same time. This is not recommended setup to have, please"
+ ewarn "consider disabling either USE=\"consolekit\" or USE=\"systemd\."
+ fi
}