summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/ophcrack/ChangeLog9
-rw-r--r--app-crypt/ophcrack/ophcrack-3.6.0.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-crypt/ophcrack/ChangeLog b/app-crypt/ophcrack/ChangeLog
index 5baf8ccc96db..373a88e9f119 100644
--- a/app-crypt/ophcrack/ChangeLog
+++ b/app-crypt/ophcrack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/ophcrack
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ChangeLog,v 1.36 2013/03/02 19:14:54 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ChangeLog,v 1.37 2014/02/24 05:47:36 patrick Exp $
+
+*ophcrack-3.6.0 (24 Feb 2014)
+
+ 24 Feb 2014; Patrick Lauer <patrick@gentoo.org> +ophcrack-3.6.0.ebuild:
+ Bump #487306
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> ophcrack-3.1.0-r2.ebuild,
ophcrack-3.3.0.ebuild, ophcrack-3.3.1.ebuild, ophcrack-3.4.0.ebuild:
diff --git a/app-crypt/ophcrack/ophcrack-3.6.0.ebuild b/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
new file mode 100644
index 000000000000..4b90372db9e0
--- /dev/null
+++ b/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.6.0.ebuild,v 1.1 2014/02/24 05:47:36 patrick Exp $
+
+EAPI="3"
+inherit eutils
+
+DESCRIPTION="A time-memory-trade-off-cracker"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="qt4 debug +tables"
+
+CDEPEND="dev-libs/openssl
+ net-libs/netwib
+ qt4? ( dev-qt/qtgui:4 )"
+DEPEND="app-arch/unzip
+ virtual/pkgconfig
+ ${CDEPEND}"
+RDEPEND="tables? ( app-crypt/ophcrack-tables )
+ ${CDEPEND}"
+
+src_configure() {
+
+ local myconf
+
+ myconf="$(use_enable qt4 gui)"
+ myconf="${myconf} $(use_enable debug)"
+
+ econf ${myconf} || die "Failed to compile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Installation failed."
+
+ cd "${S}"
+ newicon src/gui/pixmaps/os.xpm ophcrack.xpm
+ make_desktop_entry "${PN}" OphCrack ophcrack
+}