summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/wvstreams/ChangeLog6
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.4-gcc-4.3.patch23
-rw-r--r--net-libs/wvstreams/wvstreams-4.4.ebuild3
3 files changed, 30 insertions, 2 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index d81f6f79a027..b56615135659 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/wvstreams
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.122 2008/07/27 22:08:04 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.123 2008/08/31 11:05:09 hanno Exp $
+
+ 31 Aug 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/wvstreams-4.4-gcc-4.3.patch, wvstreams-4.4.ebuild:
+ gcc 4.3 fixes for 4.4 version (as 4.4.1 is masked).
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> wvstreams-4.4.ebuild,
wvstreams-4.4.1.ebuild:
diff --git a/net-libs/wvstreams/files/wvstreams-4.4-gcc-4.3.patch b/net-libs/wvstreams/files/wvstreams-4.4-gcc-4.3.patch
new file mode 100644
index 000000000000..c775ad210212
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.4-gcc-4.3.patch
@@ -0,0 +1,23 @@
+--- wvstreams-4.4.orig/include/uniconfkey.h
++++ wvstreams-4.4/include/uniconfkey.h
+@@ -9,7 +9,7 @@
+
+ #include "wvstring.h"
+ #include "wvlinklist.h"
+-
++#include <climits>
+
+ // The Python headers try to #define ANY as void. If we're building Python
+ // wrappers, get rid of that.
+--- wvstreams-4.4.orig/include/wvserialize.h
++++ wvstreams-4.4/include/wvserialize.h
+@@ -349,7 +349,7 @@
+ * except as the last character.
+ */
+ template <>
+-extern WvString _wv_deserialize<WvString>(WvBuf &buf);
++WvString _wv_deserialize<WvString>(WvBuf &buf);
+
+
+ /** Deserialize a WvBuf. */
+
diff --git a/net-libs/wvstreams/wvstreams-4.4.ebuild b/net-libs/wvstreams/wvstreams-4.4.ebuild
index 52b8fb7692bc..5e916ba847fa 100644
--- a/net-libs/wvstreams/wvstreams-4.4.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.4.ebuild,v 1.11 2008/07/27 22:08:04 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.4.ebuild,v 1.12 2008/08/31 11:05:09 hanno Exp $
EAPI=1
@@ -45,6 +45,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-sigaction.patch"
epatch "${FILESDIR}/${P}-wvconfemu.patch"
epatch "${FILESDIR}/${P}-valgrind.patch"
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
epatch "${FILESDIR}/${P}-external-xplc.patch"
local XPLC_VER=`best_version dev-libs/xplc`