summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/mediawiki/ChangeLog7
-rw-r--r--www-apps/mediawiki/files/postinstall-1.5-en.txt72
-rw-r--r--www-apps/mediawiki/mediawiki-1.11.1.ebuild5
-rw-r--r--www-apps/mediawiki/mediawiki-1.8.5.ebuild164
4 files changed, 9 insertions, 239 deletions
diff --git a/www-apps/mediawiki/ChangeLog b/www-apps/mediawiki/ChangeLog
index 836d42602c1e..42ef0e174403 100644
--- a/www-apps/mediawiki/ChangeLog
+++ b/www-apps/mediawiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mediawiki
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/ChangeLog,v 1.97 2008/02/25 15:09:22 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/ChangeLog,v 1.98 2008/02/26 07:11:16 wrobel Exp $
+
+ 26 Feb 2008; Gunnar Wrobel <wrobel@gentoo.org>
+ -files/postinstall-1.5-en.txt, -mediawiki-1.8.5.ebuild,
+ mediawiki-1.11.1.ebuild:
+ Remove vulnerable version (sec issue #207757) and fix dependencies (#208584).
25 Feb 2008; Steve Dibb <beandog@gentoo.org> mediawiki-1.11.1.ebuild:
amd64 stable, security bug 207757
diff --git a/www-apps/mediawiki/files/postinstall-1.5-en.txt b/www-apps/mediawiki/files/postinstall-1.5-en.txt
deleted file mode 100644
index bf75ab72a446..000000000000
--- a/www-apps/mediawiki/files/postinstall-1.5-en.txt
+++ /dev/null
@@ -1,72 +0,0 @@
-
-Completing setup:
-
-To complete installation cd into the MediaWiki install location, but
-make sure to start mysql first with:
-
-$ /etc/init.d/mysql start
-
-$ cd /var/www/localhost/htdocs/mediawiki/
-
-The host directory, localhost, may change depending on your installation.
-
-Then temporarily make the MediaWiki /config directory writable
-to the user the web server is running as. The quickest way is
-to make the directory world writable. For example:
-
-$ chmod a+w config
-
-Then access it, for example:
-
-lynx http://localhost/mediawiki/config/
-
-After setup move the newly created LocalSettings.php from the config/
-directory to the main mediawiki directory, for example:
-
-$ mv config/LocalSettings.php .
-
- Remember to restore safe permissions to the MediaWiki config/ and
- LocalSettings.php (which contains clear-text passwords).
- chmod a-w config
- chmod ug=r,o= LocalSettings.php
- chown root:apache LocalSettings.php
-
-After these steps MediaWiki should be accesable at
-http://localhost/mediawiki/
-
-Enabling Optional Features:
-
-If you wish to enable image uploads then you must manually edit the
-LocalSettings.php file to uncomment the \$wgEnableUploads line.
-If MediaWiki was built with the imagemagick USE-flag the directory
-permissions are correct, otherwise you must install ImageMagick and
-also adjust permissions on the images directory to allow the server
-to write. For example:
-
-$ chown apache:apache /var/www/localhost/htdocs/mediawiki/images
-
-Math Support:
-
-If you wish to enable the math support then you must manually edit"
-the LocalSettings.php file to uncomment the \$wgUseTeX line.
-MediaWiki must have been built with the math USE-flag enabled or the
-necessary support executable will not be present.
-You may also have to execute
-
-$ texconfig dvips printcmd -
-
-if you have not configured tetex before.
-
-
-Things you need to have on the server:
-- SQL database of your choice.
-- dev-php/PEAR-Mail for external smtp server.
-
-These are not installed as dependencies since it is possible to run the database
-and other services on other machines.
-
-It is very important that you follow all the major versions upgrade
-instructions from the mediawiki.org web page,
-http://www.mediawiki.org/wiki/Manual:Upgrading
-Do not, I repeat, do not assume that we can upgrade from version to version just like this. Make backups before upgrading.
-
diff --git a/www-apps/mediawiki/mediawiki-1.11.1.ebuild b/www-apps/mediawiki/mediawiki-1.11.1.ebuild
index 7d7880130cf9..74ab5e3fa7ba 100644
--- a/www-apps/mediawiki/mediawiki-1.11.1.ebuild
+++ b/www-apps/mediawiki/mediawiki-1.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.11.1.ebuild,v 1.5 2008/02/25 15:09:22 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.11.1.ebuild,v 1.6 2008/02/26 07:11:16 wrobel Exp $
EAPI="1"
inherit webapp depend.php versionator eutils
@@ -24,7 +24,8 @@ RDEPEND="${DEPEND}
RESTRICT="test"
-need_php5
+need_httpd_cgi
+need_php_httpd
pkg_setup() {
webapp_pkg_setup
diff --git a/www-apps/mediawiki/mediawiki-1.8.5.ebuild b/www-apps/mediawiki/mediawiki-1.8.5.ebuild
deleted file mode 100644
index 80e3958272ac..000000000000
--- a/www-apps/mediawiki/mediawiki-1.8.5.ebuild
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.8.5.ebuild,v 1.6 2007/11/26 12:00:23 tchiwam Exp $
-
-inherit webapp depend.php versionator
-
-MY_BRANCH=$(get_version_component_range 1-2)
-
-DESCRIPTION="The MediaWiki wiki web application (as used on wikipedia.org)"
-HOMEPAGE="http://www.mediawiki.org"
-SRC_URI="http://download.wikimedia.org/mediawiki/${MY_BRANCH}/${P/.0_/}.tar.gz"
-RESTRICT="mirror"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="imagemagick math mysql postgres restrict"
-
-S="${WORKDIR}/${P/.0_/}"
-
-DEPEND="math? ( >=dev-lang/ocaml-3.0.6 )"
-
-RDEPEND="
- >=dev-lang/php-5.1.4-r6
- math? (
- virtual/tetex
- virtual/ghostscript
- media-gfx/imagemagick
- )
- imagemagick? (
- media-gfx/imagemagick
- )
-"
-
-need_php
-
-pkg_setup() {
- webapp_pkg_setup
- require_php_with_use pcre session
- if use mysql ; then
- require_php_with_use mysql
- fi
- if use postgres ; then
- require_php_with_use postgres
- fi
- require_gd
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/jobindexlength-mysql.patch"
- if use restrict ; then
- epatch "${FILESDIR}/access_restrict.patch"
- fi
-}
-
-src_compile() {
- if use math; then
- einfo "Compiling math support"
- cd math || die
- emake || die
- else
- einfo "No math support enabled. Skipping."
- fi
-
- # TODO: think about includes/zhtable/ support
-}
-
-src_install() {
- webapp_src_preinst
-
- # copy the app's main files excluding math support, docs, and tests
- local DIRS=(
- "bin"
- "config"
- "extensions"
- "images"
- "includes"
- "includes/api"
- "includes/cbt"
- "includes/normal"
- "includes/templates"
- "includes/zhtable"
- "languages"
- "languages/classes"
- "languages/messages"
- "locale"
- "maintenance"
- "maintenance/archives"
- "maintenance/postgres"
- "maintenance/dtrace"
- "maintenance/mysql5"
- "maintenance/storage"
- "serialized"
- "skins"
- "skins/chick"
- "skins/common"
- "skins/common/images"
- "skins/common/images/icons"
- "skins/disabled"
- "skins/htmldump"
- "skins/monobook"
- "skins/myskin"
- "skins/simple"
- )
- insinto ${MY_HTDOCSDIR}
- doins *.php *.inc *.phtml
- for DIR in ${DIRS[*]}; do
- dodir ${MY_HTDOCSDIR}/${DIR}
- insinto ${MY_HTDOCSDIR}/${DIR}
- doins ${DIR}/*
- test -f ${DIR}/.htaccess && doins ${DIR}/.htaccess
- done
-
- # installing some docs
- local DOCS=(
- "AdminSettings.sample"
- "COPYING"
- "FAQ"
- "HISTORY"
- "INSTALL"
- "README"
- "RELEASE-NOTES"
- "UPGRADE"
- )
- for DOC in ${DOCS[*]}; do
- dodoc "${DOC}"
- rm -f "${DOC}"
- done
- dodoc docs/*.txt
- rm -f docs/*.txt
-
- docinto php-memcached
- dodoc docs/php-memcached/*
-
- # If imagemagick is enabled then setup for image upload.
- # We ensure the directory is prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use imagemagick; then
- webapp_serverowned ${MY_HTDOCSDIR}/images
- fi
-
- # If we've enabled math USE-flag, install math support.
- # We ensure the directories are prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use math; then
- einfo "Installing math support"
- dodir ${MY_HTDOCSDIR}/math
- exeinto ${MY_HTDOCSDIR}/math
- doexe math/texvc
-
- # Docs
- docinto math
- dodoc math/README math/TODO
-
- # Working directories. Server writeable.
- dodir ${MY_HTDOCSDIR}/images/math
- webapp_serverowned ${MY_HTDOCSDIR}/images/math
- dodir ${MY_HTDOCSDIR}/images/tmp
- webapp_serverowned ${MY_HTDOCSDIR}/images/tmp
- fi
-
- webapp_postinst_txt en "${FILESDIR}/postinstall-1.5-en.txt"
- webapp_src_install
-}