summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/claws-mail/ChangeLog95
-rw-r--r--mail-client/claws-mail/claws-mail-3.7.2.ebuild179
2 files changed, 273 insertions, 1 deletions
diff --git a/mail-client/claws-mail/ChangeLog b/mail-client/claws-mail/ChangeLog
index f586c2d74552..c7cf63495237 100644
--- a/mail-client/claws-mail/ChangeLog
+++ b/mail-client/claws-mail/ChangeLog
@@ -1,6 +1,99 @@
# ChangeLog for mail-client/claws-mail
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.123 2009/06/29 09:49:42 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.124 2009/07/06 11:53:21 fauli Exp $
+
+*claws-mail-3.7.2 (06 Jul 2009)
+
+ 06 Jul 2009; Christian Faulhammer <fauli@gentoo.org>
+ +claws-mail-3.7.2.ebuild:
+
+ version bump:
+ New in this release:
+
+ Default Cc, Bcc and Reply-To options have been added to Folder
+ Properties.
+
+ MIME parts that lack an end boundary are now handled, (even though
+ they're INVALID!).
+
+ A 'Metadata handling' option has been added to the Miscellaneous
+ options page. The options are 'safer' or 'faster'. 'faster' is
+ Claws' original behaviour. 'safer' prevents data loss on system
+ crashes where the filesystem is of a 'not-so-robust' variety, e.g.
+ xfs. If in doubt, use 'safer'. This option defaults to 'safer'.
+
+ Face and X-Face previews have been added to the Custom Header
+ Configuration dialogue in Account preferences.
+
+ An option has been added to the Receive page of IMAP account
+ preferences, Move deleted mails to trash and expunge immediately.
+ This option is on by default to avoid changing the existing
+ behaviour. Turning it off prevents automatic expunging.
+ Also, 'Tools/Expunge' and 'View/Hide deleted messages' menu items
+ have been added to main toolbar.
+
+ Support for clickable gopher:// links has been added.
+
+ In the Compose window a warning dialogue is raised if attachments
+ that have been added no longer exist on the filesystem at the time
+ of sending.
+
+ Buttons to clear header lines in the Compose window have been
+ added.
+
+ GnuTLS compatibility mode is now used, this avoids problems with
+ servers that don't comply 100% with the spec, but still exist.
+
+ tools/csv2addressbook.pl
+ thunderbird import for version 2.0.0.21 has been added.
+
+ Added Indonesian, Japanese, Portuguese, and Slovakian translations.
+
+ Updated Bulgarian, Brazilian Portuguese, Czech, Finnish, French,
+ German, Hungarian, Italian, Russian, and Spanish translations.
+
+ Bug fixes:
+ o bug 1735, 'Change To: and Newsgroups: recipient field
+ according account type'
+ o bug 1866, 'Claws should make use of the IMAP 'deleted'
+ flag'
+ o bug 1872, 'A: Cc: CCi: selector should default on same as
+ preceding contact'
+ o bug 1878, 'Processing rules for folders with brackets
+ aren't saved'
+ o bug 1883, 'Message processing fails to act on Newsgroups:
+ field'
+ o bug 1895, '(imap) cache issues when cache dir is on a
+ different mountpoint than tempdir'
+ o bug 1904, 'build mechanism looks for 'enchant.h' in a wrong
+ place'
+ o bug 1913, 'Allow to remove phantom messages from the cache'
+ o bug 1914, 'Crash reading corrupted tags file'
+ o bug 1915, 'Mails signed with smime.p7s display both signed
+ and attachment icon.'
+ o bug 1935, 'problems with very long filtering actions'
+ o bug 1940, 'Doesn't open links in user's default browser'
+ o Debian bug 531052: 'Message-ID header does not conform to
+ RFC-2822'
+ o Redhat bug 486422, Ubuntu bug 486422: Don't ask for IMAP
+ password when using GSSAPI auth
+ o fix old print interface
+ o fix wrong mime message printed out multiple times
+ o fix empty spell checker menu when there are no suggestions
+ o fix 'Wrong word replaced in 'Subject:' when spell-checking
+ correction used'
+ o fix internal headers visible in queue/sent
+ o don't use un-sensitive checkboxes in Privacy tab when
+ privacy system in None
+ o [IMAP] fix tag update when all tags are removed by another
+ client
+ o fix saving of UTF-16 files
+ o clear progressbar in the statusbar on 'Cancel'
+ o TrayIcon plugin: respect the 'empty trash on exit' option
+ o fix error messages in templates, and fix their checking
+ o win32: fix subject prefix length
+ o win32: fix exit status fetch
+ o win32: fix most focusing issues
29 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
claws-mail-3.7.1.ebuild:
diff --git a/mail-client/claws-mail/claws-mail-3.7.2.ebuild b/mail-client/claws-mail/claws-mail-3.7.2.ebuild
new file mode 100644
index 000000000000..bfb289cd1407
--- /dev/null
+++ b/mail-client/claws-mail/claws-mail-3.7.2.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-3.7.2.ebuild,v 1.1 2009/07/06 11:53:21 fauli Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="http://www.claws-mail.org/"
+
+SRC_URI="mirror://sourceforge/sylpheed-claws/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bogofilter crypt dbus dillo doc gnome gnutls imap ipv6 kde ldap nntp pda
+session smime spamassassin spell ssl startup-notification xface"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.6
+ pda? ( >=app-pda/jpilot-0.99 )
+ ssl? ( net-libs/gnutls )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ dillo? ( www-client/dillo )
+ spell? ( >=app-text/enchant-1.0.0 )
+ kde? ( kde-base/kdelibs )
+ imap? ( >=net-libs/libetpan-0.57 )
+ nntp? ( >=net-libs/libetpan-0.57 )
+ gnome? ( >=gnome-base/libgnomeprintui-2.2 )
+ gnutls? ( net-libs/gnutls )
+ startup-notification? ( x11-libs/startup-notification )
+ bogofilter? ( mail-filter/bogofilter )
+ session? ( x11-libs/libSM
+ x11-libs/libICE )
+ smime? ( >=app-crypt/gpgme-0.4.5 )"
+
+DEPEND="${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+PLUGIN_NAMES="acpi-notifier archive att-remover attachwarner cachesaver fetchinfo gtkhtml mailmbox newmail notification perl rssyl spam_report tnef_parse vcalendar"
+
+src_compile() {
+ local myconf="--disable-libetpan --disable-gnutls"
+
+ # libetpan is needed if user wants nntp or imap functionality
+ use imap && myconf="${myconf} --enable-libetpan"
+ use nntp && myconf="${myconf} --enable-libetpan"
+ # The usage of openssl was discarded once and USE=ssl is mapped to
+ # USE=gnutls now. Maybe USE=ssl can fade out sometime
+ use ssl && myconf="${myconf} --enable-gnutls"
+ use gnutls && myconf="${myconf} --enable-gnutls"
+
+ econf \
+ $(use_enable gnome gnomeprint) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable dbus) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell enchant) \
+ $(use_enable xface compface) \
+ $(use_enable doc manual) \
+ $(use_enable startup-notification) \
+ $(use_enable session libsm) \
+ $(use_enable crypt pgpmime-plugin) \
+ $(use_enable crypt pgpinline-plugin) \
+ $(use_enable crypt pgpcore-plugin) \
+ $(use_enable dillo dillo-viewer-plugin) \
+ $(use_enable spamassassin spamassassin-plugin) \
+ $(use_enable bogofilter bogofilter-plugin) \
+ $(use_enable smime smime-plugin) \
+ --enable-trayicon-plugin \
+ --disable-maemo ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins ${PN}.png || die
+ local res resdir
+ for res in 64x64 128x128 ; do
+ resdir="/usr/share/icons/hicolor/${res}/apps"
+ insinto ${resdir}
+ newins ${PN}-${res}.png ${PN}.png || die
+ done
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+ docinto tools
+ dodoc tools/README*
+
+ insinto /usr/share/applications
+ doins ${PN}.desktop
+
+ einfo "Installing extra tools"
+ cd "${S}"/tools
+ exeinto /usr/$(get_libdir)/${PN}/tools
+ doexe *.pl *.py *.conf *.sh || die
+ doexe tb2claws-mail update-po uudec uuooffice || die
+
+ if use kde; then
+ einfo "Installing kde service scripts"
+ local kdeprefix="$(kde-config --prefix)"
+ local servicescript="${PN}-kdeservicemenu.pl"
+ local desktopfile="${PN}-attach-files.desktop"
+ cd "${S}"/tools/kdeservicemenu
+ sed -i -e "s:SCRIPT_PATH:${kdeprefix}/bin/${servicescript}:g" \
+ ${desktopfile}.template
+ dodir /usr/share/apps/konqueror/servicemenus
+ insopts -m 0644
+ insinto /usr/share/apps/konqueror/servicemenus
+ newins ${desktopfile}.template ${desktopfile} || die
+ dodir ${kdeprefix}/bin
+ insopts -m 755
+ exeinto ${kdeprefix}/bin
+ doexe ${servicescript} || die
+ fi
+
+ # kill useless plugin files
+ rm -f "${D}"/usr/lib*/${PN}/plugins/*.{la,a}
+}
+
+pkg_postinst() {
+ gtk-update-icon-cache -f -t "${ROOT}"/usr/share/icons/hicolor
+
+ UPDATE_PLUGINS=""
+ RENAME_PLUGINS=""
+ for x in ${PLUGIN_NAMES}; do
+ has_version mail-client/${PN}-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+ has_version mail-client/sylpheed-claws-$x && RENAME_PLUGINS="${RENAME_PLUGINS} $x"
+ done
+ if [ -n "${RENAME_PLUGINS}" ]; then
+ elog
+ elog "The following sylpheed-claws plugins were found on your system:"
+ elog
+ for x in ${RENAME_PLUGINS}; do
+ elog " mail-client/sylpheed-claws-$x"
+ done
+ elog
+ elog "If you want to continue using those you need to merge their "
+ elog "renamed counterparts:"
+ elog
+ for x in ${RENAME_PLUGINS}; do
+ elog " mail-client/${PN}-$x"
+ done
+ elog
+ fi
+ if [ -n "${UPDATE_PLUGINS}" ]; then
+ elog
+ elog "You have to re-emerge or update the following plugins:"
+ elog
+ for x in ${UPDATE_PLUGINS}; do
+ elog " mail-client/${PN}-$x"
+ done
+ elog
+ fi
+ if [ -n "${RENAME_PLUGINS}${UPDATE_PLUGINS}" ]; then
+ elog
+ elog "You can use"
+ elog " /bin/bash ${FILESDIR}/plugins-rebuild.sh"
+ elog "to automatically handle this."
+ elog
+ epause 5
+ ebeep 3
+ fi
+}
+
+pkg_postrm() {
+ gtk-update-icon-cache -f -t "${ROOT}"/usr/share/icons/hicolor
+}