summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/kde-meta.eclass22
1 files changed, 21 insertions, 1 deletions
diff --git a/eclass/kde-meta.eclass b/eclass/kde-meta.eclass
index 7b3363dc69f4..c11b3531c2da 100644
--- a/eclass/kde-meta.eclass
+++ b/eclass/kde-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.57 2005/11/16 12:54:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.58 2005/11/16 14:13:39 flameeyes Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
# Simone Gotti <motaboy@gentoo.org>
@@ -392,6 +392,26 @@ function kde-meta_src_compile() {
# make sure games are not installed with setgid bit, as it is a security risk.
myconf="$myconf --disable-setgid"
fi
+
+ # confcache support. valid only for my (danarmak's) port of stuart's confcache to portage .51,
+ # not for stuart's orig version or ferringb's ebuild-daemon version.
+ # this could be replaced by just using econf, but i don't want to make that change in kde.eclass
+ # just yet. This way is more modular.
+ callsections="$*"
+ [ -z "$callsections" -o "$callsections" == "all" ] && callsections="myconf configure make"
+ for section in $callsections; do
+ debug-print "$FUNCNAME: now in section $section"
+ if [ "$section" == "configure" ]; then
+ # don't log makefile.common stuff in confcache
+ [ ! -f "Makefile.in" ] && make -f admin/Makefile.common
+ [ "`type -t confcache_start`" == "function" ] && confcache_start
+ myconf="$EXTRA_ECONF $myconf"
+ fi
+ kde_src_compile $section
+ if [ "$section" == "configure" ]; then
+ [ "`type -t confcache_stop`" == "function" ] && confcache_stop
+ fi
+ done
}
function kde-meta_src_install() {