summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/wine/wine-20050211.ebuild28
-rw-r--r--app-emulation/wine/wine-20050310-r1.ebuild28
-rw-r--r--app-emulation/wine/wine-20050419.ebuild28
-rw-r--r--app-emulation/wine/wine-20050524.ebuild28
4 files changed, 60 insertions, 52 deletions
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index 6a46940df069..52c99085d673 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.11 2005/06/17 02:06:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.12 2005/07/10 03:59:17 vapier Exp $
inherit eutils flag-o-matic
@@ -39,12 +39,20 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 && ! has_m32 ; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+ if has_multilib_profile ; then
+ export ABI=x86
+ else
+ append-flags -m32
+ append-ldflags -m32
+ fi
fi
}
@@ -85,12 +93,6 @@ src_compile() {
strip-flags
use lcms && append-flags -I"${ROOT}"/usr/include/lcms
- if use amd64 ; then
- [[ -n $(get_abi_var) ]] \
- && export ABI=x86 \
- || append-flags -m32
- fi
-
if ! built_with_use app-text/docbook-sgml-utils tetex ; then
export DB2PDF=true
export DB2PS=true
diff --git a/app-emulation/wine/wine-20050310-r1.ebuild b/app-emulation/wine/wine-20050310-r1.ebuild
index ed9ca21e0297..c2933f5f5354 100644
--- a/app-emulation/wine/wine-20050310-r1.ebuild
+++ b/app-emulation/wine/wine-20050310-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.4 2005/06/17 02:06:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.5 2005/07/10 03:59:17 vapier Exp $
inherit eutils flag-o-matic
@@ -39,12 +39,20 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 && ! has_m32 ; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+ if has_multilib_profile ; then
+ export ABI=x86
+ else
+ append-flags -m32
+ append-ldflags -m32
+ fi
fi
}
@@ -84,12 +92,6 @@ src_compile() {
strip-flags
use lcms && append-flags -I"${ROOT}"/usr/include/lcms
- if use amd64 ; then
- [[ -n $(get_abi_var) ]] \
- && export ABI=x86 \
- || append-flags -m32
- fi
-
if ! built_with_use app-text/docbook-sgml-utils tetex ; then
export DB2PDF=true
export DB2PS=true
diff --git a/app-emulation/wine/wine-20050419.ebuild b/app-emulation/wine/wine-20050419.ebuild
index 7b626b023325..22707855acb3 100644
--- a/app-emulation/wine/wine-20050419.ebuild
+++ b/app-emulation/wine/wine-20050419.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.6 2005/06/17 02:06:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.7 2005/07/10 03:59:17 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -39,12 +39,20 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 && ! has_m32 ; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+ if has_multilib_profile ; then
+ export ABI=x86
+ else
+ append-flags -m32
+ append-ldflags -m32
+ fi
fi
}
@@ -83,12 +91,6 @@ src_compile() {
strip-flags
use lcms && append-flags -I"${ROOT}"/usr/include/lcms
- if use amd64 ; then
- [[ -n $(get_abi_var) ]] \
- && export ABI=x86 \
- || append-flags -m32
- fi
-
if ! built_with_use app-text/docbook-sgml-utils tetex ; then
export DB2PDF=true
export DB2PS=true
diff --git a/app-emulation/wine/wine-20050524.ebuild b/app-emulation/wine/wine-20050524.ebuild
index fd7e50819084..d059c0103e22 100644
--- a/app-emulation/wine/wine-20050524.ebuild
+++ b/app-emulation/wine/wine-20050524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.4 2005/06/17 02:06:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.5 2005/07/10 03:59:17 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -39,12 +39,20 @@ DEPEND="${RDEPEND}
# doc? ( app-text/docbook-sgml-utils app-text/jadetex )
pkg_setup() {
- if use amd64 && ! has_m32 ; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+ if has_multilib_profile ; then
+ export ABI=x86
+ else
+ append-flags -m32
+ append-ldflags -m32
+ fi
fi
}
@@ -83,12 +91,6 @@ src_compile() {
strip-flags
use lcms && append-flags -I"${ROOT}"/usr/include/lcms
- if use amd64 ; then
- [[ -n $(get_abi_var) ]] \
- && export ABI=x86 \
- || append-flags -m32
- fi
-
# if ! built_with_use app-text/docbook-sgml-utils tetex ; then
# export DB2PDF=true
# export DB2PS=true