summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/audacious-plugins/ChangeLog14
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha1.ebuild104
-rw-r--r--media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.0_alpha13
3 files changed, 119 insertions, 2 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index ca8fd9fd6114..296c25dc509f 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-plugins/audacious-plugins
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.25 2006/12/20 18:18:09 gustavoz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.26 2007/01/05 10:29:43 chainsaw Exp $
+
+*audacious-plugins-1.3.0_alpha1 (05 Jan 2007)
+
+ 05 Jan 2007; Tony Vroon <chainsaw@gentoo.org>
+ +audacious-plugins-1.3.0_alpha1.ebuild:
+ Developer release of the new 1.3 series. File bugs upstream at
+ http://bugs-meta.atheme.org/ and not in the Gentoo bug tracker. Major
+ changes in playlist handling and file scanning. Add missing dependency on
+ libsdl for paranormal visual plugin, closes bug #154840, with thanks to
+ Sascha Geschwandtner <s.geschwandtner@gmx.de>.
20 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org>
audacious-plugins-1.2.5.ebuild:
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha1.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha1.ebuild
new file mode 100644
index 000000000000..d1f2ec188456
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.3.0_alpha1.ebuild,v 1.1 2007/01/05 10:29:43 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac alsa arts chardet esd flac jack lirc modplug mp3 musepack nls oss sid sndfile timidity vorbis wavpack wma pulseaudio"
+
+RDEPEND="app-arch/unzip
+ dev-libs/libxml2
+ net-misc/curl
+ >=media-sound/audacious-1.3.0_alpha1
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=dev-cpp/libbinio-1.4
+ >=media-libs/libsdl-1.2.5
+ media-libs/taglib
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ || ( ~media-libs/flac-1.1.2
+ ~media-libs/flac-1.1.3 )
+ )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-libs/libsamplerate
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( media-libs/libmpcdec )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( media-libs/libsndfile )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ wavpack? ( >=media-sound/wavpack-4.31 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ echo
+ ewarn "MP3 support is now optional, you may want to enable the mp3 USE-flag"
+ echo
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ $(use_enable vorbis) \
+ $(use_enable esd) \
+ $(use_enable mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable flac) \
+ $(use_enable aac) \
+ $(use_enable modplug) \
+ $(use_enable lirc) \
+ $(use_enable sndfile) \
+ $(use_enable wma) \
+ $(use_enable sid) \
+ $(use_enable musepack) \
+ $(use_enable jack) \
+ $(use_enable timidity) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable chardet) \
+ $(use_enable wavpack) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS
+}
+
+pkg_postinst() {
+ mp3_warning
+}
diff --git a/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.0_alpha1 b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.0_alpha1
new file mode 100644
index 000000000000..9e6e445b6fb6
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.3.0_alpha1
@@ -0,0 +1,3 @@
+MD5 2293758501331e4ad0c4cd15cd29148a audacious-plugins-1.3.0-alpha1.tgz 2537831
+RMD160 78b7f5db136c369a217317d91b82a7307b02cf77 audacious-plugins-1.3.0-alpha1.tgz 2537831
+SHA256 b20eea79f0aa16cc7c9c181e3ca0d5578058558aa97b6c2c57abe3e4d544a627 audacious-plugins-1.3.0-alpha1.tgz 2537831